Playback Issues - Audio/Video & Power

Help with audio & video playback issues, TV display type recognition & compatibility, HDCP messages, troubleshooting playback errors, advertisements, and resolving power issues.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Highlighted
Level 8

Possible Display Solution-HDCP Handshake

Problem: Using LG 4K TV and my Yamaha receiver, I would have to power off and on my ROKU Ultra to get a picture display. Possible solution: On my LG 4K TV, I just turned off my HDMI ULTRA HD Deep color settings (found under Picture- Additional settings) and no more handshake issues with my Yamaha receiver. I can now turn the TV and my Yamaha receiver off and on and the ROKU display comes up every time.
0 Kudos
5 Replies
Highlighted
Level 9

Re: Possible Display Solution-HDCP Handshake


@Wlund wrote:
Problem: Using LG 4K TV and my Yamaha receiver, I would have to power off and on my ROKU Ultra to get a picture display. Possible solution: On my LG 4K TV, I just turned off my HDMI ULTRA HD Deep color settings (found under Picture- Additional settings) and no more handshake issues with my Yamaha receiver. I can now turn the TV and my Yamaha receiver off and on and the ROKU display comes up every time.

Wlund: Respectfully, that's not a solution.

First off, you should not have to power reset your TV & receiver (or anything else) in order for ROKU to establish an HDMI connection. Prior to Software Release 9.2.0, it was only necessary to select the Roku input and press the Home button on the Roku remote in order for Roku to wake up, establish an HDMI connection and display the home screen.

Secondly, I suspect you will find this procedure will work as you describe only intermittently. Without changing any settings, your described procedure often works for me (but, not always). Under software release 9.2.0, the only sure fire way to get the HDMI connection correctly established is to power reset the Roku device (a Roku Ultra, in my case).

Unfortunately, this problem will persist for as long as Roku continues to pretend Software Release 9.2.0 is not the cause of the problem. That might be forever.

0 Kudos
Highlighted
Level 7

Re: Possible Display Solution-HDCP Handshake

I’m having the exact same problem since latest (Roku) software update to 9.2 on my LG tv and Denon receiver.  I first noticed problem with an Ulta 2018 and replaced it with an Ultra 2019.  Same issue.  As a temp measure I’ve connected the HDMI cable from the (Roku) directly to the tv and use an optical cable to bring the sound from the tv to the receiver.  This seems to be working so far for 4K, HDR, etc.  otherwise, I was having to unplug the HDMI cable and power supply cables from the Ultra and replug before the Ultra and reserves would permit signals to pass, picture and sound to work, etc.  

0 Kudos
Highlighted
Level 19

Re: Possible Display Solution-HDCP Handshake

Hi there,

Thanks for the patience while we've continued working to address the issues we heard reported. We have just made a new update available on supported devices, by manually checking for a system update, which should help address display issues. 

Please visit Settings>System>System update>Check now to perform a system update and install the latest update 9.2 build 4806 on supported devices. 

Then, make sure to change your current selection in Settings>Display type back to 'Auto detect'. 

A few important notes:

- If you are using a 4K TV and/or AVR, you'll need to ensure that all settings are configured/enabled to support HDMI 2.0/HDCP 2.2, HDR (such as Deep Color on LG TVs, or HDR+ on Samsung, HDR mode on Sony TVs, etc.) and HDCP 2.2 certified HDMI cables. You may also need to review the settings on your AVR to ensure that certain advanced features are enabled for 4K 60 Hz / 4K 60Hz HDR display type detection, and/or try adjusting HDR subsampling settings. 

- If you have enabled/modified any advanced Roku display settings during troubleshooting, such as 'Auto-detect display refresh rate' or changed HDR subsampling settings, try turning these off or changing them back to default settings. 

- You might need to power cycle your device and/or TV/AVR in order to help clear up any unresolved issues. You might also try removing and reinserting any HDMI cables connecting your devices. 

Please keep us posted from there! 

 

Thanks,

Tanner

Highlighted
Level 7

Re: Possible Display Solution-HDCP Handshake

Tanner, 

I have a Denon AVR-X4400H AND VIZIO P65-E1. The ROKU is directly connected to my AVR. 

The only solution right now seems to be rebooting the Roku. 

Hope there is a fix for this issue soon.

 

Will

babylon5fan


@RokuTannerD wrote:

Hi there,

Thanks for the patience while we've continued working to address the issues we heard reported. We have just made a new update available on supported devices, by manually checking for a system update, which should help address display issues. 

Please visit Settings>System>System update>Check now to perform a system update and install the latest update 9.2 build 4806 on supported devices. 

Then, make sure to change your current selection in Settings>Display type back to 'Auto detect'. 

A few important notes:

- If you are using a 4K TV and/or AVR, you'll need to ensure that all settings are configured/enabled to support HDMI 2.0/HDCP 2.2, HDR (such as Deep Color on LG TVs, or HDR+ on Samsung, HDR mode on Sony TVs, etc.) and HDCP 2.2 certified HDMI cables. You may also need to review the settings on your AVR to ensure that certain advanced features are enabled for 4K 60 Hz / 4K 60Hz HDR display type detection, and/or try adjusting HDR subsampling settings. 

- If you have enabled/modified any advanced Roku display settings during troubleshooting, such as 'Auto-detect display refresh rate' or changed HDR subsampling settings, try turning these off or changing them back to default settings. 

- You might need to power cycle your device and/or TV/AVR in order to help clear up any unresolved issues. You might also try removing and reinserting any HDMI cables connecting your devices. 

Please keep us posted from there! 

 

Thanks,

Tanner


 

-B


Roku with
Denon AVR-X4400H AND VIZIO P65-E1
Polk PSW505 and FOCAL Cube subs, Polk RTA 11TL towers in 7.2.4 Speaker Setup
FiOS One Gbps UP/DOWN internet service only.
0 Kudos
Highlighted
Level 7

Re: Possible Display Solution-HDCP Handshake

Just returned from out of town and followed RokuTanner’s recommendations. It appears that updating to update 9.2 build 4806 has solved the handshake problem. My Ultra was on update 9.2 build 4750, from late November when the problem started. I went into settings and asked it to search for any updates and that’s when the 4806 version appeared. I had thought updates were pretty automatic but apparently not. 
Roku’s timely assistance and solution are very much appreciated.  

0 Kudos