Playback Issues - Audio/Video & Power

Help with audio & video playback issues, TV display type recognition & compatibility, HDCP messages, troubleshooting playback errors, advertisements, and resolving power issues.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
JamieB
Level 7

OS 10.5 has broken my Roku Ultra again!!

Ok, so my Roku Ultra updated a couple of weeks back to OS 10.5 and that's when the problems started. Eventually when I ran software update I was able to downgrade to 10.0 and all was working well again and I had my Roku Ultra back and functioning. 

A few days later and the unit auto-updated to 10.5 again and the thing is useless. Apps will take forever to load, may or may not play videos and if it gets confused enough the entire unit will just lock up and become unresponsive. 

How can I go back to OS 10 and disable any auto updates? My unit has now more or less become useless in it's current state. If I manage to get one app going the minute I try to go back to home and another app it just freaks out. The channel selected is no longer highlighted as well. 

1 REPLY 1\
RokuDanny-R
Roku Employee
Roku Employee

Re: OS 10.5 has broken my Roku Ultra again!!

@JamieB

Thanks for the post.

Can you please specify the issue you are experiencing:
-Roku device model, serial number, device ID, and software OS/version (these can all be found in Settings > System > About)
-does this issue occur on a specific channel? if so, what channel and what version/build is the channel (this can be found be selecting the channel on the Home screen and pressing the * button)
-tracker ID when this issue occurs (when you see this issue occur, press the Home button 5 times, followed by the Back button 5 times)
-steps to reproduce the issue you are seeing
-screenshot of the issue

With more detailed information, we will be able to assist you further.


Thanks,
Danny

Danny R.
Roku Forum Moderator
0 Kudos