Playback Issues - Audio/Video & Power

Help with audio & video playback issues, TV display type recognition & compatibility, HDCP messages, troubleshooting playback errors, advertisements, and resolving power issues.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Highlighted
Level 7

No surround sound using HDMI splitter and optical (S/PDIF) to receiver.

I have a projector mounted on the ceiling which I need to hook an Xbox, Blu ray player, Nintendo 64, and my Roku Express to.  My receiver for surround sound is older and doesn't have an HDMI port.  I bought a 4 way HDMI splitter that has an optical (S/PDIF) out to hook to my receiver.  So in theory I can run all of my electronics to my projector and have surround sound through the optical out on the splitter.  Well it works great for everything except the Roku.  When I watch Vudu, Disney+, Amazon Video, etc. on the Roku, it outputs as PCM.  I have gone into the Roku settings and it has two audio options.  Audio setting options are Stereo and Auto (Dolby Digital and DTS) and then there is a Audio over HDMI selection that has Auto, Stereo (or something like that I think), Dolby Digital, Dolby Digital and DTS, and a few other options.  I initially chose Auto on the first 'Audio' setting and Dolby Digital and DTS on the 'HDMI' setting as that is what my receiver supports.  I have since tried most combinations and nothing seems to get me 5.1 surround sound.  If I run the Vudu app on the connected Blu ray player plugged into the same splitter, it will play 5.1 surround just fine.  If I switch back to Vudu on the Roku and pick up the movie where I left off, it switches back to PCM.  The Roku Express advertises that it does Dolby Digital pass thru, but it doesn't seem to be working.  Any ideas?  I have done extensive searching and potential "fixes" and haven't found a solution.  It has to be a Roku issue as the other devices have surround sound work just fine when I use them.

7 Replies
Highlighted
Level 7

Re: No surround sound using HDMI splitter and optical (S/PDIF) to receiver.

I'm having a similar issue. I plugged my Roku Streaming Stick Plus into the HDMI 2.0b projector, and then tried both ARC and Optical to get surround back to my amp, but no luck, only PCM Stereo...I've wasted two days trying to figure out what the problem is....

0 Kudos
Highlighted
Level 8

Re: No surround sound using HDMI splitter and optical (S/PDIF) to receiver.

Try a factory reset.
0 Kudos
Highlighted
Level 7

Re: No surround sound using HDMI splitter and optical (S/PDIF) to receiver.

Roku or projector?...or both?


@umeng2002 wrote:
Try a factory reset.

 

0 Kudos
Highlighted
Level 8

Re: No surround sound using HDMI splitter and optical (S/PDIF) to receiver.

Factory reset on the Roku. Then a power cycle (physically pull the power) on the Roku.
0 Kudos
Highlighted
Level 7

Re: No surround sound using HDMI splitter and optical (S/PDIF) to receiver.

Tried that. Looks like the problem may be that my new BenQ HT-3550 has a PCM2.1 limitation on the ARC/SPDIF output. I'm waiting to get verification back from BenQ tech support. Nothing in the datasheet or owners manual specifies this limitation, but came across a forum post or review somewhere in my Googling that indicated this may be the issue.

In the mean time, the whole reason I was doing this is because I couldn't get 4k+HDR through my 35' UHD HDMI cable, so wanted to plug the SS+ directly into the projector and just run the audio back to the AVR, through HDMI ARC (since the cable is already there). The cable length shouldn't be an issue with only the bandwidth of the audio...but alas, no surround. Anyway, I just ordered a hybrid optical HDMI cable off Amazon that should solve the cable loss problem, and just run the Roku from the AVR end so I can get DD+/DTS audio...hopefully!

0 Kudos
Highlighted
Level 7

Re: No surround sound using HDMI splitter and optical (S/PDIF) to receiver.

...so we went off the rails there...back to the OP question, have you tried swapping HDMI ports on the splitter? My thoughts are a) it could be a bad port, or b)the splitter is not telling the Roku that it can handle DD/DTS somehow (ie. handshaking issue)...or c) the Roku still isn't set up correctly.

When you force the HDMI DD/DTS selection in the audio menu, leave the other option set to auto, then go back out to the System menu and restart the device, then go back in and see if the first option has updated to show that the Roku accepted the DD/DTS selection that you forced in the HDMI section (both options should now show "Auto(DD/DTS)" or something like that. If that option isn't sticking, you may need to try the factory reset that was previously recommended.

I believe that first option is the parameter that is passed to the streaming service apps to determine which audio stream to send. I know before I start a show, be it Netflix, Prime Video or Disney+, they all indicate which audio stream they will be sending at the title screen for the show. When I had Auto(Stereo) selected, I would not see "5.1" listed on the title screens, and would get PCM2.1 stereo out of the amp. Whereas when I selected HDMI(DD/DTS) and rebooted the Roku, the title screen would list 5.1, and after starting the show, I would get no audio out of my AVR because it was sending in a format that (apparently) my projector is incapable of passing through. Kinda sounds like your splitter may be doing the same thing my projector is...?

0 Kudos
Highlighted
Level 7

Re: No surround sound using HDMI splitter and optical (S/PDIF) to receiver.

Another thing to consider is that the splitter may not be sending the correct EDID data back to the Roku device. See here: https://en.m.wikipedia.org/wiki/Extended_Display_Identification_Data

Check the specs for the splitter and see if it specifies anything about that. If it's EDID data is configurable, it would be really handy to program that port on the splitter to respond with a DD/DTS descriptor bit, which would make the "auto detect" feature of the Roku work without even needing to force the correct mode in the Roku Audio Settings menu.

0 Kudos