Playback Issues - Audio/Video & Power

Help with audio & video playback issues, TV display type recognition & compatibility, HDCP messages, troubleshooting playback errors, advertisements, and resolving power issues.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Highlighted
Level 7

No signal in Roku HDMI port until...

So my Roku has been doing this thing where when I turn on my tv it tells me the HDMI port my Roku is connected to has no signal. Nothing I press on my Roku remote does anything until I take my TV remote, switch it to a different input/source and then switch it back to the Roku input. The Roku homepage pops back up! None of my other Roku have this problems (but I will say the one giving me this problem is the Streaming Stick + aka the most expensive one I’ve purchased so far)  any advise would be appreciated! The Roku device is plugged into an outlet not the TV itself. 

75 Replies
Highlighted
Level 11

Re: No signal in Roku HDMI port until...

Just wondering if you have tried hitting a roku HOME button first, to try and wake up the Roku, then turn on the TV? 

"I might be moving to Montana soon..."
FZ
0 Kudos
Highlighted
Level 7

Re: No signal in Roku HDMI port until...

I have the same problem with the Roku Ultra. Both the tv and Roku were off. Used the Roku remote to turn them on. Tv and Roku were on, but the tv said there was no signal. Hit the Roku home button several times and waited. Nothing. Switched HDMI sources on the tv like everyone says to do. Nothing. Changed the HDMI cable to a different port. Nothing. All this while the Roku light was on. What’s the only thing that worked? Unplugging the Roku from power and plugging it back in. I had to do this every single time I turned the tv off and back on while the Roku light was still on. It’s funny because my Fire TV, Fire TV Stick, nor Apple TV have ever needed this to be done. My friend swears it’s because I have a tv that’s not name brand. It’s an Element. But I have seen reviews of Samsung and LG TVs that have had similar issues with not having a signal. They have to change the source each time, and sometimes it works for them. But my point is that you shouldn’t have to play with the tv source each time you turn your tv on if you didn’t change the source before turning the tv off. You also shouldn’t need to unplug it from power each time. Regardless of the brand of tv. It doesn’t make sense to me. I will be returning my device. Also, that same friend said I should consider getting a stick, and I considered the Stick+ like you have. But after reading your review as well as others, I am put off of Roku entirely. 

Highlighted
Level 19

Re: No signal in Roku HDMI port until...

@Tassia1487  Thanks for the note here. I'm sorry to hear about the experience you're running into. There are a few different things that may cause the behavior you've observed. A dirty HDMI cable connection or port, slightly worn connection pins inside the HDMI cable, out of date system software, etc. 

I would recommend starting by replacing the HDMI cable with a new cable, that hasn't been bent, used on multiple devices, coiled up repeatedly, or stored where dust can accumulate. You might also try lightly cleaning the Roku and TV's HDMI ports with air to remove any built-up dust. You'll also want to check in Settings>System>System update>Check now to make sure you are on the latest version of Roku OS. For your device, it should be equal to or greater than 9.2 build 4806. 

If this still doesn't help resolve the issue, please feel free to send me a private message with your Roku account email address, the serial number of your device from Settings>System>About, and the specific model of Element TV you are using. I'd be happy to help take a closer look from there. 

 

Thanks,

Tanner 

Highlighted
Level 7

Re: No signal in Roku HDMI port until...

I just got the roku streaming stick today. Set it up and it worked great. Cut my tv (Visio) off with roku remote and waited a few minutes. Cut it back on with roku remote and it says roku has no signal. Pressed every button on remote to no avail. Used other tv remote to switch input and then switch back and it cut on.  Brand new cord and roku. No idea how to fix this issue but pretty annoying to have to use two controllers

Highlighted
Level 7

Re: No signal in Roku HDMI port until...

So I actually got mine to work by factory resetting my Visio. I don’t know if it will help for you but if you have nothing to lose give it a shot, I will say it probably works best to have the roku plugged in to the tv while you factory reset.

I know this is not ideal and a flaw in both Roku and Visio i hope it works for you!! 

0 Kudos
Highlighted
Level 7

Re: No signal in Roku HDMI port until...

Tanner. My Roku has been working great. But yesterday it worked fine all morning. Turned it off went to church came back now all I get is No Signal. I’ve unplugged everything to no avail. Please let me know what to do now. [personal information removed]

Fanny

0 Kudos
Highlighted
Roku Employee
Roku Employee

Re: No signal in Roku HDMI port until...

@Farmer1218 @Zotto 

Thanks for the inquiry.

How are you powering your device? Is the device plugged into the TV USB port or is connected to a wall outlet? We would recommend powering the device with the provided cable. Have you also tried using another HDMI port on the TV to see if that resolves the issue?

Please keep us posted and we will continue to assist you from there.


Thanks,
Danny

Danny R.
Roku Forum Moderator
0 Kudos
Highlighted
Level 7

Re: No signal in Roku HDMI port until...

Mine Ultra is doing the SAME thing!!  Brand new Ultra, Brand new HDMI cable, brand new high def Sony TV for $4k?  I can switch between cable, blue ray etc. but when it gets to the roku i have to unplug the darn HDMI cable and plug it back in for it to recognize the signal,  What gives ROKU?  Apple TV device that I replaced doesn't do this on the same HDMI port and cable?????  

0 Kudos
Highlighted
Level 19

Re: No signal in Roku HDMI port until...

@TMC Try swapping the ends of your HDMI cable, and plug it into a different HDMI port on the TV. Does this resolve the issue? Have you also made sure to check for a system update in Settings>System>System update to ensure that your device is up to date? 

 

Thanks,

Tanner