Playback Issues - Audio/Video & Power

Help with audio & video playback issues, TV display type recognition & compatibility, HDCP messages, troubleshooting playback errors, advertisements, and resolving power issues.
cancel
Showing results for 
Search instead for 
Did you mean: 
sludgepickle
Level 7

No image/video coming through via Onkyo AV Receiver

I have been using a Roku premiere+ connected to my TV through an Onkyo HT-RC360 for months if not years. It all of a sudden stopped working through the receiver, I only get audio. The Roku works fine directly to the TV so it seems like a compatibility issue with the video and code/decode process.

I’m on the latest update, version 9.0.0 update as of 12/22/18. I have two of the same device, tried them both, same behavior with both. Tried different HDMI ports on the receiver, different HDMI cables, power cycled both devices, same behavior regardless. Started about a week or two ago.

My only thought now is, I have not updated my receiver firmware for a while so I will do that and see if it fixes it.
0 Kudos
3 Replies
smjones
Level 7

Re: No image/video coming through via Onkyo AV Receiver

I've had a Roku Ultra 4k hooked up to my Onkyo TX-NR1008 since late November 2017, working with no problem - HDMI to the Onkyo, and from there HDMI to an old Sharp 1080p LCD and halfway through the year a new Vizio 4k TV. Other inputs are a TiVo Premiere and a Playstation 4. All this was working with no problem until perhaps a week or less before Christmas.

At that time I noticed the same problem with my Roku - no display through the Onkyo, but a direct connection to the Vizio TV worked fine. However after I got back from a few days away over the holiday, I noticed the same thing was happening with the Playstation 4.

When I checked the Onkyo website, I didn't see a firmware update since 2012. Certainly my receiver says it's up to date when I tell it to check for an update. But the fact that this is happening with both the Roku and the Playstation makes me wonder if it isn't the Onkyo, rather than the Roku...
0 Kudos
smjones
Level 7

Re: No image/video coming through via Onkyo AV Receiver

A little more to add. A couple years ago I had to return my NR1008 to Onkyo for recall service. To fill the gap, I had picked up a TX-SR506, and a week or two later a TX-SR706 was available on Craigslist. Both were super cheap, so I grabbed them. After my NR1008 got back, they've just been sitting. Granted they were cheap for a reason, but as far as I recalled the SR706 had blue regions in black parts of the screen.

I hooked up the SR706, and had exactly the same situation as the NR1008 - the TiVo was fine, but the Roku and PS4 wouldn't display. The receiver claimed to be receiving "no signal" from these two inputs.

I hooked up the SR506 and got a surprise - all three HDMI sources worked. In fact, the Roku was now displaying in 4K on the Vizio TV - something the NR1008 wasn't capable of. I'm sure it's because the SR506 is just doing pass-through while the NR1008 has a chip to do all kinds of up-conversions and whatnot, but it's still refreshing. And makes me think that either the NR1008 has an issue with that chip, or maybe just the HDCP function that's been suggested elsewhere.

I had been considering an upgrade at some point to enable the 4K functionality, but I guess this may change the timetable...
0 Kudos
dgrace
Level 7

Re: No image/video coming through via Onkyo AV Receiver

I think I'd also completely power off the avr and tv, evening pulling power cord. Let them renegotiate the hdcp handshake.
Happy New Year
"I might be moving to Montana soon..."
FZ
0 Kudos