Playback Issues - Audio/Video & Power

Help with audio & video playback issues, TV display type recognition & compatibility, HDCP messages, troubleshooting playback errors, advertisements, and resolving power issues.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Highlighted
Level 7

No audio/video after switching inputs on receiver

I have had this issue for just about 2 months now. I also reported it on reddit.com/r/roku on 12/4/2019 (https://www.reddit.com/r/Roku/comments/e6brv8/premiere_4k_roku_no_videoaudio_after_switching/ )

I was then asked by /u/Roku_Official to start a direct chat about the issue. I have never received one response since. This issue has made my Roku useless. 

Since Disney+ was launched and v9.2 firmware my Roku Premiere will stop presenting audio and video if I change inputs on my receiver to another device (Xbox One) then back. The only fix it to change to the input the Roku is connected to then unplug power to Roku then plug it back in. 

Today I got the 9.2.0 build 4807-29 update but still am having the same issue. Its also really unfortunate that we are unable to contact Roku techs directly (either email or phone) and are forced to use communities. I need this resolved ASAP. I have 2 Roku Premiere's affected by this. They worked fine for a year+ then the 9.2.0 update came out and now it has this issue. If it cant be resolved then Roku can buy them back from me and Ill find something else.

Im an IT professional for many years and can guarantee that I have gone through all the basic troubleshooting steps. From what I was reading about this issue it seems that the issue is related to the HDCP handshakes and that the Roku only appears to do the handshake on startup. That is likely why it works when its power cycled and not after changing inputs. 

Labels (3)
0 Kudos
8 Replies
Highlighted
Level 7

Re: No audio/video after switching inputs on receiver

During testing at some point I had set my Roku to 1080p. While it was set to 1080p I cannot change inputs on my receiver and go back to the Roku. I changes it to 4k/60 and then rebooted it. Now I'm able to switch back and forth. Still unsure why it works in 4k now and not 1080p...

0 Kudos
Highlighted
Level 9

Re: No audio/video after switching inputs on receiver

When you switch from Roku to XBox...what does Roku do? Disconnect from your TV? Go to sleep?

As for unplugging and re-plugging, have you tried just restarting and rebooting the unit from the "Settings" after you switch back from XBox to Roku nothingness? The unit probably needs to reconnect itself. Not sure...but after you switch to XBox does the Roku light go out?

Anyhow, I'd rather Restart the Roku unit in the settings than otherwise. Easier to do for me. Have you tried that?

 

 

 

0 Kudos
Highlighted
Level 7

Re: No audio/video after switching inputs on receiver

Roku appears to stay on all the time. When I change inputs the light on the Roku doesnt change. When I change to the Xbox then back to the Roku I get no video or audio. I have no way of navigating the Roku's menus to even restart it. I also dont believe there is a 'power off' option for Roku's. I use a Logitech Harmony remote for my home theater equipment. Im pretty sure there is no option to power off the Roku when I turn the rest of the equipment off. I would prefer the option to turn off the Roku when not in use. 

0 Kudos
Highlighted
Level 9

Re: No audio/video after switching inputs on receiver

Every Roku I've ever had has a "Restart Roku option" At Roku home screen on the left side at "Home," remote up to "Settings," Remote right to "System." Then remote right again to"About," and you should see System Restart in the options listed...your unit may be a little different.

Try using your original Roku remote when screen goes black...just maybe.

When Roku goes Black/no sound...have you tried to turn TV off and back on and see if that would work? In the Roku settings they have an option of what you want your TV to boot up to...if it is set to automatically reboot to Roku...if you turn TV off and back on when Roku has nothing on screen after you switched back to it...seems to me that should work.  But I'm not positive, but you could try it.

You have no remote access to Roku after you switch back...use TV remote to restart the TV and see if that wakes the box back up...seems to me that would work...

If it does work...that wouldn't be too much trouble. IMO

Have you tried that already?

 

 

 

 

 

 

 

 

 

 

0 Kudos
Highlighted
Level 7

Re: No audio/video after switching inputs on receiver

While I appreciate the replies, please note that I have already tried the turn it off and turn it back on thing with every device in the chain (TV, Roku, AV Receiver). Also as I have stated 2 times now, with no video (my TV says there is no input detected) I have no way of navigating the menus on the Roku.

I dont think this is something the community can resolve. The issue is with the firmware. Nothing in my entertainment setup has changed since this issue has started. Im attempting to reach someone that works at Roku as it seems they offer no support via email/calling unless you have a Roku TV. The only option I have is to post here and hope someone from Roku comments. 

0 Kudos
Highlighted
Level 9

Re: No audio/video after switching inputs on receiver

I'm not clear on what you are saying here you are saying.

When you switch back from XBox to Roku using a toggle Switch and the screen in black...I understand you can't use the Roku Remote to do anything. But are you also telling me you can't even use your TV Remote to turn the TV off and on?

Or are you saying you tried that and the TV would not restart to Roku?

Anyhow, I get your point...and I am no tech...sorry I couldn't help.

0 Kudos
Highlighted
Level 9

Re: No audio/video after switching inputs on receiver

I really regret posting about this again but I have one more option you could, or may not want to try.

You say when you "Switch," back from your XBox to your Roku box and have a black screen and no audio, and you cannot restart your Roku System using the remote...that is not necessarily true.

I had a Roku Box and it worked fine after I received it and set it up...years passed...and at one point I turned my TV on and Nothing, no Roku, no picture, no audio...TV was on...so I checked the HDMI settings and they were correct. So I cut the power to Roku and when I reconnected, Roku came back on screen rebooting itself. And it worked fine...but I didn't like having to get up and go do that. So after I did that a few times, I came up with a better idea...I memorized how to "Restart System" using the remote on a blank screen: one up>one right>another up>another right>and down seven times>and then pressed the center button...and wallah, Roku restarted, rebooted, and worked fine. I preferred doing that every time I turned on the TV instead of getting up and go behind TV to unplug and re-plug Roku to reboot and come alive on the screen. The Roku Box seemed to go asleep or something.

When I turned off the TV, Roku would not "Wake up" ever again like it used to when I turned on the TV...much like you describe when you switch from XBox back to Roku...but I could still restart system using the remote without  seeing anything on the screen.

And after I replaced that older Roku with a new Roku Flash Drive USB Stick...problem solved.

But no, I don't really know what is causing your problem. I'm just trying to help...so, good luck with your problem.

 

If this isn't helpful please delete.

0 Kudos
Highlighted
Level 8

Re: No audio/video after switching inputs on receiver

Have you been able to resolve this?  I'm having the same issue on my Roku Ultra and am also on the latest software.

0 Kudos