Playback Issues - Audio/Video & Power

Help with audio & video playback issues, TV display type recognition & compatibility, HDCP messages, troubleshooting playback errors, advertisements, and resolving power issues.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Highlighted
Level 7

No Video : Roku Streaming Stick+ Plugged Into Receiver / Amplifier

Jump to solution

Hello, I've just added a third Roku Streaming Stick+ to our Upstairs TV and am having video difficulties.

The Roku is plugged into our receiver / amplifier.  I got the home screen and watched a bit of TV from the Spectrum app.  Sound was coming through the speakers okay too.

However, I can't seem to get any video after that one time.

I rebooted the Stick and the "dancing" Roku logo came up on the screen, but then it went dark.

Any ideas?

Labels (1)
0 Kudos
1 Solution

Accepted Solutions
Highlighted
Level 19

Re: No Video : Roku Streaming Stick+ Plugged Into Receiver / Amplifier

Jump to solution

Hi there,

 

What specific make/model of A/V receiver, and TV are you using? Have you tried changing the HDMI port on the receiver that the device is connected to? I'd also recommend trying to connect the device directly to the TV to see if this restores functionality. 

Keep us posted! 

 

Thanks,

Tanner

View solution in original post

0 Kudos
7 Replies
Highlighted
Level 19

Re: No Video : Roku Streaming Stick+ Plugged Into Receiver / Amplifier

Jump to solution

Hi there,

 

What specific make/model of A/V receiver, and TV are you using? Have you tried changing the HDMI port on the receiver that the device is connected to? I'd also recommend trying to connect the device directly to the TV to see if this restores functionality. 

Keep us posted! 

 

Thanks,

Tanner

View solution in original post

0 Kudos
Highlighted
Level 7

Re: No Video : Roku Streaming Stick+ Plugged Into Receiver / Amplifier

Jump to solution

Thank you Tanner.  I did plug the Roku directly into the Pioneer TV and that worked.  I then plugged it back into the Denon receiver / amplifier and it worked.

0 Kudos
Highlighted
Level 7

Re: No Video : Roku Streaming Stick+ Plugged Into Receiver / Amplifier

Jump to solution

I set up plugged my Roku Streaming Stick + on the side HDMI of my Vizio TV - all good thru setup.  I then plugged it into my Pioneer AV receiver.  It is working and I have sound and video - but the Roku Remote volume control no longer works (all other remote functions seem to be fine).  I think that I will need to use the receiver volume in this configuration - but wondered if there was any way to get the Roku remote to control the volume on the Pioneer AV receiver?

0 Kudos
Highlighted
Level 8

Re: No Video : Roku Streaming Stick+ Plugged Into Receiver / Amplifier

Jump to solution

This is a shot in the dark, but is the HDMI-CEC enabled on the Pioneer receiver and also on the TV? I am not sure how old the receiver is but it may or may not offer support. If they are enabled, with the Roku plugged into the pioneer receiver repeat the remote setup again. 

I had to replace my receiver because I found out it did not support HDMI standards for 4K. 

 

Keep us posted.

John

0 Kudos
Highlighted
Level 7

Re: No Video : Roku Streaming Stick+ Plugged Into Receiver / Amplifier

Jump to solution

John - thanks for getting back.  Both the TV and AV receiver are fairly old.  Vizio XVT553SV and Pioneer VSX-1021-K.  I do not see any reference to HMDI CEC in the manuals - or referenced on the HDMI port labeling on either unit.  Is it worth a try to set the remote up again with the Roku in the receiver - or just leave well enough alone and be happy that the Roku remote controls the Roku features and shuts both the Roku and TV off when power button is pushed?

Thanks,  - Tim

0 Kudos
Highlighted
Level 8

Re: No Video : Roku Streaming Stick+ Plugged Into Receiver / Amplifier

Jump to solution

Thanks for providing the receiver information. I took a look in your manual and on page 43 it explains the control with HDMI which is known as KURO LINK on Pioneer. The HDMI setup is in the middle of the page explaining how to enable it. I did notice that the page also warns that some devices may not be compatible with the pioneer flavor of the control. Trial and error may be the only way to find out. 

To get all my components working right I had to replace my receiver and one of my TV's. 

John

Highlighted
Level 7

Re: No Video : Roku Streaming Stick+ Plugged Into Receiver / Amplifier

Jump to solution

John - thanks again!  I checked the settings on the receiver and all were/are set up to enable HDMI Control per the manual.  Still no joy - but I'll keep playing with it.  I forgot to mention, the receiver has a UE33 flashing on the LED display so it is sick to begin with so may be a pointless effort - not sure?  I just hate to go off and get another 7.2 AV receiver....but this one is quite old....as is the TV!!

thanks,     - Tim

0 Kudos