Playback Issues - Audio/Video & Power

Help with audio & video playback issues, TV display type recognition & compatibility, HDCP messages, troubleshooting playback errors, advertisements, and resolving power issues.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Highlighted
Level 7

No Sound in Apps

Recently started having an issue with our Roku Stick.  We have sound when in the Roku menu, but as soon as we open any app, we lose sound.  This has to be a software/firmware issue.  We have checked all updates, reset the Roku multiple times, but keeps having the same issue.  This has to be looked at by IT.  Please fix ASAP.  This is a major problem.

15 Replies
Highlighted
Level 7

Re: No Sound in Apps

I’m having this problem as well. It started happening two days ago. As described the sound works in the main menu and app menu, but as soon as a video is cued, a single loud click can be heard and the sound is shut off. I have reset to factory settings, restarted roku, reinstalled the apps, logged in and out of the apps, and tried it with different speakers. Please fix this problem. 

0 Kudos
Highlighted
Level 7

Re: No Sound in Apps

Same issue.  System restarted, uninstall/re-install apps, factory reset.  I’ve tried everything that I can think of and still has the issue.  It’s not an internet problem either because I can stream Netflix straight on the TV.  

I have 4 Rokus but only having this problem on 1.  

0 Kudos
Highlighted
Level 7

Re: No Sound in Apps

@Tacotime @RobertC83 SAME issue here. Started happening yesterday and I can’t figure it out. Tried switching each end of the HMDI cable, unplugged for a minute, unplugged my tv as well. Nothing .. not happy. 

0 Kudos
Highlighted
Level 9

Re: No Sound in Apps

I had this develop this afternoon. I would hear sounds on the menu and the selections until I went into Hulu or Disney and played streaming content. Then the sound would go away even from the menu. I changed HDMI ports and power cycled the stick and the same thing happened in another HDMI port. When I power cycle the stick I get sound again and it plays streaming content in MLB but when I go to play content in Hulu or Disney the sound disappears again everywhere in the stick until I power cycle the stick. I tried changing settings on the TV and the stick for audio with no change in Behavior. Please fix ASAP.

0 Kudos
Highlighted
Level 7

Re: No Sound in Apps

I am having the same issue and the system updated right before it started...Roku needs to roll back the last system update or fix this ASAP!!

0 Kudos
Highlighted
Level 7

Re: No Sound in Apps

YES! I'm having the same issue! 

0 Kudos
Highlighted
Level 7

Re: No Sound in Apps

This is happening to me as well! I’ve gone into my settings on my remote and changed the sound mode and that’ll work until an ad starts, and then I’ll lose sound again. Did they update it recently and maybe this is just a bug in the update? Either way it needs to be addressed ASAP or they’ll start losing customers. These TVs aren’t cheap and this is frustrating! 

Tags (2)
0 Kudos
Highlighted
Level 9

Re: No Sound in Apps

I got this to work on my system - Roku stick on a Vizio TV (no external speakers or soundbar).

On the Roku stick menu, go to Settings -> Audio -> HDMI -> and set to PCM - Stereo. It appears that the auto detect routine has a defect in it where it fails to switch over after one of the states was selected. The Audio Mode setting did not make a difference.

Hope it works for you while Roku find the bug and squashes it.

Highlighted
Level 7

Re: No Sound in Apps

I got this to work on my system - Roku Express on a Samsung TV (no external speakers or soundbar).

On the Roku Express menu, go to Settings -> Audio -> HDMI -> and set to PCM - Stereo. It appears that the auto detect routine has a defect in it where it fails to switch over after one of the states was selected. The Audio Mode setting did not make a difference.

Hope it works for you while Roku find the bug and squashes it.

0 Kudos