Playback Issues - Audio/Video & Power

Help with audio & video playback issues, TV display type recognition & compatibility, HDCP messages, troubleshooting playback errors, advertisements, and resolving power issues.
cancel
Showing results for 
Search instead for 
Did you mean: 
Dreamfield42
Level 7

No Dolby Digital Roku Premeire+

I have a Yamaha TSR7790 receiver with a Blu-Ray player on HDMI1, Directv on HDMI2 and a Roku Premiere+ on HDMI3 inputs and one HDMI output to tv. The Blu-ray and Directv both are processing Dolby Digital and the Roku is processing PCM. I have checked the settings on the Roku and and I have it set to output Dolby/DTS. Am I missing something? What else can I check? Is it possible the receiver has separate output processing per input?
0 Kudos
5 Replies
atc98092
Level 13

Re: No Dolby Digital Roku Premeire+

"Dreamfield42" wrote:
I have a Yamaha TSR7790 receiver with a Blu-Ray player on HDMI1, Directv on HDMI2 and a Roku Premiere+ on HDMI3 inputs and one HDMI output to tv. The Blu-ray and Directv both are processing Dolby Digital and the Roku is processing PCM. I have checked the settings on the Roku and and I have it set to output Dolby/DTS. Am I missing something? What else can I check? Is it possible the receiver has separate output processing per input?

Your Yamaha supports DD+, so you shouldn't set the Roku on DTS/DD. It should be set to Auto, which should recognize what the AVR supports and bitstream what is supported. When you set it to DD, and the streaming site uses DD+, you're just going to get 2 channel PCM. 
Dan
Nvidia Shield, Roku Stick (3600), Ultra (4640), Premiere (3920), Insignia 720p Roku TV, Sharp 4K Roku TV, Windows 10 Pro x64 running Serviio and Plex on a wired Gigabit network.
0 Kudos
Dreamfield42
Level 7

Re: No Dolby Digital Roku Premeire+

"atc98092" wrote:
"Dreamfield42" wrote:
I have a Yamaha TSR7790 receiver with a Blu-Ray player on HDMI1, Directv on HDMI2 and a Roku Premiere+ on HDMI3 inputs and one HDMI output to tv. The Blu-ray and Directv both are processing Dolby Digital and the Roku is processing PCM. I have checked the settings on the Roku and and I have it set to output Dolby/DTS. Am I missing something? What else can I check? Is it possible the receiver has separate output processing per input?

Your Yamaha supports DD+, so you shouldn't set the Roku on DTS/DD. It should be set to Auto, which should recognize what the AVR supports and bitstream what is supported. When you set it to DD, and the streaming site uses DD+, you're just going to get 2 channel PCM. 

I am pretty sure I've tried it on auto as well, but I will definitely set it back to that tonight and try it. Thank you.
0 Kudos
Community Manager
Community Manager

Re: No Dolby Digital Roku Premeire+

@Dreamfield42 

If you have any 'Volume mode' settings enabled, this may also be what's causing the issue. Use of Volume modes is not supported with surround audio, and will cause PCM (stereo) audio to be output from your Roku device. You'll want to make sure to disabled any Volume modes, such as 'Leveling' when trying to play surround sound audio. 

During playback of content, press the * key on your remote. A sidebar panel will display on the lefthand side of the screen. Scroll down to 'Volume mode' and make sure this is set to 'Off'. Then check Settings>Audio>Audio mode and try selecting 'Auto' before playing content again. The source channel you are trying to play content from will also need to provide whichever surround sound format you are trying to play. For example, Netflix on Roku provides Dolby Digital+ audio format for Dolby surround. If you're not sure about a particular channel, feel free to contact that channel directly for more information about their provided audio formats on Roku.

Keep us posted with what you discover!

Thanks,
Tanner
Tanner D.
Roku Community Manager
0 Kudos
Dreamfield42
Level 7

Re: No Dolby Digital Roku Premeire+

Thank you so much for that information. I learned a lot from your post.
0 Kudos
Dreamfield42
Level 7

Re: No Dolby Digital Roku Premeire+

"RokuTannerDB" wrote:
@Dreamfield42 

If you have any 'Volume mode' settings enabled, this may also be what's causing the issue. Use of Volume modes is not supported with surround audio, and will cause PCM (stereo) audio to be output from your Roku device. You'll want to make sure to disabled any Volume modes, such as 'Leveling' when trying to play surround sound audio. 
During playback of content, press the * key on your remote. A sidebar panel will display on the lefthand side of the screen. Scroll down to 'Volume mode' and make sure this is set to 'Off'. Then check Settings>Audio>Audio mode and try selecting 'Auto' before playing content again. The source channel you are trying to play content from will also need to provide whichever surround sound format you are trying to play. For example, Netflix on Roku provides Dolby Digital+ audio format for Dolby surround. If you're not sure about a particular channel, feel free to contact that channel directly for more information about their provided audio formats on Roku.

Keep us posted with what you discover!

Thanks,
Tanner



That worked. The volume range control was on auto. I turned it off and got Dolby back.
0 Kudos