Playback Issues - Audio/Video & Power

Help with audio & video playback issues, TV display type recognition & compatibility, HDCP messages, troubleshooting playback errors, advertisements, and resolving power issues.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
StreamerUser
Level 20

Re: No Dolby Atmos for Disney Plus Channel - New Roku 4800X

You dont mention what TV you have, but for the sake of verifying the TV's EDID detection/info/handshaking, turn off everything (completely off) for 5-10 minutes, disconnect the TV from the AVR (no ARC etc), and hook the Roku directly to the TV, then turn the TV on completely, then turn the Roku on, and check what Settings/Audio/HDMI=Auto passthrough detects.

 

0 Kudos
Redjack
Level 7

Re: No Dolby Atmos for Disney Plus Channel - New Roku 4800X

Ok, so I did what you suggested. My TV is a 2019 75” Samsung RU7100. AVR is unplugged from ARC input. Roku is plugged directly into TV HDMI input. Auto passthrough detects: Stereo, DD, Dolby Atmos-DD+.  Now that is also strange since the AVR is not hooked up and this TV definitely can’t output Atmos out of its built in speakers. I went into Disney Plus and it still reports 5.1 audio, which in this case should be correct. Netflix and Apple TV+ channels still  also report Atmos availability even though the AVR is disconnected from the TV. 

0 Kudos
StreamerUser
Level 20

Re: No Dolby Atmos for Disney Plus Channel - New Roku 4800X


@Redjack wrote:

Ok, so I did what you suggested. My TV is a 2019 75” Samsung RU7100. AVR is unplugged from ARC input. Roku is plugged directly into TV HDMI input. Auto passthrough detects: Stereo, DD, Dolby Atmos-DD+.  Now that is also strange since the AVR is not hooked up and this TV definitely can’t output Atmos out of its built in speakers. I went into D+ and it still reports 5.1 audio, which in this case should be correct. Netflix and Apple TV+ channels still  also report Atmos availability even though the AVR is disconnected from the TV. 


This is what I was expecting - the EDID detection/handshaking for your TV with your AVR connected wasnt given accurate results (the TV may be doing "EDID passthrough/patching" with ARC enabled) - I suspected that from all the codec support listed when you direct-connected it to the TV before with ARC setup.

In terms of Atmos, there are currently 4 types:  DD+/Atmos, DTHD/Atmos, PCM MAT 2.x/Atmos, and AC4/Atmos.  Streaming services use DD+/Atmos, and Roku (in the 4800s current firmware build - this has changed in different builds) displays such support as "Dolby Atmos-DD+" (which is just a form of DD+).

(As an aside, if the Roku displays "DD+, Dolby Atmos" and not "Dolby Atmos-DD+", then it detects both DTHD/Atmos and DD+/Atmos - which youd expect when connecting it directly to a device with DTHD support, like an AVR, though some newer/higher end TVs support it too)

It may seem strange, but its accurate  - it has a "newer" Dolby DD+-level decoder which of course can recognize DD+ in all forms, including DD+/Atmos for either internal decoding, or passthrough (it cant decode it or pass it through if it cant recognize it).

(And what may seem even stranger is that there are TVs that do have internal Atmos output support - Atmos from internal speakers)

Regardless, in order to passthrough DD+/Atmos from HDMI to ARC, the TV has to report that DD+/Atmos support via EDID - and this is what Roku (and your other devices) properly detects.

In other words, the minimum requirement for Atmos is DD+/Atmos, and if the connected device reports DD+/Atmos (which is just a format of DD+) via its EDID, then that enables Atmos support in nearly all the streaming services (NetFlix being an exception - they require an Atmos-level decoder on the NF device itself in order to enable Atmos)

Which gets us back to Disney+ - its still reporting it incorrectly - it should be indicating Atmos if the Roku has "Dolby Atmos-DD+" support.

Lets try a couple more things (if you are willing).

With the AVR completely disconnected from ARC/Roku directly connected (and Audio/HDMI set to either Auto detect or Auto passthrough, assuming firmware 9.4.1-4236 and D+ app version 1.11.2021021200)

1) Remove Disney+, restart the 4800, reinstall D+ - check again

2) Factory reset the 4800, install Disney+ - check again

If either of those results in Atmos tagging on D+, then you can hook the AVR up via ARC and test again, etc.

However, if that still doesnt result in Atmos tagging in D+, it may very well be yet-another EDID/handshaking issue for the 4800, and you should report it to Roku & Disney+.

Otherwise:

1) if you have another TV (which may support DD+/Atmos passthrough at least) or AVR, you could check the 4800s/D+ detection on that.

2) Obtain a SS+ (or an older Ultra, 4670 etc) and see if it properly detects Atmos with either TV/AVR (these run a different firmware version/track:  9.4.0-4200).

0 Kudos
Redjack
Level 7

Re: No Dolby Atmos for Disney Plus Channel - New Roku 4800X

Thank you for that detailed explanation. So I took your direction and connected the Roku directly to the TV with AVR unplugged from ARC. I removed the Disney Plus channel, restarted the until and reinstalled the Disney Plus channel. Still showing DD 5.1.  I then factory reset the Roku. Reactivated it, and then went into the Disney Plus channel (already installed upon factory reset).  Still showing DD 5.1.   I then repeated the above steps but this time with the Roku plugged into my AVR input, and the AVR connected to the TV via ARC.  Still no luck with both a channel reinstall and a factory reset.  Finally, I have an old 1080p TV that support HDMI-CEC but doesn't have an ARC input.  I connected the Roku to my AVR, and the AVR to one of the HDMI inputs on the TV and set the sound on the TV to come from the AVR and not internal speakers.  I tried both your two options again on the old TV, but still Disney Plus shows only 5.1.  Once again, Netflix, Amazon and AppleTV+ happily worked in Atmos connected to the old TV.  Considering Disney Plus Atmos works via my Shield PRO 2019 and Apple TV 4K and their respective Disney Plus apps on both TVs, I suspect the problem lies less with the Disney Plus channel and more with how the Roku 4800 is handling audio passthrough, specifically for Disney Plus.

0 Kudos
StreamerUser
Level 20

Re: No Dolby Atmos for Disney Plus Channel - New Roku 4800X

Yeah, you'll need to report this to both Roku and Disney Plus - just make sure you detail your setup.

It might also be worth it to try a non-4800 model as well if you can (to confirm its a 4800-specific EDID/handshaking issue w/Disney Plus).

0 Kudos
atc98092
Community Streaming Expert

Re: No Dolby Atmos for Disney Plus Channel - New Roku 4800X

Yeah, I'm completely baffled. It works fine with my 4800, my Yamaha AVR and LG TV. I used to have my Ultra 4640 on this TV, but the Atmos AVR was upstairs in the bedroom and didn't have a Roku on it at the time. I'm pretty sure I also tried the Ultra 4670 on this AVR, and Atmos was available with Disney Plus. Since Atmos is working on other channels, it doesn't seem logical that it's a hardware issue with the 4800, as that should affect them all. 

Dan

Roku Community Streaming Expert

Help others find this answer and click "Accept as Solution."
If you appreciate my answer, maybe give me a Kudo.

I am not a Roku employee, just another user.
0 Kudos
Redjack
Level 7

Re: No Dolby Atmos for Disney Plus Channel - New Roku 4800X

Thanks to both of you for your help.  I was hoping there was something simple and easy I was missing with the Roku.  I am completely baffled and logically this doesn't make sense at all. I will definitely report this to Roku and Disney Plus and I guess we'll go from there. I wish I had another Roku device to try out, but I don't, and I don't want to purchase a SS+ just for that purpose.

0 Kudos
asdfghjkki
Level 7

Dolby Atmos issues after 10.5 update?

Hey all. I have a Roku Ultra 4670X (10.5.0 build 4208-46), LG 2020 CX TV, and Sonos Arc Soundbar. All was working fine since I got everything about a year ago but with what I can only assume is a recent auto-update, my Dolby Atmos has not worked for like a month. It just plays in HDR when I try from an app that should be able to play Dolby Atmos like Disney+. My AppleTV and the native LG OS Disney Plus apps all play Dolby Atmos properly so settings on the TV are correct for my setup (HDMI ARC, eARC on, etc.) Roku audio settings also look correct - Audio mode is Auto, Streaming audio format is Dolby, and Digital output format is Auto (it's an older Roku so there's no Passthrough option but it is def a Dolby Atmos model). Restarted, toggled off and back on the audio settings, unplugged everything and back, reset Roku back to factory settings, even reset LG and still no dice. It's fully up-to-date, but lo and behold that update had installed/been released in early December...

Anyone had this issue and found a resolve? I reached out to Roku support but got the regular run around where they didn't read my troubleshooting in my initial email (I get it, I used to work in CS, you got a script) but that leads me to believe it's not like a known bug/widely affects enough consumers that this can potentially be resolved. So if anyone has experienced similar and figured something out, let me know! Thanks!

Tags (2)
0 Kudos
stash64
Level 7

Re: No Dolby Atmos for Disney Plus Channel - New Roku 4800X

Add me to baffled as well.  I have my Roku Ultra 4800 set up in "Passthrough" audio mode instead of "Auto" because I prefer to have my Marantz AV8805 do any decoding.  The Roku is connected directly to the Marantz, not the TV.  I just added a Disney Plus subscription and I've tried several Disney Plus movies that have Dolby Atmos but all I get from my Marantz is Dolby Digital Plus in 5.1.

I also did a little experiment with ESPN+ last night while watching the NFL playoff game.  I was getting only Dolby Digital 2.0 in PCM.  So I switched the Roku audio to "Auto" mode and suddenly my AV8805 was showing a Dolby Atmos input.  However, I was still only getting 2.0 stereo... no sound from heights, surrounds, or center channel.  I then tried "Auto" with a Disney+ movie and, lo and behold, my AV8805 was showing Dolby Atmos input... but still just 5.1 and no sound from height speakers.  Not sure if this is just an incompatibility with Disney+ but it sure appears to me that the Roku is "faking it" when switching to Auto mode.

All the settings are correct on my Marantz AV8805 and I have never had an issue with getting Dolby Atmos to pass through on BD discs or with my previous gen AppleTV 4K.

0 Kudos
atc98092
Community Streaming Expert

Re: No Dolby Atmos for Disney Plus Channel - New Roku 4800X

@stash64 while the video is playing, press the * button and see if any of the sound modes are enabled, such as Night mode or volume leveling. Any of these modes force 2 channel output only. 

Dan

Roku Community Streaming Expert

Help others find this answer and click "Accept as Solution."
If you appreciate my answer, maybe give me a Kudo.

I am not a Roku employee, just another user.
0 Kudos