Playback Issues - Audio/Video & Power

Help with audio & video playback issues, TV display type recognition & compatibility, HDCP messages, troubleshooting playback errors, advertisements, and resolving power issues.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Highlighted
Level 8

No Digital Surround Sound From Roku Express

Jump to solution

Using good HDMI cables, I have directly connected my four Roku Express devices to various 7.1 receivers (in surround-sound systems) that support all types of Dolby Digital and DTS, and then sent the video to the TVs through the HDMI outputs. I have the settings in each of the receivers and Roku devices set to Dolby Digital. I have worked in home audio/video for over twenty years and know how to do this correctly. Nevertheless, I have been unable to get anything but a stereo signal from each Roku device, even from sources/apps that tell me they are sending their signal to Roku in Dolby Digital. Has anyone been able to get multichannel, digital (not just Pro-Logic II) surround sound from a Roku Express? If so, how? I have already tried adjusting the settings in the Roku devices themselves as well as in my receivers.  

Labels (2)
0 Kudos
2 Solutions

Accepted Solutions
Highlighted
Level 19

Re: No Digital Surround Sound From Roku Express

Jump to solution

@Raspeaker  I believe The Roku Channel has some free content which offers standard Dolby Digital format. Netflix, Vudu, Amazon Prime Video, Disney+, and others offer Dolby Digital Plus audio.  

Try some of those out and keep us posted with what you discover! 

 

Thanks,

Tanner

View solution in original post

Highlighted
Level 10

Re: No Digital Surround Sound From Roku Express

Jump to solution

I still maintain that much of the issue with surround sound has to do with confusing Roku audio options. Tanner says above to set the Roku Settings>Audio to "Auto Detect", but this is misleading. The actual options are: Settings>Audio which has 4 options "Menu Volume", "Audio Mode", "Audio pref lang", and "HDMI". Under Settings>Audio>Audio Mode, you have 2 options "(Auto(DD+, DTS))" and "(Stereo)". Then under Settings>Audio>HDMI you have several options "(Auto Detect)", "(PCM Stereo)", and lots of surround sound type options such as "(DD)", or "(DD,DTS)".

You have to have:
Settings>Audio>Audio Mode = (Auto(DD+, DTS))
AND
Settings>Audio>HDMI = (Auto Detect)

IOW there are sort of 2 "auto" settings. Strictly speaking Settings>Audio does not have a "(Auto Detect)" option as Tanner indicates; only Settings>Audio>HDMI has a "(Auto Detect)" option......hence I believe the confusion. In addition, say if you happen to pick "(DD,DTS)" for HDMI, then in that case DD+ formats (Netflix, Prime) will not be passed thru to your AVR and you will only get stereo. The only way to get all 3 formats of DD, DD+, and DTS is to pick "(Auto Detect)" as the Settings>Audio>HDMI option.

View solution in original post

39 Replies
Highlighted
Level 19

Re: No Digital Surround Sound From Roku Express

Jump to solution

@Raspeaker  Thanks for the note. During playback of content inside a streaming channel, press the * key on your remote. A menu will open on the lefthand side of the screen. Look for the 'Volume Mode' feature, and turn it 'off'. Does this resolve the issue? (Volume modes are only supported for use with stereo audio.) 

As a reminder, the channel and source content that you are trying to play must offer the multi-channel audio format, in order for your device to play it. For example, Netflix offers Dolby Digital + for some content, however, other channels may not offer any multi-channel audio options at all. 

Keep us posted from there! 

 

Thanks,

Tanner

Highlighted
Level 8

Re: No Digital Surround Sound From Roku Express

Jump to solution

@RokuTannerD: Volume mode is turned off. I have double-checked this using the method you suggest. I have repeatedly checked the audio mode settings in the Rokus to be certain each is set to Dolby Digital (which my 7.1 Denon and Integra receivers are set to decode, and which they do decode with other sources such as Blu-ray discs, antenna TV, and satellite TV). I realize that not all source content will play in multi-channel format but absolutely no source content of any kind will play in any digital multi-channel format through any of my four Roku Express devices -- and that applies to streaming services that have assured me they send their signal to Roku in Dolby Digital. Do you know of anyone who has been able to replay any content at all in true, digital (not just Pro-Logic II) surround sound using their Roku Express? If so, I would like to chat with them since all four of my Roku Express devices must then be defective. 

0 Kudos
Highlighted
Level 8

Re: No Digital Surround Sound From Roku Express

Jump to solution

thank you , i was having the  same issue, simple fix thanks again

0 Kudos
Highlighted
Level 8

Re: No Digital Surround Sound From Roku Express

Jump to solution

@pwts Are you saying that turning off volume modes enabled true, digital surround sound through a Roku Express? I have four of these and turning off volume modes did not enable Dolby Digital, even from streaming services that insisted they were sending the signal in Dolby Digital. If this worked for you and not for me I will use your comment as a basis to seek an exchange from Roku for my four defective units.

0 Kudos
Highlighted
Level 19

Re: No Digital Surround Sound From Roku Express

Jump to solution

@Raspeaker Yes, Roku Express units can provide the same audio formats to devices as other Roku devices. This is likely a configuration issue, there is not likely any defect that would be affecting multiple devices as you described. In Settings>Audio, change any available option back to 'Auto-detect', and see if this makes a difference in the behavior you are seeing. 

If not, please specify exactly which channels you are trying to stream surround sound content from, along with some example content titles in those channels. I'd be happy to help take a closer look and see what other changes we can recommend. 

 

Thanks,

Tanner

0 Kudos
Highlighted
Level 8

Re: No Digital Surround Sound From Roku Express

Jump to solution

@RokuTannerD I have already done what you suggested with the settings. My most recent frustration was with Vidgo. A representative assured me that they sent their audio in Dolby Digital but a tech support person yesterday admitted it was only in stereo. I have tried a variety of apps such as Disney Now and could not get digital surround sound (though I can always put the stereo signal in Pro-Logic II). I will have to do some experimentation later with other apps. Do you know of any free apps (that is all I have left since I canceled Vidgo) that have content in Dolby Digital? It would help me greatly and speed up my testing if you could tell me of some. Thanks so much for your patience and persistence!

0 Kudos
Highlighted
Level 19

Re: No Digital Surround Sound From Roku Express

Jump to solution

@Raspeaker  I believe The Roku Channel has some free content which offers standard Dolby Digital format. Netflix, Vudu, Amazon Prime Video, Disney+, and others offer Dolby Digital Plus audio.  

Try some of those out and keep us posted with what you discover! 

 

Thanks,

Tanner

View solution in original post

Highlighted
Level 10

Re: No Digital Surround Sound From Roku Express

Jump to solution

I still maintain that much of the issue with surround sound has to do with confusing Roku audio options. Tanner says above to set the Roku Settings>Audio to "Auto Detect", but this is misleading. The actual options are: Settings>Audio which has 4 options "Menu Volume", "Audio Mode", "Audio pref lang", and "HDMI". Under Settings>Audio>Audio Mode, you have 2 options "(Auto(DD+, DTS))" and "(Stereo)". Then under Settings>Audio>HDMI you have several options "(Auto Detect)", "(PCM Stereo)", and lots of surround sound type options such as "(DD)", or "(DD,DTS)".

You have to have:
Settings>Audio>Audio Mode = (Auto(DD+, DTS))
AND
Settings>Audio>HDMI = (Auto Detect)

IOW there are sort of 2 "auto" settings. Strictly speaking Settings>Audio does not have a "(Auto Detect)" option as Tanner indicates; only Settings>Audio>HDMI has a "(Auto Detect)" option......hence I believe the confusion. In addition, say if you happen to pick "(DD,DTS)" for HDMI, then in that case DD+ formats (Netflix, Prime) will not be passed thru to your AVR and you will only get stereo. The only way to get all 3 formats of DD, DD+, and DTS is to pick "(Auto Detect)" as the Settings>Audio>HDMI option.

View solution in original post

Highlighted
Level 8

Re: No Digital Surround Sound From Roku Express

Jump to solution

@sgmfish Thanks for your input and help! I have adjusted the setting of which you speak. I'm not sure what it was on but I just made sure that it was set correctly as you have noted. After trying some of the content that @RokuTannerD suggested I did get Dolby Digital surround sound!

 

@RokuTannerD Thanks for your suggestions! They worked (such as the movie The Dark Night on the Roku Channel). I think there must be only a limited number of apps that offer Dolby Digital and I was expecting more. I wrongly assumed that movies and shows on some of the free apps would be in Dolby Digital and falsely accused Roku Express of being defective. My apologies to Roku and heartfelt thanks to all who have helped me on this thread. I greatly appreciate it!

0 Kudos