Playback Issues - Audio/Video & Power

Help with audio & video playback issues, TV display type recognition & compatibility, HDCP messages, troubleshooting playback errors, advertisements, and resolving power issues.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Highlighted
Level 7

Invalid No-Signal Error

Our 3700 X has not been used for quite a while, and trying to set it up today appeared successful but then failed. As briefly as possible, the device was in a loading mode after all other steps were complete. I left the room briefly and returned to find a black screen with “no signal” message. Tried to troubleshoot and cross-check, using another of our Roku devices on the same TV (they had never been linked together before) and all was perfect.

Trying the reset on the 3700 had no effect and neither does powering on/off, etc. Really appreciate any advice, and/or “sad to report” news that the old rascal is just dead. Thanks, Chuck

 

0 Kudos
4 Replies
Highlighted
Level 7

Re: Invalid No-Signal Error

Apologies, I failed to note that the troubleshooting included confirmation that our internet signal shows as “excellent” on a large screen TV a room away, perhaps 25 feet or so. The stream produces a really good image.

0 Kudos
Highlighted
Roku Employee
Roku Employee

Re: Invalid No-Signal Error

@hookc 

Thanks for the note.

Have you tried plugging in your device into another HDMI port on the TV or trying to connect the device to another TV to see if it is able to detect the device? If the device is able to work on another HDMI port or can connect to another TV, then it may be a TV connection issue.

Please keep us posted and we will continue to assist you.


Thanks,
Danny

Danny R.
Roku Forum Moderator
0 Kudos
Level 7

Re: Invalid No-Signal Error

Danny, really appreciate your follow-up. We just brought the 3700X to another room in the house, tried it there on each of a TV’s two HDMI in’s with same result. “No Signal,” and this was after swapping cables around. Maybe of significance: the Roku’s little blue-green LED stays on constantly, no flickering at all. 

This whole sequence seems so strange since the whole set-up downstairs went perfectly, code entry and network connect, etc. During what I recall is the last phase of all this, the screen went black and Roku did nothing. Again, with other of our Roku, we hooked it up on that set and all was fine.

0 Kudos
Highlighted
Level 19

Re: Invalid No-Signal Error

@hookc Thanks for the extra details. This sounds like there may either be an issue with the HDMI cable you are using, or the HDMI port may have worn out on your device. Try using a different HDMI cable to connect the device to your TV. If that isn't working, please send either @RokuDanny-R or myself a private message with your Roku account email address and the serial number printed on your Roku device. We'll see what other options we can help provide from there. 

 

Thanks,

Tanner

0 Kudos