Playback Issues - Audio/Video & Power

Help with audio & video playback issues, TV display type recognition & compatibility, HDCP messages, troubleshooting playback errors, advertisements, and resolving power issues.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Steventhomason6
Level 7

Having to switch inputs

Just installed roku express + on tv. Using hdmi port 1. When I power the tv back on, the signal from roku isn't showing up on the screen.  Hdmi port 1, shows that roku is plugged in, but no signal.  I have to switch to another input, then back to hdmi 1 and roku home screen shows up.

This happens every time I power off the tv and turn it back on.

0 Kudos
5 REPLIES 5\
aural88
Level 9

Re: Having to switch inputs

Assuming you have gone through the Setup Settings and they are correct...sometimes that happens to me, [No internet connection] although not every time, and I just go thru the options settings menu and restart Roku...may take 30 seconds or so for it to connect to the internet...every now and then I have to do that.

But sounds like your box is asleep and switching cables back and forth somehow wakes it up. I don't know about that. I just happened to be passing by...hope you get a sure fix!

 

0 Kudos
JimL
Level 9

Re: Having to switch inputs

I would hazard a guess that it's because the Roku is 'asleep' when you turn your TV on.  Asleep may not be the correct term, but my projector wouldn't see an HDMI signal from the Roku until I pressed a button on the Roku remote and the light on the Roku was lit.  I suggest pressing the home button on your Roku to wake it up before turning on the TV, and see if that solves it for you. 

Mimioftwins2017
Level 7

Re: Having to switch inputs

I have the exact issue and it is driving me crazy.  Did you find a solution?

0 Kudos
AvsGunnar
Community Streaming Expert

Re: Having to switch inputs

@Mimioftwins2017 

Usually pressing the Home button on the remote is all that is necessary. (you need to wake the device).

If you have a Roku device model in which the included remote has TV volume and power controls, then you can also try enabling Roku's 1-touch play (CEC) feature.  With this feature Enabled, any press of a Roku remote button (excluding the power and volume), will simulataneously power the TV on, wake up the Roku device, and automatically switch to the HDMI port that the Roku is plugged into.

(https://support.roku.com/article/360037934914)

 

Roku Community Streaming Expert
Just another Roku user... I am not a Roku employee.
Insignia RokuTV, Ultra 4660x, Premiere+ 3921, Express 4k+ 3941
JimL
Level 9

Re: Having to switch inputs

@Mimioftwins2017,  I think you just need to try what was suggested and wake the Roku first.   

If you have to do this even when the Roku is already awake, then perhaps it's your TV.  Or, possibly taking too long to wake up if powered by the TV.  Some Roku's seem to take more power than some TV's USB ports are able to provide, resulting in erratic behavior from the Roku.

I now have a Streambar connected to a projector and do not have to power up the Streambar first.  For my TV, I picked up an Express 4K and it apparently detects when the TV is turned on because the Roku automatically wakes up with the TV, even though the Roku is powered from a wall outlet and not the TV.  I was glad to see that Roku addressed this.

0 Kudos