Playback Issues - Audio/Video & Power

Help with audio & video playback issues, TV display type recognition & compatibility, HDCP messages, troubleshooting playback errors, advertisements, and resolving power issues.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
FxProgrm
Level 8

HLS Stream Tester with Stereo/DD tracks failing to start

I have encoded a title and provided the necessary parameters per the HLS spec on how the audio EXT-X-MEDIA should be named.  When launched, the stream tester starts up but eventually throws a generic 'Video PlayBack Error": An unexpected problem (but not server timeout of HTTP error) has been detected.  Trying to understand how to debug this or capture some more detailed response from the stream tester app.  I presume it's something to do with the DD track, but no idea as to what would be the issue.

Thanks.

Test Device: Roku 3090RW - Roku Express

Software: 10.5.0 4208-AE

HDMI connection to an monitor with internal stereo speakers.

#EXTM3U
#EXT-X-VERSION:4
#EXT-X-INDEPENDENT-SEGMENTS
#EXT-X-STREAM-INF:BANDWIDTH=11332537,AVERAGE-BANDWIDTH=10193732,CODECS="ac-3,avc1.4d4028,mp4a.40.2",RESOLUTION=1920x1080,FRAME-RATE=23.976,AUDIO="program_audio",SUBTITLES="subs"
sample_1080_10000.m3u8
#EXT-X-STREAM-INF:BANDWIDTH=9161361,AVERAGE-BANDWIDTH=8191521,CODECS="ac-3,avc1.4d4028,mp4a.40.2",RESOLUTION=1920x1080,FRAME-RATE=23.976,AUDIO="program_audio",SUBTITLES="subs"
sample_1080_8000.m3u8
#EXT-X-STREAM-INF:BANDWIDTH=6978753,AVERAGE-BANDWIDTH=6161648,CODECS="ac-3,avc1.4d4028,mp4a.40.2",RESOLUTION=1280x720,FRAME-RATE=23.976,AUDIO="program_audio",SUBTITLES="subs"
sample_720_6000.m3u8
#EXT-X-STREAM-INF:BANDWIDTH=4476357,AVERAGE-BANDWIDTH=3710536,CODECS="ac-3,avc1.4d401f,mp4a.40.2",RESOLUTION=960x540,FRAME-RATE=23.976,AUDIO="program_audio",SUBTITLES="subs"
sample_540_4000.m3u8
#EXT-X-STREAM-INF:BANDWIDTH=2551004,AVERAGE-BANDWIDTH=2198790,CODECS="ac-3,avc1.4d401f,mp4a.40.2",RESOLUTION=854x480,FRAME-RATE=23.976,AUDIO="program_audio",SUBTITLES="subs"
sample_480_2000.m3u8
#EXT-X-STREAM-INF:BANDWIDTH=1612800,AVERAGE-BANDWIDTH=1269328,CODECS="ac-3,avc1.4d401f,mp4a.40.2",RESOLUTION=640x360,FRAME-RATE=23.976,AUDIO="program_audio",SUBTITLES="subs"
sample_360_1200.m3u8
#EXT-X-MEDIA:TYPE=AUDIO,GROUP-ID="program_audio",LANGUAGE="eng",NAME="English",AUTOSELECT=YES,DEFAULT=YES,URI="sample_audio_96_2ch.m3u8"
#EXT-X-MEDIA:TYPE=AUDIO,GROUP-ID="program_audio",LANGUAGE="eng",NAME="English",AUTOSELECT=YES,DEFAULT=NO,URI="sample_audio_384_6ch.m3u8"
#EXT-X-MEDIA:TYPE=SUBTITLES,GROUP-ID="subs",NAME="English",DEFAULT=YES,AUTOSELECT=YES,FORCED=NO,LANGUAGE="eng",URI="sample_cc.m3u8"

0 Kudos
1 REPLY 1\
makaiguy
Community Streaming Expert

Re: HLS Stream Tester with Stereo/DD tracks failing to start

You've posted to a forum for Roku users, where few, if any, will be able to help. The Developers forums are a couple of doors down the hall: https://community.roku.com/t5/Developers/ct-p/channel-developers

Roku Community Streaming Expert
I am not a Roku employee, only a user like you.  Please, no support questions via private message -- post them publicly to the Community where others may benefit as well.
If this post solves your problem please help others find this answer by clicking " as Solution.".

Streaming Stick 4K+ 3821 | Streaming Stick+ 3810 | TCL Roku TV 43S245/C107X