Playback Issues - Audio/Video & Power

Help with audio & video playback issues, TV display type recognition & compatibility, HDCP messages, troubleshooting playback errors, advertisements, and resolving power issues.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Dmcclean
Level 7

HELP - Sony Bravia light blinks red when streaming stick+ plugged in

Jump to solution

Bought a new streaming stick yesterday.

It initially worked fine, but after turned off and on TV, the Sony Bravia light blinks red 3 times and screen is blank.

 

Removing the stick fixes the problem.

I exchanged the stick, new stick has same issue.

Please help.

Thanks

dmcclean

0 Kudos
1 Solution

Accepted Solutions
RokuDanny-R
Roku Employee
Roku Employee

Re: HELP - Sony Bravia light blinks red when streaming stick+ plugged in

Jump to solution

Hi everyone,

Thanks for the posts.

Have you tried contacting your TV manufacturer support yet to inquire further? I'd suggest starting there to see what options or suggestions they can provide.

You can reach them here: https://www.sony.com/electronics/support


Thanks,
Danny

Danny R.
Roku Forum Moderator

View solution in original post

0 Kudos
9 REPLIES 9\
DocNyr
Level 9

Re: HELP - Sony Bravia light blinks red when streaming stick+ plugged in

Jump to solution

I am having the same problem. Sony bravia blinks three times with Roku plugged in and no image shows up. I unplug it, switch TV off and back on, and then plug Roku in. It works. This is happening all the time. 

Roku does not play well with Sony Bravia tv??

Please help.

0 Kudos
renojim
Community Streaming Expert

Re: HELP - Sony Bravia light blinks red when streaming stick+ plugged in

Jump to solution

Are you using the supplied power adapter or the TV's USB port for power?  My limited research shows that code (3 flashes) as some kind of power problem with the TV.

Roku Community Streaming Expert

Help others find this answer and click "Accept as Solution."
If you appreciate my answer, maybe give me a Kudo.

I am not a Roku employee.
0 Kudos
Steelersx
Level 8

Re: HELP - Sony Bravia light blinks red when streaming stick+ plugged in

Jump to solution

I have been complaining about this for over a year and no fixes

0 Kudos
DocNyr
Level 9

Re: HELP - Sony Bravia light blinks red when streaming stick+ plugged in

Jump to solution

Roku has not responded to this?? 

Hey Roku, please wake up and address this issue!!! 

Please!!

0 Kudos
RokuDanny-R
Roku Employee
Roku Employee

Re: HELP - Sony Bravia light blinks red when streaming stick+ plugged in

Jump to solution

Hi everyone,

Thanks for the posts.

Have you tried contacting your TV manufacturer support yet to inquire further? I'd suggest starting there to see what options or suggestions they can provide.

You can reach them here: https://www.sony.com/electronics/support


Thanks,
Danny

Danny R.
Roku Forum Moderator
0 Kudos
Crumbbum
Level 7

Re: HELP - Sony Bravia light blinks red when streaming stick+ plugged in

Jump to solution

Is there a solve beyond "contact Sony?" That's not really a solve. My PS4, Switch, another streaming devices work perfectly with the television.

0 Kudos
Dave810
Level 7

Re: HELP - Sony Bravia light blinks red when streaming stick+ plugged in

Jump to solution

Getting tired of this one. Every other streaming device from Apple, Amazon, Google, et al. Work just fine. My Roku Ultra, not so much. Any update, Roku?

0 Kudos
RokuDanny-R
Roku Employee
Roku Employee

Re: HELP - Sony Bravia light blinks red when streaming stick+ plugged in

Jump to solution

@Dave810

Thanks for the post.

Can you please specify your inquiry?

With more detailed information we will be able to assist you further.


Thanks,
Danny

Danny R.
Roku Forum Moderator
0 Kudos
Dave810
Level 7

Re: HELP - Sony Bravia light blinks red when streaming stick+ plugged in

Jump to solution

Sure.  I have a Roku Ultra with current software that is plugged into my Sony Bravia fulltime. Occasionally, when I go to power up the TV/Roku the Sony's light is blinking 'Red' and will not power on from either the Roku remote or the TV's remote.  Power cycling the Roku or TV has no effect.  If I unplug the HDMI cable from the Roku, I can then power up the TV just fine.  I then plug the Roku back in and all is well -- for a random period of time from a day or two to a couple weeks.  Back in May of 2019 (yes, two years ago) I experienced the same issue and a Roku software update fixed things for a year or so but now it's been back for at least 6 months.  I plugged in an Apple TV for a ~month and had no issues.

 

0 Kudos