Playback Issues - Audio/Video & Power

Help with audio & video playback issues, TV display type recognition & compatibility, HDCP messages, troubleshooting playback errors, advertisements, and resolving power issues.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
benananada
Level 7

Frame-rate matching no more

Under Advanced Display options (buried as deep as possible in Roku settings) there is an option that was the primary reason I got a Roku years ago. Frame-matching, essential for proper 24 and 23.976hz playback, which is 95% of all streaming content. Worked like a dream, until this year (AGAIN, 2020!?). One by one, most of the primary apps have failed to follow Roku's Frame-matching Directive.

Apps that worked and now have stopped playing correctly:

Netflix (1st to stop, most of a year ago) Consequently, I've watched far less of it this year

Hulu 

Disney+

And as of last week Apple TV no longer even loads the stream unless Frame-matching is turned off.

 

I've loved my Roku, but that's it. I'm done with weird looking juddery 60hz playback. If they can't or won't fix what was promised to me I'm moving on to a system that will. As far as I know that means an Apple TV4k. Anyone else have a suggestion or input, I'd love to hear it.

Tested on Roku Ultra

0 Kudos
7 REPLIES 7\
benananada
Level 7

Re: Frame-rate matching no more

Wow....nothing. No response. Well, I guess I'm moving on to Apple TV 4k while it's on sale then. Really sad. Loyal Roku user no more.

0 Kudos
2Woofs
Level 7

Re: Frame-rate matching no more

I am having the exact same problem with Netflix.  I have an Ultra that I purchased in April.

This is a new problem that has surfaced in the last month.  I have not seen the frame matching setting in the last week or so.

I find that if I switch my TV off and then let the Roku set the Display, it will recognize HDMI 2.2 for t hat session only.  But this is a PITA solution.

I will contact Roku Support and see what they say.  I have a feeling that this is affecting quite a few users.

 

 

0 Kudos
2Woofs
Level 7

Re: Frame-rate matching no more

I contacted Roku Support on this and if was an ORDEAL.

The system would not accept an email report, so I did a chat.  Seeing that this problem started with the new software version did not seem to make a difference to the "tech".  I wasted nearly an hour with try this, try that, maybe your cable is bad, etc. etc. of things I already tried.

Finally, out of  exasperation...  Well I will show an excerpt from the transcript: 

(08:05:01)

RIck: It was perfect in this past with Frame Matching set to OFF,

(08:06:25)

Kezi: The auto-adjust display type is an alternative for the frame rate settings, Rick.

(08:07:15)

RIck: Are my years of using Roku coming to a close?

(08:07:41)

Kezi: I'm sorry for the trouble, Rick.

(08:08:14)

Kezi: Since it is a recurring issue, how about I check the device information from my end and follow up via email to resolve the issue for you?

(08:09:29)

RIck: that is fine. You may also want to look at the forums and see others with this same issue, I doubt that we all had cables go bad at the same time. Everything I see points to the new software update.

(08:10:38)

Kezi: Yes, Rick, we are working to resolve it, and I would forward your concern to our team to fix it at the earliest.

(08:11:24)

RIck: OK - enough time on this. I will watch for some good news in the email.

(08:11:50)

Kezi: Sure, Rick, please use this ticket number for reference #5015464.

 

So, as it stands, at least there is a ticket and hopefully we can get this resolved.

0 Kudos
atc98092
Community Streaming Expert

Re: Frame-rate matching no more

Framerate matching on Netflix was stopped several years ago because Netflix has that annoying auto-playback of videos in the background of the main screen. Because of the framerate screen blanking, there were many, many complaints, and since Netflix wouldn't stop the video playing Roku locked out framerate matching. The same issue popped up with a couple of other channels. In most cases, it's the channel developer that has disabled framerate matching, not Roku. 

In general, there's no problem with frame-rate matching. But the screen blanking that happens with the change of frame rate generates many complaints as well. For users that understand what's happening, it's not a problem. But that's why the setting is under the advanced stuff, so people who don't care leave it alone. For myself, I have as much problem with it enabled as some do with it disabled. Playing media from my home server causes lots of video stuttering if I turn it on, so for my use it's better turned off. Your mileage may vary. 

Dan

Roku Community Streaming Expert

Help others find this answer and click "Accept as Solution."
If you appreciate my answer, maybe give me a Kudo.

I am not a Roku employee, just another user.
0 Kudos
2Woofs
Level 7

Re: Frame-rate matching no more

I have to think that the Frame Matching control either had some other unintended consequences or something else is going on.  I had this problem with recognizing the level of the HDMI ports in the past and turning explicitly FM off eliminated the problem.  Now the problem is much more difficult to control.

What I can say is that this issue appeared 4 days ago when my software updated to 10.5.0 build 4198-C2.

I will also take a look at the power saving and see if it may be playing a a role in this.

BTW, I had issues with my Plex server stuttering over WIFI and switched it to a wired connection.  That solved that.

0 Kudos
atc98092
Community Streaming Expert

Re: Frame-rate matching no more

My stuttering was a different issue than bandwidth. it was literally the video frames moving, pausing, and then moving again as a steady stutter. Audio continued playing fine. It was just unwatchable, and it only occurred with MPEG-2 video. No problems with H.264/265. Ripped DVDs were the worst. And that was on a wired connection. Smiley Happy

Dan

Roku Community Streaming Expert

Help others find this answer and click "Accept as Solution."
If you appreciate my answer, maybe give me a Kudo.

I am not a Roku employee, just another user.
0 Kudos
2Woofs
Level 7

Re: Frame-rate matching no more

Just as a follow up to my earlier message, I disabled the Power Saving feature several days ago and am no longer experiencing the issue.  

I am still trying to get my head around this but everything is working as expected now.

0 Kudos