Playback Issues - Audio/Video & Power

Help with audio & video playback issues, TV display type recognition & compatibility, HDCP messages, troubleshooting playback errors, advertisements, and resolving power issues.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Highlighted
Level 8

Dolby Digital/+ Issues - Configuration Requirements and Playback

Jump to solution

Yesterday I got the update and now its not sending out anything other than a stereo signal.  I pass HDMI to the TV, and Optical out of the TV to my receiver.  The roku is the only device having the issue.  I've tried setting HDMI to "Auto" and the more direct choice such as "dolby digital, DTS" etc.  I've moved inputs around with other devices.  They all work fine no matter which HDMI input on the TV that I use except the Roku.  Why is there not an option to rollback updates?  Is a fix coming?

5 Solutions

Accepted Solutions
Highlighted
Level 7

Re: Update 9.2 broke dolby digital

Jump to solution

I am using a Roku Express 3900RW that I bought from Walmart about 6 months ago.  App shows Software 9.2.0.4806.   My AVR is Onkyo TX-NR636.  

I verified that the AVR "Input" shows DD+ and the "Output" shows the same.    I do get sound out of my center channel as well.   

Before I turned off the "Volume leveling" in the Roku my AVR "Input" showed as PCM 2.1 going to all speakers (not sure about center one though).    Turning off the "Volume leveling" while playing a movie in Vudu instantly fixed my issue.

I hope this helps someone.  

View solution in original post

Highlighted
Level 19

Re: Update 9.2 broke dolby digital

Jump to solution

@sgmfish Thanks for sharing. 

Your model of Roku device does support Dolby/DTS passthrough, however, the Hulu channel on Roku does not currently broadly offer multi-channel surround sound audio formats. This is why you may not get surround sound with Hulu. You can follow up with Hulu support directly for more information regarding supported content audio/video formats for your specific device. 

The 'Volume modes' feature that we offer also does not apply to multi-channel surround sound formats, and would cause your device only to play stereo audio. You'd need to disable this feature by pressing the * key during playback of content inside a channel, locating 'Volume mode' and turning this to 'off'.

Auto-detect is usually the best option for most folks, as different channels provide different audio formats. Some channels, like Netflix and Amazon Prime, use the Dolby Digital+ format for their surround sound audio. Others may use standard Dolby Digital 5.1, etc. or only offer 2 channel stereo audio. You'll always want to check the content details page inside any particular channel to see what audio formats are offered for each content title. You can also confer with any specific channel provider directly to inquire further regarding their content format offerings on the Roku platform. 

 

Thanks,

Tanner

View solution in original post

0 Kudos
Highlighted
Level 12

Re: Update 9.2 broke dolby digital

Jump to solution

@Wsb wrote:

I tested also.  Volume leveling off.  “Auto” selected.  Tested with amazon prime on a movie that said 5.1 supported. Sound was PCM.  Only Roku channel delivers 5.1.

im using the newest Roku ultra with a Yamaha receiver that supports Dolby dts 


Roku only passes through Dolby audio to the device it's connected to.  Amazon Prime uses Dolby Digital PLUS (DD+) surround.  Same for Netflix - Dolby Digital Plus.  If you're connecting your Roku to a receiver/AVR that does not support Dolby Digital Plus surround, you'll get stereo-only. It's as simple as that. 

Some people connect their Rokus to their TV, and then use the TV's Optical Out to send to their receiver that does not support Dolby Digital Plus but DOES support regular-old Dolby Digital (non-plus). In this case, it's the TV that's doing the converting of the surround sound. In these cases where the TV supports this, the TV is converting Dolby Digital Plus to standard Dolby Digital, and then sending it on to the receiver.  For that to work, your TV needs to be able to do the DD+ --> DD conversion. This is not a Roku issue. This is whether your TV supports DD+ conversion down to regular DD.

 

 

 

 

View solution in original post

Highlighted
Level 8

Re: Update 9.2 broke dolby digital

Jump to solution

And I am very thankful for this thread as well. I also had tried all kinds of things to get Dolby Digital and Digital plus working again and all I was getting was stereo. I have a very straightforward setup with my Roku Premier + connected to my receiver and the receiver connected to the TV all via HDMI. After reading this thread, I discovered that leveling was on even though I don't think I ever set that. After turning it off, I simply told my receiver to reset the audio and mid stream, it immediately started providing Dolby Digital plus again. No resetting to defaults or rebooting devices. I'm all set and thanks again to everyone who contributed to this thread.

View solution in original post

0 Kudos
Highlighted
Level 9

Re: Update 9.2 broke dolby digital

Jump to solution

Solved - quick update and full disclosure:  I was wrong, it was a Netflix account setting that was limiting the audio for us.  At some point (this ski vacation) the playback settings for "Data usage per screen" got lowered.  I could not find much information on how the audio gets affected for each setting (Auto, Low, Medium, High) but apparently lowering the quality of the video also lowers the quality of the audio.  This makes sense, as Dolby Digital 5.1 & DD+ is going to use more bandwidth than stereo.  Ticked it back to "High" and Lo and Behold, 5.1 audio is back.

I kept at this because it made no sense to me that every other app that normally worked in 5.1 still worked fine and my OCD wouldn't let me quit troubleshooting (it's a curse).  Thanks to all who helped and I retract my statement about Roku audio issues, as it's not Roku's fault when someone is all eat up with the Dumass.

View solution in original post

233 Replies
Highlighted
Level 7

Re: Update 9.2 broke dolby digital

Jump to solution

I am having the same problem. No Dolby Digital, only Stereo

Highlighted
Level 13

Re: Update 9.2 broke dolby digital

Jump to solution

@thedo @Effinae 

 

Same here. Since 9.2 OS update my soundbar is not indicating that 5.1 audio is detected. Soundbar is doing a decent job of simulating Surround, but not what we should expect. Oddly, my soundbar does recognize Dolby ATMOS audio from shows such as Jack Ryan and Carnival Row and from the demos on DOLBY app. Just seems to be an issue with 5.1 audio specifically. Not sure if that means DD/DD+ is the issue if ATMOS can be recognized.

TCL-TV Roku 55P605 (4K HDR & DV) | VIZIO SB36512‑F6 ATMOS Soundbar
TCL-TV Roku 43S425 (4K HDR) | TCL-TV Roku 32S301 (720p) | Fire TV Stick 4K
Highlighted
Level 8

Re: Update 9.2 broke dolby digital

Jump to solution

I have the same problem and reported it to customer service that seems to be non existent. To fix it temporally, when the Dolby Digital + video starts to play and I get no sound, I pause the video, rewind it, and believe it or not, the DD+ plays.

Interestingly, it the video is HDR then the DD+ plays automatically.

Highlighted
Level 7

Re: Update 9.2 broke dolby digital

Jump to solution

I am having the same problem with Roku Express.

0 Kudos
Highlighted
Level 8

Re: Update 9.2 broke dolby digital

Jump to solution

Same issue here no Dolby pass thru, every other device I own passes through the Tv to optical out no problems for Dolby 5.1. 

Highlighted
Level 8

Re: Update 9.2 broke dolby digital

Jump to solution
I had the same issue. I did a factory reset and I now get surround sound again.
Highlighted
Level 8

Re: Update 9.2 broke dolby digital

Jump to solution

I have the same problem. I just bought the ultra yesterday and connected the device via HDMI to my receiver. I received the 9.2 update during my setup. I logged into Netflix and HBO GO and selected movies I know play in 5.1, and I’m only getting 2.1 sound when I’m playing from these apps. What’s interesting is, when I select free stuff from the Roku menu and play something from there, my receiver detects the signal and plays the Dolby digital 5.1 sound. I tried this on a few different movies from the free section. When, I play a movie using the Netflix or HBO app, I only get 2.1 and my receiver does not detect the signal. I’ve reset my device to factory defaults and this did not fix the issue. I made sure Netflix was not in night mode and all those options are turned off. If I use my smart tv connected to the same receiver to play a movie using the Netflix or HBO app, I get 5.1 audio. I don’t understand why the app via Roku is not sending 5.1 surround sound??  From what I’ve read there was an update that broke the decoding. Will this be fixed?

Highlighted
Level 7

Re: Update 9.2 broke dolby digital

Jump to solution

I tried a factory reset and I still have the audio problem.

0 Kudos
Highlighted
Level 8

Re: Update 9.2 broke dolby digital

Jump to solution

What I notice is that things on Amazon Prime or Netflix that are in atmos no longer show up as atmos.  My Ultra is connected through the AVR (MRX1120), which plays atmos from other sources (e.g. Oppo 203).

It is as if the ROKU now thinks only 5.1 signles can pass and so downgrades the audio.

0 Kudos