Playback Issues - Audio/Video & Power

Help with audio & video playback issues, TV display type recognition & compatibility, HDCP messages, troubleshooting playback errors, advertisements, and resolving power issues.
cancel
Showing results for 
Search instead for 
Did you mean: 
srober76
Level 7

Audio missing anyone Roku3

I tried the troubleshooting guide with no solution.  Today our Roku 3 has no audio when streaming Netflix, Hulu, Amazon does not matter.  I do have video and I am getting menu noise.  I have rebooted, switched HDMI cables, tried different HDMI inputs, changed audio to stereo and PCM-stereo.  I find it odd I have video and sound in the roku menu but as soon as I stream only video.  I did notice the Roku auto updated this morning at 5am.  Im thinking this latest update broke something.

Anyone else having these issues?  Anyway to rollback a update to see if it clears the problem? 

Thanks
0 Kudos
17 Replies
Basil
Level 10

Re: Audio missing anyone Roku3

I just launched a video on Amazon and it played fine.

So, we need to find out more about your setup.

Which Roku 3? What’s the model number?

What firmware? Don’t say “latest.” Your latest might not be my latest. On one device, latest is 8.1 while on another, latest is 8.0.1, while on another, latest is 8.0. They all say “up to date.” That’s why we need specifics. Software version and build.

What version Prime Video, including build?

What’s your a Roku connected to? TV? Sound system?

What are your Audio settings? Don’t say “tried them all.” On my simple setup, there are 48 possible combinations. Need specifics. List how they’re set.

It may be that your setup is sufficiently different from mine that I can be of no use, but others might.
Basil
https://www.basilsblog.com/
Roku Ultra (4660)
Apple TV (5th gen), TiVo

Previous:
Roku boxes from every generation.
Apple TV (2nd, 3rd, 4th gen)
0 Kudos
Lorcanh
Level 7

Re: Audio missing anyone Roku3

I have the same issue as original poster. I was watching a movie using Plex last night, went to bed then when I woke this morning no sound on Netflix, Plex or YouTube. I do have sound on the menu and the Angry Birds game which is strange.

My software version is 8.1.0 on Roku 3 model number 4230x. Audio mode is Stereo and HDMI is PCM Stereo. I just checked for a system update but the last updated is 3:35am. All help appreciated.
0 Kudos
ARRR
Level 7

Re: Audio missing anyone Roku3

Yes! The exact same problem here! My Roku updated yesterday(June 26) at 11:26pm CST. Roku menu beeps and boops (technical term) but no audio from video or music apps (Sling, Netflix, Roku Channel, Pandora). My hunch is that it has something to do with this latest build release.

Roku 3 - Model: 4230X1
Software version: 8.1.0
Build: 4131
Connection: Roku > TV via HDMI
Audio Mode: Stereo
HDMI: PCM-Stereo
0 Kudos
srober76
Level 7

Re: Audio missing anyone Roku3

I had the same firmware/build as the other two with this problem, updated this morning.

I dont think it matters on the Prime Video build as it does it to every streaming service I tried.  YouTube, Netflix ect ect

My Roke is connected to TV through HDMI cable

I have two audio settings by default they was both on auto, I changed them to Stereo and PCM-Stereo as the troubleshooting guide suggested.

Can firmware be rolled back to rule out that?
0 Kudos
iith096
Level 7

Re: Audio missing anyone Roku3

I had the same no audio with any streaming channels and discovered the ATT DirecTV NOW app was the culprit.  I removed the app, and all sound was restored to all my streaming channels. Hope this helps someone. 
0 Kudos
Ldkap
Level 7

Re: Audio missing anyone Roku3

Same thing happened to me. Anyone hear from Roku about a fix??
0 Kudos
Lorcanh
Level 7

Re: Audio missing anyone Roku3

Unfortunately I've never had the ATT DirecTV NOW app installed so that's not an option. I've deleted most of the streaming channels but still no audio. Very frustrating.
0 Kudos
omstr
Level 7

Re: Audio missing anyone Roku3

Same issue here.  I talked to support on chat and they acted like they had never heard of this.  We watched a show right before the 8.1.0 build 4131-04 and everything was fine.  Right after the update we weren't getting sound and it's been like that for 48 hours.  We can hear the clicks when we use the remote and it plays the song during startup, but audio is totally dead during all videos (and I tried Pandora and nothing there either).  I tried the troubleshooting steps (power cycling, switch to PCM, stereo vs 5.1, etc., etc.) but nothing else.
0 Kudos
cubanorafter
Level 7

Re: Audio missing anyone Roku3

FIX WORKED FOR ME:

I had the same issue with my Roku3 after the update. No audio out on any app to my TV or Receiver. Only audio that worked was the Roku menu.
I attempted to adjust the audio settings, remove apps, reboot, etc and nothing fixed the audio issue.

I decided to do a factory reset and that fixed the audio issue. Verified that I am still on 8.1 and all apps I have tested are working (Netflix, Amazon Prime, PBS Kids, Disney, Plex, HBO, Showtime)
Of course I had to link all those apps again with my cable TV provider so keep that in mind...
0 Kudos