Playback Issues - Audio/Video & Power

Help with audio & video playback issues, TV display type recognition & compatibility, HDCP messages, troubleshooting playback errors, advertisements, and resolving power issues.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Level 7

Audio is Always PCM Stereo

I recently added a Roku Premier to my Home Theater.   The video quality is great, but the audio is always PCM Stereo.  My receiver indicates it is not getting any kind of surround information, as would occur in Dolby Digital or Dolby Digital+.     I mostly watch Hulu, but I've also tried numerous other apps including the Roku channel.  All of them have the same issue -- always PCM Stereo.  I know it's not my receiver because if I watch the same show via the same app through my BluRay player instead of the Roku, then I get Dolby.  It's only the Roku that sends as PCM Stereo.  I've tried all combinations of the Roku audio options from the settings menu  -- audio, only Dolby, only Dolby+,  only...   It's always the same result -- everything is PCM stereo.   Rebooting the Roku and/or installing latest updates also doesn't change anything.

Does anyone have ideas about how to get Dolby or other audio mode that has digitally encoding surround sound?

0 Kudos
3 Replies
Level 14

Re: Audio is Always PCM Stereo

Verify that Settings/Audio/HDMI="Auto detect" shows a detected Dolby mode (DD or DD+ etc) and Settings/Audio/Audio mode="Auto (DD etc..)"

If it doesn't detect any form of Dolby (DD or DD+), that would explain it.

Otherwise, if you enabled any "volume modes" ("Leveling" or "Night Mode") they disable multichannel output.

Verify you dont have them enabled:  press the options (*) button on your remote during actual playback, check that "Volume mode"=off.

 

Level 7

Re: Audio is Always PCM Stereo

Thanks. I had leveling on.  After disabling volume modes, I can get Dolby audio.   I still get PCM during Hulu commercials and Hulu show intros, which can result in a dramatic change in volume between show and commercial.   If I don't hit mute during commercials, the sound is quite unpleasant.   However, this volume change sounds like a Hulu problem or something intrinsic to Dolby vs PCM stereo, rather than one with Roku.

Level 7

Re: Audio is Always PCM Stereo

This doesn't work on my R8F5 55 inch system. I do not get multipcm sound no matter what I use. Optical or ARC. When I 'force it' by setting the R8F5 to Dolby Digital plus, DTS I get partial surround the subwoofer drops out and I sometimes lose the center channel. Even using regular channels (used the Apple+ app) I only get PCM 2 channel stereo. (BTW, 'night mode' doesn't exist?)

When I by pass the internal audio processor using an HDMI extractor/converter/splitter I get full multipcm sound up to and including Dolby Atmosphere (gets converted to 7.1 since that's all I have)  using a NuForce AVP-18 sound processor. 

After trying pretty much everything I think a software update is in order to fix the audio system is in order for my system. 

0 Kudos