Playback Issues - Audio/Video & Power

Help with audio & video playback issues, TV display type recognition & compatibility, HDCP messages, troubleshooting playback errors, advertisements, and resolving power issues.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Data10
Level 7

Audio is Always PCM Stereo

I recently added a Roku Premier to my Home Theater.   The video quality is great, but the audio is always PCM Stereo.  My receiver indicates it is not getting any kind of surround information, as would occur in Dolby Digital or Dolby Digital+.     I mostly watch Hulu, but I've also tried numerous other apps including the Roku channel.  All of them have the same issue -- always PCM Stereo.  I know it's not my receiver because if I watch the same show via the same app through my BluRay player instead of the Roku, then I get Dolby.  It's only the Roku that sends as PCM Stereo.  I've tried all combinations of the Roku audio options from the settings menu  -- audio, only Dolby, only Dolby+,  only...   It's always the same result -- everything is PCM stereo.   Rebooting the Roku and/or installing latest updates also doesn't change anything.

Does anyone have ideas about how to get Dolby or other audio mode that has digitally encoding surround sound?

11 REPLIES 11\
StreamerUser
Level 20

Re: Audio is Always PCM Stereo

Verify that Settings/Audio/HDMI="Auto detect" shows a detected Dolby mode (DD or DD+ etc) and Settings/Audio/Audio mode="Auto (DD etc..)"

If it doesn't detect any form of Dolby (DD or DD+), that would explain it.

Otherwise, if you enabled any "volume modes" ("Leveling" or "Night Mode") they disable multichannel output.

Verify you dont have them enabled:  press the options (*) button on your remote during actual playback, check that "Volume mode"=off.

 

Data10
Level 7

Re: Audio is Always PCM Stereo

Thanks. I had leveling on.  After disabling volume modes, I can get Dolby audio.   I still get PCM during Hulu commercials and Hulu show intros, which can result in a dramatic change in volume between show and commercial.   If I don't hit mute during commercials, the sound is quite unpleasant.   However, this volume change sounds like a Hulu problem or something intrinsic to Dolby vs PCM stereo, rather than one with Roku.

lerici
Level 7

Re: Audio is Always PCM Stereo

This doesn't work on my R8F5 55 inch system. I do not get multipcm sound no matter what I use. Optical or ARC. When I 'force it' by setting the R8F5 to Dolby Digital plus, DTS I get partial surround the subwoofer drops out and I sometimes lose the center channel. Even using regular channels (used the Apple+ app) I only get PCM 2 channel stereo. (BTW, 'night mode' doesn't exist?)

When I by pass the internal audio processor using an HDMI extractor/converter/splitter I get full multipcm sound up to and including Dolby Atmosphere (gets converted to 7.1 since that's all I have)  using a NuForce AVP-18 sound processor. 

After trying pretty much everything I think a software update is in order to fix the audio system is in order for my system. 

0 Kudos
MVman
Level 8

New Roku Express 4K + PCM only

Just added a Roku express 4K+. 
Sound system is Sonos Arc with bar, sub and rear surrounds. When playing Netflix, Prime and YouTube TV without going through Roku, I get Dolby atmos and 5.1. When playing through Roku only get PCM???? I’m using the HDMI cable provided and my LG TV has 4 HDMI INPUTS, one is ARC. I’ve tried switching the new Roku connection to the ARC input and still my system says only receiving PCM signal. Any help appreciated. 

BigDragon
Level 7

Re: New Roku Express 4K + PCM only

I have the same issue.

Was wondering if you were able to solve it.

0 Kudos
MVman
Level 8

Re: New Roku Express 4K + PCM only

Sadly NO! So I use Roku only for their stuff. Use my TV for Netflix, Prime and YouTube TV

0 Kudos
BigDragon
Level 7

Re: New Roku Express 4K + PCM only

Just found the solution that works for me.

I had to switch in the roku audio settings "streaming audio format" to Auto while the audio mode is on Auto (DD+).

In the TV (samsung) the settings is on bitstream. 

I hope this helps.

0 Kudos
Dan84
Level 7

Roku Streaming Stick+ audio output is always PCM stereo (except for AppleTV)

I have a Roku Streaming Stick+ 3800 series, and an older Samsung TV UE48JU6400.

I have recently got a Sonos Beam (Gen 2), and no matter what Roku Audio setting combination I select, the Roku audio output registers on the Beam as PCM stereo for all apps except AppleTV.

The AppleTV app outputs from the Roku on Dolby 5.1, but Netflix, Amazon, Disney+, and BBC iPlayer all output in PCM stereo (even content that should have multichannel audio like a Marvel film).

I have the Roku audio settings as HDMI Audio--Auto (DD or DD+); Streaming Format--Auto; Audio Output--Auto. However, I have tried all combinations of the three in various settings (including Streaming Format--Dolby; and Audio Output--Custom-DD) and nothing changes. I neither have Levelling nor Night audio mode active.

The TV audio settings are HDMI Audio Input--Bitstream (other option is PCM); and Audio Output--Dolby Digital (other options are PCM and DTS). The TV does not have Passthrough as an option.

The Roku is connected to the TV via HDMI (port 1), the Beam is connected to the TV via the only HDMI-ARC port on the TV (port 3).

Notably, the Playstation 4 registers on the Beam with a Dolby 5.1 output, this is connected to the TV via HDMI (port 2). The Playstation audio output is set to Dolby Digital.

Thanks everyone.

0 Kudos
EghDragon
Level 7

Re: Roku Streaming Stick+ audio output is always PCM stereo (except for AppleTV)

I found that turning off the Menu sound in settings stops everything playing in stereo (PCM). Apparently, the Menu sound is in Stereo and then stays that way no matter what the sound format is from then on. This is a Roku bug. 

0 Kudos