Playback Issues - Audio/Video & Power

Help with audio & video playback issues, TV display type recognition & compatibility, HDCP messages, troubleshooting playback errors, advertisements, and resolving power issues.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
rburn99
Level 7

Audio from satellites only after switching to ultra

Jump to solution

We had the Roku stick and it started acting up.. locking up, rebooting. So we just purchased the Roku Ultra. Pulled the roku stick from the hdmi port on our Sony str-dh590 receiver and plugged the hdmi cable from the ultra into the same hdmi port. Seems like that should have been all that was needed. But audio only comes out the 2 satellite speakers now instead of the 3 front speakers (also comes out the subwoofer). When I swap the old roku stick back into the same hdmi port we get sound from all the speakers again. I've tried a different hdmi port on the receiver also with no change. The only audio option I saw in the roku settings was ac-4 dialog enhancement on or off. I tried both of those.

During setup it also said no 4k device found (or something to that effect) even though we have a 4k Verizon tv and the hdmi ports on the receiver are labeled 4k. I tried a few different hdmi cables as well. (I can live without 4k though but not without the speakers)

0 Kudos
1 Solution

Accepted Solutions
StreamerUser
Level 20

Re: Audio from satellites only after switching to ultra

Jump to solution

You didnt mention your Roku model # or firmware version: Settings/System/About

A few things to consider (assuming a 4800 Ultra):

1) Change audio output to passthrough:  Settings/Audio/HDMI=Auto passthrough - try again

2) Verify you arent applying Dolby/DTS/Etc "surround processing" to the HDMI input (though you may have an "auto surround" mode that only applies it to 2.0 channel sources) - try again

3) Unplug all devices (Roku/TV/AVR) from AC power for 10-15 minutes, then power them (fully on) again in the following order:  A) AVR B) TV C) Roku  - try again

 

View solution in original post

0 Kudos
2 REPLIES 2\
StreamerUser
Level 20

Re: Audio from satellites only after switching to ultra

Jump to solution

You didnt mention your Roku model # or firmware version: Settings/System/About

A few things to consider (assuming a 4800 Ultra):

1) Change audio output to passthrough:  Settings/Audio/HDMI=Auto passthrough - try again

2) Verify you arent applying Dolby/DTS/Etc "surround processing" to the HDMI input (though you may have an "auto surround" mode that only applies it to 2.0 channel sources) - try again

3) Unplug all devices (Roku/TV/AVR) from AC power for 10-15 minutes, then power them (fully on) again in the following order:  A) AVR B) TV C) Roku  - try again

 

0 Kudos
rburn99
Level 7

Re: Audio from satellites only after switching to ultra

Jump to solution

Thanks. Those audio settings are what I was looking for but when I hit options I only got one choice that had no effect. I was streaming so I could hear/test the audio. When I left all apps and saw settings on the 'home' screen that's when I found those audio choices and Auto Passthrough fixed it. Thanks again.

0 Kudos