Playback Issues - Audio/Video & Power

Help with audio & video playback issues, TV display type recognition & compatibility, HDCP messages, troubleshooting playback errors, advertisements, and resolving power issues.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Level 7

Audio dropouts with Ultra - Action desired from Roku

It is clear the Roku Ultra has a problem with Audio Dropouts.  The Roku Ultra is advertised at the best and most advanced Roku device to date.  The Audio Dropouts appear to occur only on the Roku Ultra, but not on other Roku devices such as the Premiere Plus (which I also use).

I, and I'm sure others, would like this repaired, and would like Roku to take the following actions:

1) Acknowledge the Roku Ultra device has a problem with Audio Dropouts.

2) Add this problem to the Roku Development Department's "Bug List".

3) Allocate some development resources to resolving this problem.

4) Provide we Roku Ultra users with regular "progress reports" until this problem is resolved.

 

Although many users have reported this problem, is appears as if Roku is ignoring this problem.  We, part of the Roku user community, are loyal Roku users, evidenced by our purchase of Roku's flagship product, and would like our Roku Ultra to function properly, and at least as well as our other Roku devices.  We understand that sometimes technology does not function completely as desired.  We can be understanding when this happens, as long as Roku does it's best to repair the problem, ideally in a timely manner.

In my personal situation, my Roku Premier Plus purchased two or so years ago, functions as advertised.  My Roku Ultra, located in a different room on a different TV, has this Audio Dropout problem.  This problem occurs across many different channels, and not on all videos.  When I could repeat the problem on my Roku Ultra with a specific video, when I watched the same video on my Roku Premier Plus, the video plays correctly without error.

I have performed all the the resets, reboots, and other troubleshooting actions, with no change in the problem.  I believe the problem is in the Roku Ultra software and possibly the hardware of this device.

Please allocate some development resources to resolving this problem, and keep us, your user community, updated regarding your progress.

Thank you