Playback Issues - Audio/Video & Power

Help with audio & video playback issues, TV display type recognition & compatibility, HDCP messages, troubleshooting playback errors, advertisements, and resolving power issues.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
McMike
Level 8

Audio dropouts with HE-AAC on Roku Media Player (RokuOS 10)

About a week ago I got RokuOS 10 on my TCL tv, and immediately some MKVs that I was watching in Roku Media Player (5.5 build 9) started to have an issue with the audio cutting out every 15 seconds or so for a split second. Volume leveling is off, sound mode is Normal.

I found other MKVs that don't have the same audio problem, and the only obvious difference is that the ones with the problem use HE-AAC and the ones that work fine are AAC-LC.

Anyone else notice anything like this?

Labels (1)
63 REPLIES 63\
SNACKeR
Level 8

Re: Audio dropouts with HE-AAC on Roku Media Player (RokuOS 10)

I've been experiencing the same issue, just started to happen recently. I use Plex, not sure if the problem is there or with Roku. I've been re-encoding to AAC to work around it. Pretty annoying though, I'm currently running ffprobe on all my videos to figure out which content I need to transcode.

keen
Level 9

Re: Audio dropouts with HE-AAC on Roku Media Player (RokuOS 10)

same here - since the ~may 13th update a lot of my content has audio drops when being direct played.   a lot of my context is x265/heaac, but I haven't tried to nail it down to something specific.  transcodes (plex user) perform OK (excluding transcode problems, but those are on me, not roku)

of course, the update before that broke volume-down for HDMI-CEC controlled devices (still not fixed), so.....

volcom45
Level 8

Re: Audio dropouts with HE-AAC on Roku Media Player (RokuOS 10)

I've been having this exact same problem since the 10.0 update last week. I sure hope there's an easy fix coming for this.

emichael0
Level 8

Re: Audio dropouts with HE-AAC on Roku Media Player (RokuOS 10)

Same thing for me with my TCL Roku TV on the Emby app. Every single (unskippable) update they push out breaks something about my setup. Absolutely infuriating.

linuxman
Level 7

Re: Audio dropouts with HE-AAC on Roku Media Player (RokuOS 10)

Me too. I use Plex mostly and this is happening with HE-AAC stereo. It’s really infuriating! Only since the update to Roku 10 a few days ago.

BigStingman
Level 8

Re: Audio dropouts with HE-AAC on Roku Media Player (RokuOS 10)

I was so happy that my audio sync issue was fixed, but now I too am suffering from the audio dropout problem with HE-AAC files.

SNACKeR
Level 8

Re: Audio dropouts with HE-AAC on Roku Media Player (RokuOS 10)

I have a lot of different content sources and the problem does seem restricted to HE-AAC only. I use this command to test my videos:

 

ffprobe.exe -v error -select_streams a:0 -of default=noprint_wrappers=1 -show_entries stream=profile my_video.mp4
McMike
Level 8

Re: Audio dropouts with HE-AAC on Roku Media Player (RokuOS 10)

All righty, it sure seems like 10.0 has a defect in playing HE-AAC. A lot of y'all use Plex, but I just use the Roku Media Player app, and all of us have the same issue. So how does one report a bug to Roku? I see that Roku employees sometimes pop into these forum discussions, but not always, and not this discussion. Is there something other than posting here?

TMUR
Level 7

Re: Audio dropouts with HE-AAC on Roku Media Player (RokuOS 10)

Yes @McMike! Having this exact same issue on my multiple 4-series TCL Roku 4K TVs and also Roku Streaming Stick + (3810, 3811 series) since the OS 10.0 update. MKVs encoded with HE-AAC (AAC LC SBR) have the same audio dropouts that you are experiencing. All other audio formats seem to play without a hitch. I experimented with volume leveling (it was already off); sound mode (normal); all audio/passthrough settings (no difference); and sound bar vs tv speakers (same on both). Also tested playback on non-Roku devices/pcs and do not have the audio dropout issue elsewhere, only on all Roku devices with OS 10.0.