Playback Issues - Audio/Video & Power

Help with audio & video playback issues, TV display type recognition & compatibility, HDCP messages, troubleshooting playback errors, advertisements, and resolving power issues.
cancel
Showing results for 
Search instead for 
Did you mean: 
malrats
Level 8

55S401 major audio delay issues...even when using an AVR! What is going on?!

This is an issue I’ve been having since November. It’s driven me crazy at this point. My Roku TV introduces 100ms audio delay to PCM and 200ms audio delay to Dolby Digital/DTS, regardless of an Optical or HDMI-ARC connection. I tested out 7-8 separate sound bars and they all had the delay.

Now I even have an AVR with a delay! I don’t know how it’s doing this, given that the AVR is supposed to handle the audio processing now. The Roku TV is connected to the AVR via HDMI and Optical (also tried with just HDMI) and then all sources (Xbox One X, DirecTV, etc) are connected to the AVR via HDMI. They all have a 100ms audio delay, regardless of connection type.

The ONLY thing that has zero delay is the internal Roku TV speakers. I’ve tried every single configuration, setting, connection, etc that I could possibly think of or have been recommended and there is consistently a delay.

This is so far beyond unacceptable and ridiculous. And I’ve done support with Roku for months now to the point where their response is, “We’ll let you know it we ever figure out something that fixes this.”

...Wow.
TCL 55S401 Roku TV (Unsolved audio/video lag issues!)
0 Kudos
23 Replies
jeffrok
Level 11

Re: 55S401 major audio delay issues...even when using an AVR! What is going on?!

Doesn't your AVR have an adjustment for audio? Like a lipsynch setting or a manual millisecond adjustment? Mine has it, and I've had to use it for my cable box.
Yeah, I got some Rokus.
https://youtu.be/d1CSEeqWl10
0 Kudos
malrats
Level 8

Re: 55S401 major audio delay issues...even when using an AVR! What is going on?!

"jeffrok" wrote:
Doesn't your AVR have an adjustment for audio? Like a lipsynch setting or a manual millisecond adjustment? Mine has it, and I've had to use it for my cable box.


It does, but it’s only to ADD a delay from 5-500ms, and I need the delay reduced by about 100ms.
TCL 55S401 Roku TV (Unsolved audio/video lag issues!)
0 Kudos
jeffrok
Level 11

Re: 55S401 major audio delay issues...even when using an AVR! What is going on?!

What's the brand and model of the AVR? Is there possibly a firmware upgrade for it?
Yeah, I got some Rokus.
https://youtu.be/d1CSEeqWl10
0 Kudos
malrats
Level 8

Re: 55S401 major audio delay issues...even when using an AVR! What is going on?!

"jeffrok" wrote:
What's the brand and model of the AVR? Is there possibly a firmware upgrade for it?


It’s a Pioneer VSX-532. No firmware upgrade that I could find.

I also just grabbed a Denon S540BT. Same delay! Doesn’t make sense because even sources that are only connected to the receiver have the delay, like my Xbox. It doesn’t make sense.
TCL 55S401 Roku TV (Unsolved audio/video lag issues!)
0 Kudos
jeffrok
Level 11

Re: 55S401 major audio delay issues...even when using an AVR! What is going on?!

Yeah, if it's happening with both AVRs, I'm not sure you can do anything to fix it.. see if you can get a replacement Roku, because I'd consider this unacceptable.
Yeah, I got some Rokus.
https://youtu.be/d1CSEeqWl10
0 Kudos
Kippiis
Level 7

Re: 55S401 major audio delay issues...even when using an AVR! What is going on?!

Agree. Seems like a hardware issue.
0 Kudos
Heyitsrick
Level 10

Re: 55S401 major audio delay issues...even when using an AVR! What is going on?!

What's the actual make/model of the Roku TV?  

And note: I know you don't want to hear this, but it's not really a "Roku" issue. It's the TV's manufacturer (e.g. TCL), since it's undoubtedly their processing that's affecting the audio - particularly as you said it happens on other external inputs.
0 Kudos
Highlighted
malrats
Level 8

Re: 55S401 major audio delay issues...even when using an AVR! What is going on?!

"jeffrok" wrote:
Yeah, if it's happening with both AVRs, I'm not sure you can do anything to fix it.. see if you can get a replacement Roku, because I'd consider this unacceptable.


It’s outside of warranty, so they won’t replace it.
TCL 55S401 Roku TV (Unsolved audio/video lag issues!)
0 Kudos
malrats
Level 8

Re: 55S401 major audio delay issues...even when using an AVR! What is going on?!

"Heyitsrick" wrote:
What's the actual make/model of the Roku TV?  

And note: I know you don't want to hear this, but it's not really a "Roku" issue. It's the TV's manufacturer (e.g. TCL), since it's undoubtedly their processing that's affecting the audio - particularly as you said it happens on other external inputs.


It’s a TCL 55S401 Roku TV.

And the thing that I don’t understand is that with an AVR, the TV shouldn’t be doing any processing. As far as I knew, it’s purely hooked up as a screen. So how does it even get a chance to mess up the audio?

Also, for what it’s worth, Roku is who updates the firmware and it was the update in November that really introduced this issue. Everything was great before that.
TCL 55S401 Roku TV (Unsolved audio/video lag issues!)
0 Kudos