Playback Issues - Audio/Video & Power

Help with audio & video playback issues, TV display type recognition & compatibility, HDCP messages, troubleshooting playback errors, advertisements, and resolving power issues.
cancel
Showing results for 
Search instead for 
Did you mean: 
ziloni
Level 8

5.1 Multichannel sound only works on one Roku

Jump to solution

I have 3 Rokus, 3 different models. The only change I am making is to swap out the Rokus, otherwise ALL is the same including the source streams.

Source is 5.1 surround sound, output is capable of handling surround sound and is connected via optical cable from the TV. Roku connected to TV via HDMI.

1) Roku Express 3900R - No multi channel sound detected by receiver. Audio in Roku settings is set to Dolby.

2) Roku Ultra - No multi channel sound detected by receiver. Audio in Roku settings is set to Dolby.

3) Roku 2 - 4210R - This is the only Roku I can get to emit 5.1 surround sound to the receiver. Unfortunately this model doesn't have private listening, so I can't keep it in the location I need the 5.1 surround sound.

Labels (1)
0 Kudos
1 Solution

Accepted Solutions
ziloni
Level 8

Re: 5.1 Multichannel sound only works on one Roku

Jump to solution
I read that turning on "Night Listening" can cause this. I went to turn it off as I definitely had it enabled on the Ultra. However the menu option no longer exists for Night Listening? I thought I was going crazy, so I looked it up.. yep.... its supposed to be in the Settings, Audio - but its not there any more?? I have only HDMI, Menu Volume, and Audio Mode (Set to Dolby DTS). It doesnt match the screenshots online....

Update:
Was able to turn it off by playing a video and using the * key. Now the Ultra sends 5.1 sound properly. Second update.. The Express had night mode on as well... turned it off but have to move it to retest it. I expect this will fix it.

I think maybe this should be well documented or even a warning when turning night listening on....

View solution in original post

6 Replies
twiceover
Level 11

Re: 5.1 Multichannel sound only works on one Roku

Jump to solution
So the setups is ROKU<HDMI>TV<OPTICAL>RECEIVER -> Speakers

DD+ does not transmit over Optical to your receiver, that is most likely the reason you do not have 5.1 (depending on source content) at the receiver.  Now why the Roku2 does?  I want to say I read somewhere long ago that the Roku2 converted DD+ to DD which would then pass along your chain.  I could be wrong about this though.
0 Kudos
ziloni
Level 8

Re: 5.1 Multichannel sound only works on one Roku

Jump to solution
I read that turning on "Night Listening" can cause this. I went to turn it off as I definitely had it enabled on the Ultra. However the menu option no longer exists for Night Listening? I thought I was going crazy, so I looked it up.. yep.... its supposed to be in the Settings, Audio - but its not there any more?? I have only HDMI, Menu Volume, and Audio Mode (Set to Dolby DTS). It doesnt match the screenshots online....

Update:
Was able to turn it off by playing a video and using the * key. Now the Ultra sends 5.1 sound properly. Second update.. The Express had night mode on as well... turned it off but have to move it to retest it. I expect this will fix it.

I think maybe this should be well documented or even a warning when turning night listening on....

View solution in original post

ziloni
Level 8

Re: 5.1 Multichannel sound only works on one Roku

Jump to solution
"twiceover" wrote:
So the setups is ROKU<HDMI>TV<OPTICAL>RECEIVER -> Speakers

DD+ does not transmit over Optical to your receiver, that is most likely the reason you do not have 5.1 (depending on source content) at the receiver.  Now why the Roku2 does?  I want to say I read somewhere long ago that the Roku2 converted DD+ to DD which would then pass along your chain.  I could be wrong about this though.

Receiver isn't DD+, only DD. Its an old receiver but quality. I had 2 newer ones but both a Sony and Onkyo died within 1 year so I went used but much higher end. Its already outlived any newer receiver. Smiley Happy

Also the optical is from my TV to receiver, Roku is sending audio to TV via HDMI.

The Rokus do pass through. The problem was night listening... when its on it decodes and reencodes.. turning that off fixes the 5.1 issue. Both on this forum and in Google this is a common issue, but few have resolved or learned why. I was lucky to find something in a reddit thread.
0 Kudos
atc98092
Level 16

Re: 5.1 Multichannel sound only works on one Roku

Jump to solution
Yeah, Roku has never made it clear to many users that Night Mode, or any other volume modification mode, switches the output to 2 channel stereo. It's out there, but not well publicized. 
Dan
Roku Stick (3600), Ultra (4640), Premiere (3920), Insignia 720p Roku TV, Sharp 4K Roku TV, Nvidia Shield, Windows 10 Pro x64 running Serviio and Plex on a wired Gigabit network.
0 Kudos
whoiscarmine
Level 7

Re: 5.1 Multichannel sound only works on one Roku

Jump to solution

@ziloni You're a hero. This was driving me nuts and I stumbled upon this thread. Setup a new Samsung soundbar today with HDMI ARC connection to my Samsung TV and the Roku (Ultra 4660x) was refusing to send the soundbar a 5.1 stream. The built-in native Samsung apps were fine. This "feature" needs to be highlighted better in Roku's options on what it does and not buried in some silly secret menu. 

0 Kudos
tmundal
Level 7

Re: 5.1 Multichannel sound only works on one Roku

Jump to solution

Thanks for this post.  I was about to start a whole new thread because I couldn't get DD sound through my streaming stick 3810R via ARC, or directly plugged into my AVR.  But then I went and checked this and while it wasn't set to night mode, it was set to low volume leveling.  Turned that off, and now I have DD+ while directly plugged into AVR.  Going to try using it with ARC later.  Hopefully it works because my wife generally prefers not to have to mess with the sound system at all and just watch directly through the tv, whereas I like to make the walls shake so to speak Smiley Wink

0 Kudos