Network - Wireless & Wired Connections

Help & troubleshooting for network issues, including connecting your device to your home Wi-Fi network, connecting to public networks, troubleshooting wireless issues & ethernet connections, and optimizing streaming performance.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
MJmusicguy
Level 8

Wrong WIFI channel?

Since updating dating to version 10.0 my roku seems to jump between channel 48 (the default channel which i have 5GH set to)  and 149 (the one reserved for our cable boxes)

my question is why does reoku detecting 149 and not abiding by my default channel this was never a concern until 10.0

 

0 Kudos
7 REPLIES 7\
AvsGunnar
Community Streaming Expert

Re: Wrong WIFI channel?

If using a tri-band router (2 separate 5ghz networks and one 2.4ghz network), try renaming one of the 5ghz BSSIDS to clearly distinguish the bands.  

If both 5ghz BSSIDS using same network name, likely router itself, not the Roku, trying to automatically balance the device distribution between wireless channels.  Could be Roku seeing the higher frequency as being better connection but you can override behavior during Roku Network Setup if separate network names.

Since OS10 is recent, I can't claim the above is an absolute...possibility there is a bug. 

If above not the case in your instance, post back with your router model number and Roku device.

 

Roku Community Streaming Expert
Just another Roku user... I am not a Roku employee.
Insignia RokuTV, Ultra 4660x, Premiere+ 3921, Express 4k+ 3941
0 Kudos
MJmusicguy
Level 8

Re: Wrong WIFI channel?

Hi @AvsGunnar  it is a duel band

I have the networks separated and channels are manually set

 

 

 

0 Kudos
AvsGunnar
Community Streaming Expert

Re: Wrong WIFI channel?

If using dual-band (1 5ghz band and 1 2.4 ghz band) router, then should only be seeing one 5ghz channel (frequency) if you are sure manually assigned.  Unless you are using multiple access points (APs, extenders, additional routers) in network, don't understand how you reserved/set different 5 ghz channels for different devices on a single 5ghz band before update.

Are you using multiple APs or a router in addition to the ISP modem.  Maybe describe your network a little and provide router model number and ISP provider so I and others can look into it a bit. (Or maybe others already know).  Could be I am missing something or reading your issue wrong.

Screenshot of 5ghz Wireless Settings may also be helpful.

Roku Community Streaming Expert
Just another Roku user... I am not a Roku employee.
Insignia RokuTV, Ultra 4660x, Premiere+ 3921, Express 4k+ 3941
0 Kudos
MJmusicguy
Level 8

Re: Wrong WIFI channel?

@AvsGunnar 

I am only using the isp provided system manually configured by myself and never had a problem like this prior to Roku os 10 not only that  but on this modem channels higher then 48 are restricted to consumers

0 Kudos
AvsGunnar
Community Streaming Expert

Re: Wrong WIFI channel?

Gotta tell you, @MJmusicguy , I strongly suspect that this ISP supplied and managed modem router is a tri-band, evidenced by being able to see two 5 ghz frequencies on same 5ghz band.

Also likely that the upper frequency BSSID is actually automatically configured to accept the lower frequency BSSID.  Creating more a mesh network than true separate 5ghz bands.  Can verify above somewhat by changing ch48 to ch36 and see if upper ch149 also changes. (May not depending on ISP configurations).

Regardless, and without more info from you, I really think the Roku is changing to the higher frequency because the BSSID is the same and it is better connection.  If not affecting performance, then let it do it's thing.

 

Roku Community Streaming Expert
Just another Roku user... I am not a Roku employee.
Insignia RokuTV, Ultra 4660x, Premiere+ 3921, Express 4k+ 3941
0 Kudos
MJmusicguy
Level 8

Re: Wrong WIFI channel?

@AvsGunnar  here is the router it is branded by my isp  but this is what i found

http://www.dslreports.com/hardware/Sagemcom-F-st-5566-h4553

 

0 Kudos
AvsGunnar
Community Streaming Expert

Re: Wrong WIFI channel?

Ok, nice job with model link @MJmusicguy .  Found some time to do some prelim. researching on it for you this evening.  So the Sagemcom F@st 5566 seems to be the Bell Home Hub 3000 which is a tri-band router. (Mainly Bell Canada).  Now, by default, seems that it also uses the same SSID name for all three bands.  It also has a "Manage Wi-fi" section that has "Whole Home Wi-fi" enabled by default.  This is basically the mesh system that allows devices to "roam" between the bands the router determines will provide the best connection of a wireless device.  

If this indeed is what you you are seeing on your end, it is basically your router automatically changing between the 5.0 ghz bands (low and high channels/low and high frequencies).  If the 5.0ghz bands are deemed inadequate (somehow gets overly crowded), this router may/will switch a device to the 2.4ghz band.  Unlikely, but it can if the 2.4 ghz band SSID is not different from 5.0ghz SSID. (You said you seperated, so not concern for you.  However, both 5.0 ghz bands share same SSID by default so those are working in tandem.)

You can apparently disable the mesh feature by disabling the "Whole Home Wi-fi" toggle button.  This apparently will allow you into a more extensive "Advanced Settings" page that allows you to provide individual SSIDS to all three bands (create three individual networks with no automatic band steering.)

I didn't come across a router simulator for this model since I just did some quick looking so can't confirm the extent of advanced settings available to the end user.  (some ISPs hobble user input with their firmware).  Seems like a very good system especially when paired with their pods - rave reviews of system.

So after all that, seems like router is just doing its thing automatically... connecting devices where it sees fit.  The channel reservation you mentioned really wasn't a "reservation".  Basically, your manual setting is just telling the router.. "When using the lower 5.0 ghz band frequency, please use channel 48".  For awhile, the router placed the Roku on ch 48, but is now determining that the Roku should be on ch 149 on the higher frequency. (which in turn is a bit faster with data transfer).  Could be the OS10 update is providing some better device info to router (not a flaw or arising concern in my humble opinion).  Entirely feasible that you will see the Roku again on ch 48 if ch 149 gets too much interference or too crowded with device demands.  You may even see your cable box appear on ch 48 if the router prefers it there.

If everything is working properly on your network, just let your router manage it. Unless you really need the individual control of the three bands individually, I wouldn't bother. (and I rarely recommend merged networks, but if easier on the end user and provides better wireless coverage in the home, who am I to argue; especially with popularity of emerging mesh routers). This seems to be one of the better mesh systems supporting Roku devices.  Here are some links that may help explain your system better.

Post back if you need more help.

https://mobilesyrup.com/2018/02/24/bell-whole-home-wi-fi-review-canada/

https://help.ncf.ca/Bell_Home_Hub_3000_Configuration#Configure_WiFi_Settings

https://support.bell.ca/Internet/Products/Home-Hub-3000-modem#step1

 

 

Roku Community Streaming Expert
Just another Roku user... I am not a Roku employee.
Insignia RokuTV, Ultra 4660x, Premiere+ 3921, Express 4k+ 3941
0 Kudos