Network - Wireless & Wired Connections

Help & troubleshooting for network issues, including connecting your device to your home Wi-Fi network, connecting to public networks, troubleshooting wireless issues & ethernet connections, and optimizing streaming performance.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
TheOGJimGo
Level 8

Wireless stopped working after rebooting router

 

My Roku Streaming Stick suddenly won’t connect to my WiFi. I have rebooted both the router and the Roku but nothing works. Other decides connect to the WiFi just fine. So I am at a loss as to what is happening. I want to clear the WiFi info (SSID and password) from the cache and completely set it up again, but that doesn’t seem like an option from any of the menus. When the Roku scans for available networks, it sees my SSID but it doesn’t have a lock icon on it. I don’t know if this is normal behavior (since the Roku already knew the password) or if this is an indicator of the problem. I also tried to connect to my guest network (to which the Roku has never been connected) and that didn’t work either.

I tried a factory reset and that didn’t work either.  I’m using a Verizon Fios WiFi 6 wireless router, If that makes a difference.

0 Kudos
4 REPLIES 4\
AvsGunnar
Community Streaming Expert

Re: Wireless stopped working after rebooting router

@TheOGJimGo 

Could be a couple of different things going on with that router.

Initially, I would try resetting the Network Connection from within Roku. (your cache-clearing idea).

Settings...System..Advanced System Settings..Network Connection Reset...Reset Connection

After the Roku reboots, and you head to Network Connections, you may have to press "Scan Again" a few times to refresh the available networks to get yours to show up.

Secondly, I would ensure that the 5ghz Wireless Channel from within the router is configured to be using either 36-48 or 149-161.  Chances are your router may be using "Auto" for Channel and has switched itself automatically to an incompatible wireless channel with the Roku device when the router was rebooted.  Configuring your router manually to use one of the channel numbers mentioned above will ensure that does not happen again when router reboots.

You could also try rebooting your router a few times which also may cycle it to a compatible router channel but easiest method is to simply manually assign it.

There are additional steps you can take which include seperating your 2.4ghz band and 5ghz bands but try the initial troubleshooting steps above first to see if that resolves your issue.

Post back with an update or if you need more help.  Include your streaming stick model number as well as router model number.

Roku Community Streaming Expert
Just another Roku user... I am not a Roku employee.
Insigna RokuTV, Ultra 4660x, Premiere+ 3921, Express 4k+ 3941
0 Kudos
TheOGJimGo
Level 8

Re: Wireless stopped working after rebooting router

Thank you for the quick reply!  I don’t see where to set the Channel numbers in the router settings.  I’ve looked, but just don’t see it.  It is very frustrating.  I tried disabling SON to see if that gave me access to the channels, but I still don’t see it.

I had read about the channel issue and decided that, rather than mess up my WiFi for my other devices, I would just put the Roku on the built-in IoT WiFi.  It is only a 2.5 GHz channel, so no issues with 5Ghz channels, and not switching issues between the 2.5 and 5Ghz bands.  Unfortunately, the Roku can’t login to that network either.  It is getting late, so I am stopping for the night.  I may try changing the WiFi password on the IoT network to something simple (I do cybersecurity for a living, and thus tend to use long complex passwords, which I may be mistyping) to see if that makes a difference. I did try 4 or 5 times, so I don’t really think it is user error…but I will try once again anyway. 

I will also be calling Verizon.  I am concerned that the Roku sees the main WiFi network as not needing a password.  I even reset the password to see if that would change anything, but no luck.

0 Kudos
TheOGJimGo
Level 8

Re: Wireless stopped working after rebooting router

Ok, I feel like an idiot.  I found the channel settings!

AvsGunnar
Community Streaming Expert

Re: Wireless stopped working after rebooting router

@TheOGJimGo 

Here are a couple of links from other threads regarding the SON feature and changing the settings of the G3100.

https://community.roku.com/t5/Network-Wireless-Wired-Connections/BOTH-Roku-TVs-will-no-longer-connec...

https://community.roku.com/t5/Network-Wireless-Wired-Connections/won-t-connect-to-wireless-network/m...

https://community.roku.com/t5/Network-Wireless-Wired-Connections/5-month-old-Premiere-losing-wifi-co...

Sometimes just have to take a break and get a fresh start when troubleshooting. 

The Roku devices will only connect to 2.4Ghz and 5Ghz bands.  Unless you mistyped, the 2.5Ghz (another band for different devices and regions), the Roku is unlikely connect to it).  It should connect to your 2.4Ghz band though even if having issues with the 5ghz as long as the radio is enabled and broadcasting. (Would also lower bandwidth/channel width to 20mhz for troubleshooting.  Then try all three modes/protocols [b/g/n, or g/n, then n-only]  All these changes are usually under "Advanced Settings" in the "Wireless Settings" of a router's admin settings.

Roku Community Streaming Expert
Just another Roku user... I am not a Roku employee.
Insigna RokuTV, Ultra 4660x, Premiere+ 3921, Express 4k+ 3941
0 Kudos