Network - Wireless & Wired Connections

Help & troubleshooting for network issues, including connecting your device to your home Wi-Fi network, connecting to public networks, troubleshooting wireless issues & ethernet connections, and optimizing streaming performance.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Highlighted
Level 7

Will not connect to my 5G network, my phone is connected

My Roku suddenly stopped recognizing my 5G network. It is on and working and I have reset the modem and called provider to reset it from their end. My phone is connected as always but ROKU will not find the network. I tried entering it manually and it won't find it that way either. I have a 2G network it sees but I can't stream on 2G.
0 Kudos
29 Replies
Highlighted
Level 21

Re: Will not connect to my 5G network, my phone is connected

It sounds like your router changed the channel it uses for 5 GHz (not 5G, that's a different wireless protocol). Roku devices will not see or connect to a 5 GHz router that is using a DFS type channel. Check the channel it's using (it's probably set to Auto) and make sure you're using Channel 149 or higher. There are also some lower channels that can be used, but I can't remember them off the top of my head. 

Dan
Roku Stick (3600), Ultra (4640), Ultra (4670), Premiere (3920), Insignia 720p Roku TV, Sharp 4K Roku TV, Nvidia Shield, Windows 10 Pro x64 running Serviio and Plex on a wired Gigabit network.
Highlighted
Level 19

Re: Will not connect to my 5G network, my phone is connected

@RoadRage90  If you have a Roku Express or Roku Premiere (model 3920/3921) device, these are not capable of connecting to 5GHz wireless networks. They only support wireless b/g/n network connections on the 2.4GHz band spectrum. If you are encountering an issue, I would recommend trying to change the wireless broadcast channel on your 2.4GHz network to see if this helps, Most routers default to channels 1, 6 or 11. The goal would be to try and choose a channel that is not in use by other wireless networks around you, to help eliminate any possible wireless interference. Your ISP or wireless router manufacturer can assist you with this process. 

Keep us posted from there! 

 

Thanks,

Tanner

Highlighted
Level 7

Re: Will not connect to my 5G network, my phone is connected

I have the Premiere Plus and initially, upon set-up, it saw and connected to my 5ghz SSID. Shortly after the hour of updating for the 77 channels it installed on set-up, it disconnected from the 5ghz SSID and would not connect even after resetting all network settings (erased the remembered networks also). It still will see the 5ghz SSID..but would not connect back to it. I tried changing the channel on the router.

Seems that the 2.4ghz works pretty well, but the 5ghz never did connect again.

 


@RokuTannerD wrote:

@RoadRage90  If you have a Roku Express or Roku Premiere (model 3920/3921) device, these are not capable of connecting to 5GHz wireless networks. They only support wireless b/g/n network connections on the 2.4GHz band spectrum. If you are encountering an issue, I would recommend trying to change the wireless broadcast channel on your 2.4GHz network to see if this helps, Most routers default to channels 1, 6 or 11. The goal would be to try and choose a channel that is not in use by other wireless networks around you, to help eliminate any possible wireless interference. Your ISP or wireless router manufacturer can assist you with this process. 

Keep us posted from there! 

 

Thanks,

Tanner                                                                                                                                                                   

0 Kudos
Highlighted
Level 7

Re: Will not connect to my 5G network, my phone is connected

How and where do I change to the 149 setting

0 Kudos
Highlighted
Level 19

Re: Will not connect to my 5G network, my phone is connected

It's a router setting.  You have to login to your router and change it there.  Post the make and model number of your router and someone will hopefully help.  But first, ensure your Roku is capable of connecting to 5GHz.  The Express models are not capable.

0 Kudos
Highlighted
Level 7

Re: Will not connect to my 5G network, my phone is connected

For anyone with an AT&T Gateway router, the router interface has changed recently (2020).

  1. Go to Settings> LAN > Wi-Fi.
  2. Then, a little ways down the page, select Advanced Options. This opens up a new menu.
  3. Under both the 2.4 GHz radio and the 5 GHz radio sections, you can change the Wi-Fi channel from "Auto" to a specific number.
  4. For 5 GHZ, choose something above channel 149.
  5. After changing, click save at the bottom of the page.
  6. Test your devices. If you still are having trouble, try a different channel.
Highlighted
Level 21

Re: Will not connect to my 5G network, my phone is connected


@SkipptATL wrote:

For anyone with an AT&T Gateway router, the router interface has changed recently (2020).

  1. Go to Settings> LAN > Wi-Fi.
  2. Then, a little ways down the page, select Advanced Options. This opens up a new menu.
  3. Under both the 2.4 GHz radio and the 5 GHz radio sections, you can change the Wi-Fi channel from "Auto" to a specific number.
  4. For 5 GHZ, choose something above channel 149.
  5. After changing, click save at the bottom of the page.
  6. Test your devices. If you still are having trouble, try a different channel.

Or channel 48 or below. Smiley Happy

Dan
Roku Stick (3600), Ultra (4640), Ultra (4670), Premiere (3920), Insignia 720p Roku TV, Sharp 4K Roku TV, Nvidia Shield, Windows 10 Pro x64 running Serviio and Plex on a wired Gigabit network.
0 Kudos
Highlighted
Level 8

Re: Will not connect to my 5G network, my phone is connected

My Roku suddenly wouldn't connect to my 5G or a slower connection. I tried everything to connect. So, I went back to using my old Roku and that one worked fine. I decided to take another look today. And, after much frustration, I stumbled upon a FIX! YAY!!!!

I would like to share in hopes of may help others.

On the Roku main screen, go to SETTINGS at the bottom on the left side of the screen. 

Click right arrow on remote and move down to  SYSTEM at the bottom on the left side.

Click right arrow and move down to ADVANCED SYSTEM SETTINGS.

Click right arrow and move down to NETWORK CONNECTION RESET.

Click right arrow and choose RESET CONNECTION.

 

I really hope this helps someone else.

 

Highlighted
Level 21

Re: Will not connect to my 5G network, my phone is connected


@Lingo1 wrote:

My Roku suddenly wouldn't connect to my 5G or a slower connection. I tried everything to connect. So, I went back to using my old Roku and that one worked fine. I decided to take another look today. And, after much frustration, I stumbled upon a FIX! YAY!!!!

I would like to share in hopes of may help others.

On the Roku main screen, go to SETTINGS at the bottom on the left side of the screen. 

Click right arrow on remote and move down to  SYSTEM at the bottom on the left side.

Click right arrow and move down to ADVANCED SYSTEM SETTINGS.

Click right arrow and move down to NETWORK CONNECTION RESET.

Click right arrow and choose RESET CONNECTION.

I really hope this helps someone else.


Yes, that has been mentioned before. Glad it worked for you. Smiley Very Happy

As far as your 5 GHz connection, most routers are set by default to select their broadcast channel automatically. There is a subset of channels (labeled DFS) that have restrictions or are completely banned from use for WiFi (depends on your geographical location). Roku devices are designed to not use DFS channels. So if your router decided to change channels, and it selected a DFS channel, your Roku would no longer see it. 

Most routers themselves don't have the DFS channels available, but if they do that is a common reason for the loss of a 5 GHz connection. 

Dan
Roku Stick (3600), Ultra (4640), Ultra (4670), Premiere (3920), Insignia 720p Roku TV, Sharp 4K Roku TV, Nvidia Shield, Windows 10 Pro x64 running Serviio and Plex on a wired Gigabit network.
0 Kudos