Network - Wireless & Wired Connections

Help & troubleshooting for network issues, including connecting your device to your home Wi-Fi network, connecting to public networks, troubleshooting wireless issues & ethernet connections, and optimizing streaming performance.
cancel
Showing results for 
Search instead for 
Did you mean: 
kdimeg
Level 7

Wifi one day, Error 014.50 the next. Rinse, Lather, Repeat

I apologize upfront if this has been solved but I haven't seen my symptom reported yet.

Setup: Hisense Roku TV with DLINK DIR-655 wireless router.

When connected I'm getting fast downloads for 1080p quality vid with uninterrupted service all night. The next day I turn on the TV and can't connect (no IP addr). Try reconnecting using standard network with no luck (error code 014). To remedy this, I spend 10 minutes either simultaneously rebooting my router and Roku system reboot through secret screen until it finally connects, or I log into my router and start changing the wireless channel until Roku is happy again (usually end up on channel 1, 3, 10 or 11 but I have connected on all). Once I reconnect, I'm good for the night and it's a crap shoot if it reconnects the next day. I'm no wireless expert, but all my other devices in the house work flawlessly and get 29Mbs download/5Mbs upload through the same router and ISP. My network is set to mixed mode n/g/b, and I've set the router to reserve the same IP for the Hisense/Roku mac just for kicks. The router isn't in the ideal spot: it's about 25linear feet away but goes through two internal walls and entertainment center (my other devices connect throughout the house at greater distances/obstacles). Once connected, the Roku secret antenna screen has one or both antennas in the Green with a SNR of 25 or so. But as I said, it's a rock star while connected seems to lose it's mind after powered off. It's a recoverable inconvenience for me but a virtual show stopper for the wife & kids.

Thanks for any help/insight. I read briefly about hardwire lan using usb dongle but haven't look into it. I'd prefer to get wireless working.

0 Kudos
28 Replies
TheEndless
Level 7

Re: Wifi one day, Error 014.50 the next. Rinse, Lather, Repe

"kdimeg" wrote:
I've set the router to reserve the same IP for the Hisense/Roku mac just for kicks.

Did you do that before or after you started experiencing this issue? The TV powers down fully a few minutes after you turn it off, including disconnecting from the network, so every time you turn it back on, it has to request a new IP address from the router again. If you reserved an IP in the same range as your other DHCP devices, it's possible one of those other devices has taken that IP while your TV was powered off, which would cause a collision, and likely behavior similar to what you're seeing.
My Channels: http://roku.permanence.com - Twitter: @TheEndlessDev
Instant Watch Browser (NetflixIWB), Aquarium Screensaver (AQUARIUM), Clever Clocks Screensaver (CLEVERCLOCKS), iTunes Podcasts (ITPC), My Channels (MYCHANNELS)
0 Kudos
kdimeg
Level 7

Re: Wifi one day, Error 014.50 the next. Rinse, Lather, Repe

"TheEndless" wrote:
"kdimeg" wrote:
I've set the router to reserve the same IP for the Hisense/Roku mac just for kicks.

Did you do that before or after you started experiencing this issue? .


I did that well after the fact. I've been living with the problem for months now and just recently changed it. I was grasping at straws and looking to see if roku could be configured for static IP... but as i've got the router configured now I don't see other devices grabbing the same IP to which your concern is. I also forgot to mention that I've also done the "disable ping" solution for error 14, but that too seems like a placebo. I haven't noticed a difference in behavior if I have roku's network pings enabled or not.
0 Kudos
jeffrok
Level 11

Re: Wifi one day, Error 014.50 the next. Rinse, Lather, Repe

I've had problems with D-Link routers in the past, on two separate occasions... I bought one, and had connectivity issues. Returned it to the store and bought a Netgear and had no problems (eventually got a Buffalo that I've had for 3+ years).. I also tried to set up a D-Link for a friend, and ended up having that person return it due to device and internet connectivity issues. It's up to you, but I'd try a different router.
Yeah, I got some Rokus.
https://youtu.be/d1CSEeqWl10
0 Kudos
kdimeg
Level 7

Re: Wifi one day, Error 014.50 the next. Rinse, Lather, Repe

"jeffrok" wrote:
It's up to you, but I'd try a different router.


Well I already tried superstition, so why not a different router? I'll wait to see if others have any ideas before I spend money on something that otherwise has been more than serviceable. In the meantime I'll continue to "not look at it" while it's trying to connect. That practice had an suspiciously high success rate like a shy bladder'd Rob Lowe...
0 Kudos
knuckle
Level 7

Re: Wifi one day, Error 014.50 the next. Rinse, Lather, Repe

Before swapping out routers set up a guest network for the TV and only the TV -- set it to "g" and an assigned channel only and see if it still acts the same -- if it connects first time every time after that post back and we will delve deeper into your main network setup -- note that set up like this Plex or any media servers and smart phone remote apps won't work.
ROKU 3 4114AT076252
ROKU 2 LT 16A182002191
ROKU 2 LT #2 16A19K025194
ROKU HD 18D2CP067635
Roku TV 2N002P050587 2WE012050587
ROKU HDMI STICK 5S35CF000124
Roku Express + YU000X236772
all running wireless on a Technicolor C2000T
0 Kudos
Heyitsrick
Level 9

Re: Wifi one day, Error 014.50 the next. Rinse, Lather, Repe

I have that router (ok, it's in a box since being replaced by a FIOS router), but wondering why mixed-mode n-g-b? Does anyone still need "b" any longer? Along the lines of what Knuckle says above, I would just set the router for "G" only (or even "N" if all devices you use support it) and then see how consistent it is. This doesn't include the steps he mentions of guest networks, etc. I'm just saying change the 655 to G or N only, and not mixed-mode, and try it that way.
0 Kudos
kdimeg
Level 7

Re: Wifi one day, Error 014.50 the next. Rinse, Lather, Repe

"Heyitsrick" wrote:
but wondering why mixed-mode n-g-b?

I have no good answer - probably the default setting. I'm not wifi savvy to appreciate the difference with mixed or g or n but will give it a try when family activity is at a minimum. I also don't know how to tell what my client devices support (laptops, phones, older generation iTouch, etc) to know what the impacts will be. It may take me days to respond as it will sometimes connect for days straight before exhibiting the problem again.
0 Kudos
kdimeg
Level 7

Re: Wifi one day, Error 014.50 the next. Rinse, Lather, Repe

"knuckle" wrote:
... set up a guest network for the TV and only the TV -- set it to "g" and an assigned channel only and see if it still acts the same

I tried the "g" only guest network and that did not work (channel 1). I didn't bother swapping to different channels... figuring it looks like the same problem. I believe this also set my home network to "g only" as well and I haven't notice any problems with any of my other devices after making the switch (perhaps you were thinking I have may have b devices out there?). As another reference point, before setting up the guest network I simply changed my home network as "n only" but my Roku to failed to connect right out of gate. So I configured it connect on the guest and "g only" as you suggested. Roku connected right away but took a couple days before the symptom came back which is on par with how it behaved on the mixed mode network.

Here are some other current D-LINK router settings in case it raises an eyebrow to anyone: security mode = WPA Personal as "WPA or WPA2", Cipher = "TKIP and AES", group key update interval = 3600minutes. Transmit Power = high, Beacon Period = 100, RTS Threshold = 2346, DTIM Interval = 1, WMM Enabled, Short GI enabled, extra wireless protection (against 11b connections) is on, WLAN partition is off.
0 Kudos
kdimeg
Level 7

Re: Wifi one day, Error 014.50 the next. Rinse, Lather, Repe

I think I have this solved problem, so I'll recap the common suggested "fixes" that I tried and the final step which seems to have cleared it up.
1. disable ping on wifi secret screen - this had nearly no effect on me
2. changed wifi channel - this does improve general connection issues but did not address my problem
3. changed router location - this improves signal strength but did not address my problem
4. setup a static IP address based on roku tv mac address - this did not help
5. created a separate guest wifi network for roku only - this did not help
6. changed wifi router to "g only" - this did not help
7. played with various router security modes - this did not help
8. i'm sure i did other random things that I can't recall that never seemed to help long term

Finally, the last thing I changed was reconfiguring my router to use a different DNS server instead of my default ISP provider's (i.e. Comcast). I changed mine to Norton ConnectSafe pri/secondary DNS servers (199.85.126.10/199.85.127.10) and since then everything has worked great. I can only guess that Roku tries to connect with it's host servers occasionally and my ISP was flakey and didn't always resolve it unless my router was reset. That's an activity the my other devices (laptops, smart phones, tablets, etc) don't do much of other than for well known email servers. I don't think there is anything magical about using Norton's DNS, but figured why not use that for more security against malware. I'd guess google's DNS servers would work too. Do an internet search about changing your default DNS server if you don't know what I'm talking about as your might be a router or windows configuration.

I'm still disappointed that Roku couldn't help me with this problem by providing a better error code, giving me instead the BS response of error code 14. In who's world besides Roku is failing to connect via a wifi password the same as an unreachable internet address? Based on all these "techy" problems that people seem to be dealing with, I'm not sure if I'd recommend Roku for the mainstream public. I can't imagine anyone else in my family putting up with this for so long. Luckily for me I stuck it out.
0 Kudos