Network - Wireless & Wired Connections

Help & troubleshooting for network issues, including connecting your device to your home Wi-Fi network, connecting to public networks, troubleshooting wireless issues & ethernet connections, and optimizing streaming performance.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Chingaderas
Level 9

Upgraded to Wifi 6 router and Roku will NOT connect to the internet. I HAVE TRIED EVERYTHING....HELP

Jump to solution

I recently switched my old spectrum wifi 5 router out for a new Asus RT-AX86U Wifi 6 router. Prior to switching routers, everything was working flawlessly. I never had issues connecting to the internet via wifi. My router and modem are 5 feet from the Roku device. In my Asus router application, I have the 2.4ghz and 5 GHz bandwidth split into 2 separate connections. When I go to set up the connection on the Roku device I see only the 2.4ghz bandwidth being recognized by the Roku. Strangely beyond only the 2.4ghz showing up on the available connections. the 2.4ghz connection doesn't show that it requires a password to join the wifi channel, which it does require a password.

1. I have restarted my Roku 10 times

2. I have reset my router and modem multiple times

3. I have enabled ping connections in the secret menu on Roku 

4. I have reset my cache on Roku.

5. I have tried changing settings in my Asus router app

I have 9 other devices, in my house, that have seamlessly connected after changing the router. 

I need some serious help on fixing my issue. I'm about ready to switch from using Roku. Roku needs to update its software, firmware, or hardware to enable this **bleep** device to seamlessly connect with the new wifi standards that release or whatever the problem is.

What do I do to fix this issue? 

1 Solution

Accepted Solutions
renojim
Community Streaming Expert

Re: Upgraded to Wifi 6 router and Roku will NOT connect to the internet. I HAVE TRIED EVERYTHING....

Jump to solution

@Devereiii831, check the 5GHz channel your router is using.  If it's set to "Auto", change it to a fixed channel 49 or below or 150 or above.

Roku Community Streaming Expert

Help others find this answer and click "Accept as Solution."
If you appreciate my answer, maybe give me a Kudo.

I am not a Roku employee.

View solution in original post

40 REPLIES 40\
AvsGunnar
Community Streaming Expert

Re: Upgraded to Wifi 6 router and Roku will NOT connect to the internet. I HAVE TRIED EVERYTHING....

Jump to solution

@Chingaderas 

If only seeing the 2.4 ghz, likely your 5ghz is currently using an unsupported wireless channel.  Access your router settings and manually assign the wireless channel to either 36-48 or 149-161.

Re: the 2.4 ghz password issue, may be connecting to your Guest Network if enabled (normally doesn't require password).

From within Roku, try Resetting Network Connections.

Settings..System..Advanced..Network..Reset Network Connection.

Roku Community Streaming Expert
Just another Roku user... I am not a Roku employee.
Insignia RokuTV, Ultra 4660x, Premiere+ 3921, Express 4k+ 3941
0 Kudos
Chingaderas
Level 9

Re: Upgraded to Wifi 6 router and Roku will NOT connect to the internet. I HAVE TRIED EVERYTHING....

Jump to solution

I have tried multiple channels between 36-48 and 149-161 including a modem and router reboot between. I’m never able to see a 5ghz band at any point on my Roku. I don’t have guest networks enabled on 2.4 ghz or 5ghz for that matter. 

any other ideas of what’s the problem?

0 Kudos
StreamerUser
Level 20

Re: Upgraded to Wifi 6 router and Roku will NOT connect to the internet. I HAVE TRIED EVERYTHING....

Jump to solution

@Chingaderas   What is the model # and firmware version of your Roku?  Settings/System/About

Most Express models are 2.4Ghz-only, so they wouldnt see 5Ghz SSIDs.

Reset the Rokus network config:  Settings/System/Advanced system settings/Network connection reset

0 Kudos
Chingaderas
Level 9

Re: Upgraded to Wifi 6 router and Roku will NOT connect to the internet. I HAVE TRIED EVERYTHING....

Jump to solution

model # 3920RW - Roku Premiere

Software version - 10.0.0 - Build 4209-91

 

Thanks for your response

0 Kudos
StreamerUser
Level 20

Re: Upgraded to Wifi 6 router and Roku will NOT connect to the internet. I HAVE TRIED EVERYTHING....

Jump to solution

The 3920 is 2.4Ghz-only.

Try the network connection reset.

Also, make sure 2.4Ghz is on channel 1, 6, or 11, bandwidth=20Mhz, and "B" mode is disabled.

0 Kudos
Chingaderas
Level 9

Re: Upgraded to Wifi 6 router and Roku will NOT connect to the internet. I HAVE TRIED EVERYTHING....

Jump to solution

Ok. Does B mode disabled mean I shouldn't have my wireless mode on auto? My other options on the wireless mode dropdown are 

1. N only

2. Legacy 

if not I'm unsure about what b mode is. 

0 Kudos
StreamerUser
Level 20

Re: Upgraded to Wifi 6 router and Roku will NOT connect to the internet. I HAVE TRIED EVERYTHING....

Jump to solution

@Chingaderas wrote:

Ok. Does B mode disabled mean I shouldn't have my wireless mode on auto? My other options on the wireless mode dropdown are 

1. N only

2. Legacy 

if not I'm unsure about what b mode is. 


Correct - do not use "auto" for the channel, bandwidth, or mode.

Choose N-only.

..and do the network connection reset.

0 Kudos
Chingaderas
Level 9

Re: Upgraded to Wifi 6 router and Roku will NOT connect to the internet. I HAVE TRIED EVERYTHING....

Jump to solution

I have turned it to N only and all the other specifications you suggested. I have attempted this with channel 1, 6, and 11. None have worked. 

0 Kudos
StreamerUser
Level 20

Re: Upgraded to Wifi 6 router and Roku will NOT connect to the internet. I HAVE TRIED EVERYTHING....

Jump to solution

@Chingaderas wrote:

I have turned it to N only and all the other specifications you suggested. I have attempted this with channel 1, 6, and 11. None have worked. 


You've been advised to do the network connection reset multiple times, but you haven't indicated you have done it.

0 Kudos