Network - Wireless & Wired Connections

Help & troubleshooting for network issues, including connecting your device to your home Wi-Fi network, connecting to public networks, troubleshooting wireless issues & ethernet connections, and optimizing streaming performance.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
SRRW
Level 7

Time Zone

When my ROKU'S are connecter to my wired Century Link, I get Denver Time Zone and Stations.

When my ROKU'S are connecter to my wireless AT&T internet, I get Dallas Time Zone and Stations.

Any Help?

0 Kudos
3 Replies
atc98092
Level 21

Re: Time Zone

When Time Zone is set to Auto, it determines where you are by your public IP address. AT&T is obviously using an Internet access point located in the Dallas area. I get the same thing with my work computer when connected to the FAA network. Our Internet access point is Oklahoma City, so I get all sorts of web page ads for stores and services in the OKC area, and I'm in Seattle. 

Your only solution is to set the Time Zone manually in the Settings/System/Time menu. Change "Set automatically" to "Set manually" and set it to Mountain Time, assuming you want the Denver TZ.

Dan
Ultra (4640), Ultra (4670), Ultra (4800), Premiere (3920), Insignia 720p Roku TV, Sharp 4K Roku TV, Nvidia Shield, Windows 10 Pro x64 running Serviio and Plex on a wired Gigabit network.
SRRW
Level 7

Re: Time Zone

I have both the Roku and the AT&T wireless internet router set to MST. The AT&T tower being used is in Plano TX so all local channels are Dallas not where I am.

0 Kudos
atc98092
Level 21

Re: Time Zone

Unfortunately, there's nothing further you can do. That's due to where AT&T is making your Internet presence known, and that's why you're getting the Texas stations when using that connection. 

Exactly what channel are you using that is giving the wrong location? What Roku device are you using?

Dan
Ultra (4640), Ultra (4670), Ultra (4800), Premiere (3920), Insignia 720p Roku TV, Sharp 4K Roku TV, Nvidia Shield, Windows 10 Pro x64 running Serviio and Plex on a wired Gigabit network.
0 Kudos