Network - Wireless & Wired Connections

Help & troubleshooting for network issues, including connecting your device to your home Wi-Fi network, connecting to public networks, troubleshooting wireless issues & ethernet connections, and optimizing streaming performance.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
MooseCat
Level 7

Shows freeze, say no connnection. Check connection, it’s “excellent”...

I am not sure what the problem is or how to fix.  Every time I try to watch a show in Roku, the show freezes.  I go into settings and check wi-if and internet.  They connect and it tell me my connection is excellent and d/l is good.  Why am I still having problems?  I can watch the show on my iPad which is also WiFi no problem.  Help please.

0 Kudos
6 Replies
AvsGunnar
Level 10

Re: Shows freeze, say no connnection. Check connection, it’s “excellent”...

What model Roku and are you sure the software is up to date?  Settings..System..System Update..Check Now

Do you have a Single SSID or dual SSID network setup? (2 names for network, maybe 5g on end of one?)

Do this on your remote from Home Screen then post back results after doing above...

Home5x, Up, Down, Up, Down, Up

Note the Strength and Antenna Numbers (post results)

Note all the numbers below the graphic and post back.

Can also do screenshot if you prefer.

0 Kudos
MooseCat
Level 7

Re: Shows freeze, say no connnection. Check connection, it’s “excellent”...

I did not understand your instructions and antenna numbers.   When I try to do this, Netflix tries to load.

My settings always tell me that the signal strength is excellent and internet d/l speed is good.

The roku device says it’s model no. 3920x

Software is up to date.

I used to have 2 network names. 2.5ghz and 5 ghz. Now it only shows 2.5 ghz but xfinity tells me the system still includes both but are now shown as 2.5 ghz.

0 Kudos
AvsGunnar
Level 10

Re: Shows freeze, say no connnection. Check connection, it’s “excellent”...

The instructions above for your remote were to hit the Home Button (the one that looks like a house) at least 5 times. (You can press it 10 times, doesnt matter). Then you press the purple Up Arrow, Down Arrow, Up Arrow, Down Arrow, Up Arrow.  This provides a little more detailed screen of your connection and gives us a better idea of what Roku is considering "good" or "excellent".  

If you have the 3920 then you are going to have the Premiere.  It is only going to operate on the 2.4Gz band of your network.  It is not designed to see or use the 5gz band of your network.

The problem appears that Xfinity has merged your network into a Single SSID (single network name).  It still has one 2.4gz band and at least one 5gz band but is only showing you the one name. [I think Xfinity may have told you that only the 2.4 gz led light will show connection, but that you still have 5gz connection ability].  I guess we will have to take their word for it. (You can correct me if I am wrong with what they told you.)

The problem is that with these merged SSID networks, every device that uses 5gz will drop down to the 2.4gz network when they have trouble maintaining a stable connection on the 5gz. (Basically, these devices roam for the best signal, be it on 2.4 or 5).  As such, if your 5gz band is not configured properly, or you have a lot of interference on the 5gz band, more of these devices jump off and start to crowd the 2.4gz band and your 2.4gz-only devices (like the Premiere) may begin to have performance issues and just get pushed out of the way.  Also holds true when your 2.4gz band is not configured properly,  

Try to do the above test described before so we can actually see what your connection looks like.  Also provide the model number of your router and your internet speed. (https://speedtest.xfinity.com/)  You may end up having to change some router settings to get the Premiere working as it should.

In the meantime, you can see if lowering your bit-rate will at least let you watch a movie while you are troubleshooting this problem.  Again, using your remote from the Home Screen...

Press Home Button (5 times), Press Rewind (3 times) Press Fast Forward (2 times).....Select Manual Selection... Then choose a bitrate.  Try 3.5Mbps and see how it works.  Press Home Button to exit this screen.  You may have to try some different settings.  You may run into some buffering, but at least should help keep you connected through a movie.

Post back with your results and will see if we can get you going a little better.

0 Kudos
MooseCat
Level 7

Re: Shows freeze, say no connnection. Check connection, it’s “excellent”...

3636A838-CAF4-4985-A2EC-6EBCB1BFB2EA.jpeg

0 Kudos
MooseCat
Level 7

Re: Shows freeze, say no connnection. Check connection, it’s “excellent”...

The router is arris tg1682g

 

When I check internet speed, where am I to check it?  On my iPad?  

0 Kudos
AvsGunnar
Level 10

Re: Shows freeze, say no connnection. Check connection, it’s “excellent”...

Yes, can use your ipad to check internet speed.

0 Kudos