Network - Wireless & Wired Connections

Help & troubleshooting for network issues, including connecting your device to your home Wi-Fi network, connecting to public networks, troubleshooting wireless issues & ethernet connections, and optimizing streaming performance.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
rmjones58
Level 7

Roku won’t find network

Jump to solution

Roku won’t find my network even though all of my other devices do. Rebooted, etc. No luck. Not sure what is happening with Roku now….. updates, etc. No problems at all for 2 years and now 3 problems at the same time.

0 Kudos
1 Solution

Accepted Solutions
makaiguy
Community Streaming Expert

Re: Roku won’t find network

Jump to solution

@rmjones58 wrote:

Roku won’t find my network even though all of my other devices do. Rebooted, etc. No luck. Not sure what is happening with Roku now….. updates, etc. No problems at all for 2 years and now 3 problems at the same time.


I've run into this here several times.  This has always worked for me to re-establish my net connection when it has been lost:

  • Restart your router (even if other devices have no problem finding and connecting). Sometimes that's all it takes, if not keep going.
  • DON'T SKIP THIS STEP.  Restart the Roku to clear its memory via Settings > System > System restart (for a Roku TV it's Settings > System > Power > System restart).  Again sometimes that's all it takes, if not keep going.
  • Find and connect to your network via Settings> Network > Set up connection

If that doesn't fix it, try disconnecting the power to your Roku for a few seconds.  When it comes back up, see if you then can set up the network connection.

If you still can't connect ...

You don't say what model and model number Roku you have.  Check via Roku menu path Settings > System > About.

  • If you have a Roku Express/Express+ (prior to the new Express 4K) or a Premiere/Premiere+  read on, otherwise you can skip to the next bullet point.

    Express/Express+ and Premiere/Premiere+ are lower end units with single band Wi-Fi radios that only support the 2.4 GHz band. They, and many other devices of all sorts that are 2.4 GHz only, can't even see the 5 GHz band, let alone connect to it. If you have one of these models and a dual band router with both 2.4 and 5 GHz bands, be sure the router's 2.4 GHz band is turned on.

    Also, there have been a number of reports lately of people who have routers supplied by their Internet Provider in which the router's 2.4 GHz band was disabled by an update to the router software.   They've had to have their Internet Provider re-enable the 2.4 GHz band, or in some cases swap in a new router with 2.4 GHz support.

  • For all Roku models, your router must be set to a channel number the Roku can see.

    Within the 2.4 GHz band
    , be sure your router is set to use channels in the 1 through 11 range as are  used in North America.  Some other parts of the world also support channels 12 & 13, but Rokus can't even see these channels.  If your router supports channels 12-13 and it has an auto-selection capability, switch this off to prevent 12 & 13 from being used.  Try setting your router manually to channels 1, 6, or 11 as these do not overlap with each other.

    Within the 5 GHz band, (see first bullet point above), the nine 5 GHz channels supported by Roku devices are 36, 40, 44, 48, 149, 153, 157, 161, and 165.

    The channels assigned to the 5 GHz band in ranges 50-64 and 100-144 are shared with other uses such as military, radar, and weather. These channels are termed DFS (dynamic frequency selection) channels and routers are supposed to automatically switch to a different channel if they detect one of these channels is in use in your area. Roku and many other home use devices don't support these DFS channels at all and many home routers don't even include them.  If your router supports DFS channels and it has an auto-selection capability, switch this off to prevent DFS channels from being used.
Roku Community Streaming Expert
I am not a Roku employee, only a user like you.
Streaming Stick 4K+ 3821 | Streaming Stick+ 3810 | TCL Roku TV 43S245/C107X | Streaming Stick 3600

If this post solves your problem please help others find this answer by clicking "Accept as Solution.". Please only do this if it ACTUALLY solves your problem.

View solution in original post

2 REPLIES 2\
RokuMary-F
Roku Employee
Roku Employee

Re: Roku won’t find network

Jump to solution

Hi @rmjones58,

Thanks for reaching out to the Roku community! I understand that you are unable to connect to your wireless network.

Do you get an error message when you try to connect to your wireless network, What Roku model device are you using?

I would recommend checking out our Support page for troubleshooting issues here: What should I do if I cannot connect to my home network or ...

Please keep us posted and we'll continue assisting you from there!

Many thanks,
Mary

0 Kudos
makaiguy
Community Streaming Expert

Re: Roku won’t find network

Jump to solution

@rmjones58 wrote:

Roku won’t find my network even though all of my other devices do. Rebooted, etc. No luck. Not sure what is happening with Roku now….. updates, etc. No problems at all for 2 years and now 3 problems at the same time.


I've run into this here several times.  This has always worked for me to re-establish my net connection when it has been lost:

  • Restart your router (even if other devices have no problem finding and connecting). Sometimes that's all it takes, if not keep going.
  • DON'T SKIP THIS STEP.  Restart the Roku to clear its memory via Settings > System > System restart (for a Roku TV it's Settings > System > Power > System restart).  Again sometimes that's all it takes, if not keep going.
  • Find and connect to your network via Settings> Network > Set up connection

If that doesn't fix it, try disconnecting the power to your Roku for a few seconds.  When it comes back up, see if you then can set up the network connection.

If you still can't connect ...

You don't say what model and model number Roku you have.  Check via Roku menu path Settings > System > About.

  • If you have a Roku Express/Express+ (prior to the new Express 4K) or a Premiere/Premiere+  read on, otherwise you can skip to the next bullet point.

    Express/Express+ and Premiere/Premiere+ are lower end units with single band Wi-Fi radios that only support the 2.4 GHz band. They, and many other devices of all sorts that are 2.4 GHz only, can't even see the 5 GHz band, let alone connect to it. If you have one of these models and a dual band router with both 2.4 and 5 GHz bands, be sure the router's 2.4 GHz band is turned on.

    Also, there have been a number of reports lately of people who have routers supplied by their Internet Provider in which the router's 2.4 GHz band was disabled by an update to the router software.   They've had to have their Internet Provider re-enable the 2.4 GHz band, or in some cases swap in a new router with 2.4 GHz support.

  • For all Roku models, your router must be set to a channel number the Roku can see.

    Within the 2.4 GHz band
    , be sure your router is set to use channels in the 1 through 11 range as are  used in North America.  Some other parts of the world also support channels 12 & 13, but Rokus can't even see these channels.  If your router supports channels 12-13 and it has an auto-selection capability, switch this off to prevent 12 & 13 from being used.  Try setting your router manually to channels 1, 6, or 11 as these do not overlap with each other.

    Within the 5 GHz band, (see first bullet point above), the nine 5 GHz channels supported by Roku devices are 36, 40, 44, 48, 149, 153, 157, 161, and 165.

    The channels assigned to the 5 GHz band in ranges 50-64 and 100-144 are shared with other uses such as military, radar, and weather. These channels are termed DFS (dynamic frequency selection) channels and routers are supposed to automatically switch to a different channel if they detect one of these channels is in use in your area. Roku and many other home use devices don't support these DFS channels at all and many home routers don't even include them.  If your router supports DFS channels and it has an auto-selection capability, switch this off to prevent DFS channels from being used.
Roku Community Streaming Expert
I am not a Roku employee, only a user like you.
Streaming Stick 4K+ 3821 | Streaming Stick+ 3810 | TCL Roku TV 43S245/C107X | Streaming Stick 3600

If this post solves your problem please help others find this answer by clicking "Accept as Solution.". Please only do this if it ACTUALLY solves your problem.