Network - Wireless & Wired Connections

Help & troubleshooting for network issues, including connecting your device to your home Wi-Fi network, connecting to public networks, troubleshooting wireless issues & ethernet connections, and optimizing streaming performance.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Anonymous_User
Level 8

Roku will not stay connected

Software 9.4 build 4190-30

Status: Connected

Signal Strength: Excellent

Router: Google WiFi (1 unit only)

Issue: When I open an app (YouTube, Prime Video, Apple TV+, etc.) it says I am not connected and to check my network.

Troubleshoot: I have tried, seemingly, everything including: reset/rebooted everything, entered the various secret screens, used a guest WiFi account, changed password to not use special characters, changed DNS, etc  

Background: My TCL/Roku tv worked great with software version 9.2. Ever since then (all of 9.3 and now 9.4) it will not stay connected. By all metrics I am connected with excellent signal strength.

It connects and stays connected when I use Ethernet, but I have to remove and carry the tv to another room to do that. It works with my phone too, when setup for a hotspot.

Help!

7 Replies
rbunker
Level 7

Re: Roku will not stay connected

Did you receive a resolution to this issue?

0 Kudos
boogernose
Level 18

Re: Roku will not stay connected

how far is the Router.

Is it behind a wall or corner?

How strong is the signal? Settings/Network/about

are you using the 2.4 ghz band?

Roku Model type?

---A problem clearly stated is a problem half solved---.
0 Kudos
Anonymous_User
Level 8

Re: Roku will not stay connected

The Router is about 25 feet away

It is not behind a wall or corner (open floor plan)

The signal strength is Excellent

I'm not sure of the band - where do I find that?

Roku TV model 7120X / TCL model 55R615

When I connect with an older Buffalo Router, it connects with an Excellent signal strength and I have zero issues. When I connect with Google Wifi, initially it says I am connected with Excellent strength. But when I attempt to stream any channel (Disney+, Amazon Prime, Youtube, Apple TV, etc.) it says there is no connection and asks me if I want to connect to a network. To use the TV only, I've taken to swapping the Google WiFi with the old Buffalo router. When I'm done, I swap back to Google WiFi because I get better signal strength and throughput on ALL my other computers, devices with Google WiFi.

0 Kudos
atc98092
Level 21

Re: Roku will not stay connected

You can identify the band by looking at the network settings in your Roku. If the channel number is 1 through 11, it's connected on the 2.4 GHz band. Any channel number higher than that is 5 GHz. 

2.4 GHz is more prone to interference from other devices, as it's much more crowded than 5 GHz. First thing to try on 2.4 GHz is changing the channel number. There are three channels that offer the most separation from other channels: 1, 6 and 11. Your router is likely set to auto-select the best channel, but they don't always get it right. Try changing the channel manually in your router settings. I can't say exactly how to do that, as every brand is different. But it should be somewhere under wireless/radio. 

Dan
Ultra (4640), Ultra (4670), Ultra (4800), Premiere (3920), Insignia 720p Roku TV, Sharp 4K Roku TV, Nvidia Shield, Windows 10 Pro x64 running Serviio and Plex on a wired Gigabit network.
0 Kudos
Anonymous_User
Level 8

Re: Roku will not stay connected

I'm on channel 36 - so the 5 Ghz band.

0 Kudos
atc98092
Level 21

Re: Roku will not stay connected

OK, good. I wasn't sure if that TV supported 5 GHz. Now, you might try manually changing the channel to see if it improves. Pick something in the higher numbers: 149, 153, 157, 161, 165.

Dan
Ultra (4640), Ultra (4670), Ultra (4800), Premiere (3920), Insignia 720p Roku TV, Sharp 4K Roku TV, Nvidia Shield, Windows 10 Pro x64 running Serviio and Plex on a wired Gigabit network.
0 Kudos
boogernose
Level 18

Re: Roku will not stay connected

with my TP-Link Router I am able to broadcast both 2.4 ghz and 5 ghz with two SSID's.

But it was set up in the firmware for the Router. I would imagine Google wifi allows this.

Why not try both? Especially if nothing is logged into 2.4 ghz channel. But the best solution

is Ethernet. I never have problems related to this Net connection.

Buffalo Router???wow those are ancient. You could run the Buffalo as well at the same time.

Just connect it to the Google Router with an Ethernet cable on the back.

---A problem clearly stated is a problem half solved---.
0 Kudos