Network - Wireless & Wired Connections

Help & troubleshooting for network issues, including connecting your device to your home Wi-Fi network, connecting to public networks, troubleshooting wireless issues & ethernet connections, and optimizing streaming performance.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Bud22923
Level 7

Roku will not connect to Wavlink Ac600

I have the Wavlink AC600
I have it set up and working it works good with my phones on WiFi and computers but when I go to put it on my Roku boxes it shows the wifi signal from it I go to put in the wifi password it gives me a error on both my Roku boxes now if I use my old router that is far away with very low signal they both sign in but the signal is a lot lower from my old router that's why I bought the AC600 to extend the signal.
Could anyone please tell me why it is doing this?
0 Kudos
2 REPLIES 2\
AvsGunnar
Community Streaming Expert

Re: Roku will not connect to Wavlink Ac600

@Bud22923 

If you are trying to use Wavlink as an extender, verify that it is in Repeater or Relay mode. (Settings in Wavlink should mirror those of old router re: gateway IP, wireless channels, modes/protocols, and wireless security)  If you are using it in Router or Access Point Mode and your other router is still connected to network, the Gateway IP address  (192.168.1.0 or the like) has to be different than the old router.  I am unclear as to whether you have swapped routers or trying to extend coverage.  

Basically, verify that you do not have 2 routers set to Router Mode that are using same gateway IP address. (The 2 router's DHCP servers will conflict with each other trying to assign IP addresses to wireless devices).

If you unplug your old router from power and use your Wavlink set to Router Mode, can you now connect to your Roku devices?

Roku Community Streaming Expert
Just another Roku user... I am not a Roku employee.

0 Kudos
atc98092
Community Streaming Expert

Re: Roku will not connect to Wavlink Ac600

Since your Roku devices are seeing the new router, it's using an accepted channel. You are saying it's not accepting your password, so check your security settings in the new router. Make sure you're using WPA2 as the security level. Also make sure your password isn't using special characters (like @, #, $, etc.) as some Rokus don't like using them. Just stick with upper and lower case letters and numbers. 

Dan

Roku Community Streaming Expert

Help others find this answer and click "Accept as Solution."
If you appreciate my answer, maybe give me a Kudo.

I am not a Roku employee, just another user.
0 Kudos