Network - Wireless & Wired Connections

Help & troubleshooting for network issues, including connecting your device to your home Wi-Fi network, connecting to public networks, troubleshooting wireless issues & ethernet connections, and optimizing streaming performance.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Jennel
Level 7

Roku not working- did factory reset multiple times and it still is not connecting

 
0 Kudos
3 Replies
RokuDanny-R
Roku Employee
Roku Employee

Re: Roku not working- did factory reset multiple times and it still is not connecting

@Jennel

Thanks for the post.

Can you please specify the issue you are experiencing? What Roku model device are you using? What are you seeing on screen? Is there a light on your Roku device? How are you powering the Roku device?

With more information we will be able to assist you further.


Thanks,
Danny

Danny R.
Roku Forum Moderator
0 Kudos
JMAY1
Level 7

Re: Roku not working- did factory reset multiple times and it still is not connecting

I am not able to connect also.  I have a Roku Premiere | HD/4K/HDR Streaming Media Player, Simple Remote and Premium HDMI Cable.  I have reset everything and it is not connecting.

0 Kudos
AvsGunnar
Level 10

Re: Roku not working- did factory reset multiple times and it still is not connecting

@JMAY1 

Is your Premiere seeing your 2.4gz network connection?  Under your Settings...Network, press SCAN AGAIN, is your network showing up as an option? 

Do you see any indication at your router that the 2.4gz is broadcasting? (perhaps an LED light or such)? You may have to access your router via admin. panel login and verify channels are broadcasting and enabled.

Basics to troubleshoot is to restart your router and let it reboot, then do a reboot of your Roku Premiere (Setting..System..System Restart.)  Then proceed to Network Settings.

0 Kudos