Network - Wireless & Wired Connections

Help & troubleshooting for network issues, including connecting your device to your home Wi-Fi network, connecting to public networks, troubleshooting wireless issues & ethernet connections, and optimizing streaming performance.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
MrEd
Level 8

Roku not connecting to CenturyLink modem/router

I suddenly could not connect to the internet on any of my Roku devices and what a solution I found!

I went to my CenturyLink router's advanced setup page, clicked on LAN Settings, clicked on “Set the DHCP name special character state”, clicked on “Allow Special Characters” and rebooted. All my Roku devices now connect flawlessly.

I hope this helps, especially those with CenturyLink modem/routers.

3 Replies
MommaO
Level 8

Re: Roku not connecting to CenturyLink modem/router

I went on the Advanced setting page but couldn’t find anywhere to click Allow Special Characters.  All I saw was Enable, which was checked, and Disable in a box marked DHCP Name Special Character State.

0 Kudos
akkocher
Level 7

Re: Roku not connecting to CenturyLink modem/router

Thanks This really worked Saved me a ton of trouble

0 Kudos
C_I
Level 12

Re: Roku not connecting to CenturyLink modem/router


@MrEd wrote:

I suddenly could not connect to the internet on any of my Roku devices and what a solution I found!

I went to my CenturyLink router's advanced setup page, clicked on LAN Settings, clicked on “Set the DHCP name special character state”, clicked on “Allow Special Characters” and rebooted. All my Roku devices now connect flawlessly.

I hope this helps, especially those with CenturyLink modem/routers.


      Hopefully now you can access your WiFi  network through your modem/router. 

0 Kudos