Network - Wireless & Wired Connections

Help & troubleshooting for network issues, including connecting your device to your home Wi-Fi network, connecting to public networks, troubleshooting wireless issues & ethernet connections, and optimizing streaming performance.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Kimmie10
Level 7

Roku express keeps losing network with Arris router

I have a Roku Express+ and whenever I turn my tv on to connect to Spectrum or Netflix, it says it’s not connected to the internet and I have to go through the whole process of setting up the wi-fi network. (Set up connection, wireless, set password, etc)

I have the Roku unit’s power cord plugged into the wall and the other cable plugged into the tv’s hdmi port.

I’ve worked with Arris, the modem/router manufacturer, and they say the problem is with the Roku unit.  

I’ve reset/powered down both the modem and Roku unit.

My Roku device ID is S122981FFO.

23 REPLIES 23\
RokuDanny-R
Roku Employee
Roku Employee

Re: Roku express keeps losing network with Arris router

@Kimmie10

Thanks for the post.

I've passed along your information to the appropriate Roku team for further investigate. Once more information is available, I'll be sure to update this thread.


Thanks,
Danny

Danny R.
Roku Forum Moderator
sirald66
Level 8

ROKU EXPRESS+ 3910X/RW virtually no longer connects to XFINITY XFI WIRELESS GATEWAY ARRIS TG1682G

Can not connect two Rokus to two Xfinity WiFi routers. When they very rarely do, they will lock out within hours. Had been working for many months.
Roku Express+ (3910 series)  
ROKU EXPRESS+ 3910X/RW 10.0.0.4209-51  (UNIT-1)
ROKU EXPRESS+ 3910X/RW 10.5.0.4174-51 (UNIT-2)
XFINITY XFI WIRELESS GATEWAY: ARRIS TG1682G (ROUTER-1)
XFINITY XFI WIRELESS GATEWAY: CISCO DPC3941T (ROUTER-2)
XFINITY ESSENTIALS 50/5 (SERVICE-1)
XFINITY ESSENTIALS 50/5 (SERVICE-2)
WIFI ID/PW FORMAT Xxxxxxxx ########## (WIFI-1)
WIFI ID/PW FORMAT XXXX xxxxxx####xx~ (WIFI-2)

* UNIT-1/2, ROUTER-1, SERVICE-1, WIFI-1 belong to CUSTOMER
* ROUTER-2, SERVICE-2, WIFI-2 belong to NEIGHBOR
* CUSTOMER AND NEIGHBOR ARE ACROSS HALL IN APARTMENTS
* UNIT-1/2 SERIAL# AND DEVICE# CAN BE SUPPLIED PRIVATELY TO ROKU
* ERRORS 014.30 014.40* Customer had been using UNIT-1 without problem for many months, but then started getting disconnected, and then couldn't reconnect at all.

- WIFI-1/2 signals good / excellent. If they do ever connect, may last an hour or so. A check connection usually fails on WIFI.
- Both UNIT-1/2 connected at least once to update system software and allow app logins.
- Soft started ROUTER-1/2 and UNIT-1/2
- Power cycled ROUTER-1/2 and UNIT-1/2
- Factory reset ROUTER-1/2 and UNIT-1/2
- Left Router-1/2 and UNIT-1/2 off overnight.
- Tried connecting UNIT-1/2 across hall to neighbor's ROUTER-2 (good signal).
- Tried disabling 5 Ghz and 2.4 Ghz 802.11b on WIFI-2 local test
- Called Roku 800# Support, factory resets, UNIT-1/2 eventually worked a couple hours then disconnected.
- Called Xfinity Support, factory reset ROUTER-1, performance normal, UNIT-2 worked a couple hours then disconnected.

* Is it possible that UNIT-1/2 software has a bug (or is no longer compatible) with ROUTER-1/2 ?
* The Roku Express 39xx series is still being sold, but has no agent-assisted support ?

0 Kudos
RokuDanny-R
Roku Employee
Roku Employee

Re: ROKU EXPRESS+ 3910X/RW virtually no longer connects to XFINITY XFI WIRELESS GATEWAY ARRIS TG1682

@sirald66 

Thanks for the post and providing us with your information.

I have passed it along to the appropriate Roku team to investigate further.


Thanks,
Danny

Danny R.
Roku Forum Moderator
AvsGunnar
Community Streaming Expert

Re: ROKU EXPRESS+ 3910X/RW virtually no longer connects to XFINITY XFI WIRELESS GATEWAY ARRIS TG1682

@sirald66 

Is being reported by Xfinity customers that the router's mode/protocol being manually set to b/g/n is resolving many of the disconnection/failure to connect issues.  For many that had only mode/protocol g/n enabled, enabling the legacy support of b is required to resolve the issue.  This seems to be applicable for Xfinity/Comcast/Cox customers from forum reports. (Since b/g/n is the default setting for many routers, likely the factory reset of the router in your troubleshooting initially returned it to this setting.)

Might as well verify manual wireless channel selection as well.  For 2.4ghz band, select ch. 1-11, mode/protocol b/g/n, bandwidth/channel width 20mhz.  On the 5ghz band, Roku cannot utilize DFS, so assign wireless channels 36-49, 149-161.  

Roku Community Streaming Expert
Just another Roku user... I am not a Roku employee.
Insigna RokuTV, Ultra 4660x, Premiere+ 3921, Express 4k+ 3941
sirald66
Level 8

Re: ROKU EXPRESS+ 3910X/RW virtually no longer connects to XFINITY XFI WIRELESS GATEWAY ARRIS TG1682

Thank you Danny for your time.

Are we likely to hear back by the end of the week?  We're having to decide if we're continuing with the platform.

0 Kudos
sirald66
Level 8

Re: ROKU EXPRESS+ 3910X/RW virtually no longer connects to XFINITY XFI WIRELESS GATEWAY ARRIS TG1682

Thank you, Gunnar.  I'll try the steps.

My first tries at 2.4 GHz b/g/n didn't work, but I'll look at more specific settings.

Do you know if this is being report for all Roku, or just Express series?

Your time is appreciated.

0 Kudos
AvsGunnar
Community Streaming Expert

Re: ROKU EXPRESS+ 3910X/RW virtually no longer connects to XFINITY XFI WIRELESS GATEWAY ARRIS TG1682

@sirald66 

Have seen it for Express and Premiere models. (the two Roku models using the 2.4ghz bands) affecting those using Xfinity/Comcast/Cox ISP, as well as for the newer Express4k/4k+ devices.  Seemed to be an issue that developed over the last 3 weeks or so.  I think the problem with the 4k/4k+ devices seem to be more attributable to some Xfinity provided routers that are not user configurable (auto-managed firmware) so most likely the Auto settings have DFS channels enabled, thus forcing users to use the 2.4ghz band that further has legacy b disabled resulting in no way for the Roku device to connect.

The Arris router does seem to pose an additional problem for some using the Roku, but seemed to be working previously according to your posting. 

It does really appear that Xfinity pushed a firmware update that is affecting some Rokus from connecting to a previously working network connection.  Came across a few online reports that affecting security cameras as well (which makes sense as many use 2.4 b and g protocols).

Roku is also in process of pushing new OS update (10.5) so may also be affecting unit2.  Unit 1 with 10.0-4209 build is stable though so that would be the unit I would do the troubleshooting with.  Unit 2 with the 10.5 update adds the additional unknown whether it is a router issue, a network issue, a Roku OS update issue, etc.

Once I got Unit1 to work, I would then move to Unit2.  

Roku Community Streaming Expert
Just another Roku user... I am not a Roku employee.
Insigna RokuTV, Ultra 4660x, Premiere+ 3921, Express 4k+ 3941
0 Kudos
sirald66
Level 8

Re: ROKU EXPRESS+ 3910X/RW virtually no longer connects to XFINITY XFI WIRELESS GATEWAY ARRIS TG1682

* The following is done via UNIT-1, SERVICE-2, ROUTER-2, WIFI-2 (referenced above):
- Set WIFI-2 2.4 GHz to 802.11 b/g/n, WPA2-PSK (AES), Automatic Channel Selection (1-11); currently 6, Channel Bandwidth to 20 (not 20/40), Broadcast Network Name.
- Login syntax XXXX xxxxxx####xx~
- Power cycle ROUTER-2
- Power cycle UNIT-1
- Factory reset UNIT-1
* Current UNIT-1 software version unknown.
* ROUTER-2 software flashed by SERVICE-2, "[Docsis][1049]: SW download Successful - Via NMS 2021/10/8 21:17:27"; eMTA & DOCSIS Software Version:2.3.10.13_5.5.0.5 - Software Image Name:DPC3941_4.10p14s1_PROD_sey - Advanced Services:DPC3941T - Packet Cable:2.0
* ROUTER-2 gets following even warning approximately once per day that seems like SERVICE-2 resetting link, "[Docsis][1041]: No Ranging Response received - T3 time-out"  Wondering if this will result in loss of settings, or SERVICE-2 fixing link problem with Roku Express series.

No success.

0 Kudos
sirald66
Level 8

Re: ROKU EXPRESS+ 3910X/RW virtually no longer connects to XFINITY XFI WIRELESS GATEWAY ARRIS TG1682

If this is cable provider service related possibly known for weeks, I'm concerned that Roku doesn't have easily accessible steps to resolve this, a timeline, no mention of it, is still selling Express series and says that agent support isn't for that line.

Community forums can be helpful, but also a way of saying "good luck!".

0 Kudos