Network - Wireless & Wired Connections

Help & troubleshooting for network issues, including connecting your device to your home Wi-Fi network, connecting to public networks, troubleshooting wireless issues & ethernet connections, and optimizing streaming performance.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
sbirkner
Level 7

Roku express can't see my network, but can see other wifi networks.

I just moved and changed ISPs. I got a Linksys router with DD-WRT on it, but my Roku Express will not see my wireless network. It can see other (neighbor's) networks though. Other devices see my router just fine.

Things I have tried (all on 2.4Ghz WiFi network)...

Wireless Network Mode - Tried mixed, B-only, and G-only. (with router and Roku restart between each) No luck
 
Channel Width - tried Full(20Mhz) and Dynamic(20/40Mhz) (with router and Roku restart between each) No luck
 
Wireless Channel - tried channels 1, 3, 6, 9, 11. (with router and Roku restart between each) No luck
 
I even tried changing the Wireless Network Name (SSID) No luck.
 
Does anyone have any other ideas? or does the Roku box just not like DD-wrt  routers for some reason?
0 Kudos
3 Replies
renojim
Level 21

Re: Roku express can't see my network, but can see other wifi networks.

It looks like you've tried everything, but just make sure you're not overlooking something simple like ensuring SSID broadcast is enabled.

0 Kudos
sbirkner
Level 7

Re: Roku express can't see my network, but can see other wifi networks.

Sorry, yes. SSID is set to broadcast.

0 Kudos
renojim
Level 21

Re: Roku express can't see my network, but can see other wifi networks.

As you may have seen, there is/was an issue with OpenWrt and 2.4GHz and the solution was to disable "Legacy" (B) mode.  It looks like you've already tried that.  Updating OpenWrt to the latest version also seemed to fix the problem, but it could have been that the updated version just disabled legacy mode by default.  Still, I'd make sure you're using the latest version of DD-WRT.  One last thing to try, if possible, is to use OpenWrt instead of DD-WRT.

0 Kudos