Network - Wireless & Wired Connections

Help & troubleshooting for network issues, including connecting your device to your home Wi-Fi network, connecting to public networks, troubleshooting wireless issues & ethernet connections, and optimizing streaming performance.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Amiller71284
Level 7

Roku disconnected on its own

We use 2 roku's. Both were working fine earlier. Now they both say they are unable to connect to our network. The password for our network has never changed. Never had this issue before. Reset the devices and unplugged them. Our smart is hooked up to the network with no issue. Why would they just stop working not reconnect?

0 Kudos
3 REPLIES 3\
makaiguy
Community Streaming Expert

Re: Roku disconnected on its own

Can't answer the why, but it's happened to me several times.

Restart your router, then when the router comes back up, if the Roku still doesn't see your net, restart and reconnect the Roku. Restart and reconnect the other Roku too.

Roku Community Streaming Expert
I am not a Roku employee, only a user like you.
Streaming Stick 4K+ 3821 | Streaming Stick+ 3810 | TCL Roku TV 43S245/C107X | Streaming Stick 3600

If this post solves your problem please help others find this answer by clicking "Accept as Solution.". Please only do this if it ACTUALLY solves your problem.
0 Kudos
Mrboyd12
Level 7

Re: Roku disconnected on its own

Same issue here. Restarted the router and both rokus. No luck connecting. Going to try a factory restart and see what happens. 

0 Kudos
RokuKariza-D
Roku Employee
Roku Employee

Re: Roku disconnected on its own

Hello @Mrboyd12

Thanks for the post.

If you are getting an error code or message, refer to this link for common Roku error codes and their recommended actions: How to connect your Roku device to the internet using Wi-Fi or Ethernet

Furthermore, if the affected devices are Roku Express or Roku Premiere, please note that they are only compatible with wireless b/g/n networks on the 2.4 GHz spectrum. Ensure that your router is broadcasting a 2.4GHz Wi-Fi network for the device to connect to. You can check your device model by navigating to Settings > System > About.

You can also try configuring your router and use wireless channels 1, 6, or 11 which are the preferred channels in North America. Each time you change the wireless channel, you will likely need to apply/save changes before you are prompted to restart the router.

Let us know how it goes!


All the best,
Kariza

Kariza D.
Roku Forum Moderator
0 Kudos