Network - Wireless & Wired Connections

Help & troubleshooting for network issues, including connecting your device to your home Wi-Fi network, connecting to public networks, troubleshooting wireless issues & ethernet connections, and optimizing streaming performance.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
maupin10123
Level 8

Roku Express can't find router

Roku Express 

YG009G615776

Device Id

76446493

Software version

9.4.0

Tried a factory reset since Roku could not find my network. Still cant find it my router is 1 foot away from the roku.

0 Kudos
maarond
Level 7

Re: Express device can't pickup network

@RokuDanny-R 

I'm having the same issue--that is, my Roku suddenly stopped picking up my home wireless network a few weeks ago.

Roku Model: 3900RW - Roku Express
Serial Number: YG00EG363463
Device ID: C4389E363463
Software: 9.4.0 - build 4190-51
Router: Westell VersaLink Model 327W
Frequency: 2.4 Ghz

I spent a very long, very frustrating 2 hours on on Roku support chat last night. It seems the MO is for Roku Support to blame the issue on the ISP. Instead of passing the buck, I would have been much happier had they owned the issue and said something along the lines of, "please bear with us as we atempt to resolve this issue yadda yadda yadda." I was very close to purchasing an Amazon Fire Stick until I discovered this thread. It appears Roku might be trying to fix the issue. Roku, I'll give you a couple of weeks before I jump ship to a Fire Stick. I just can't go that long without my re-runs of The Office.

0 Kudos
mmortal03
Level 9

Re: Roku can't find network


@renojim wrote:

There are many threads on this and the one common denominator seems to be having 802.11b mode enabled on your router, especially if you're using OpenWRT or DD-WRT.


This was the solution. After trying all kinds of things, the fix in OpenWRT on a Linksys WRT1200AC was to uncheck the "allow legacy 802.11b rates" setting, then Save, and Save and Apply.

The setting is under: 
Network->Wireless
Click the Edit button associated with the 2.4GHz radio
Go to Advanced Settings tab
uncheck "allow legacy 802.11b rates"
Save, then Save and Apply. Possibly reboot the router after this.

0 Kudos