Network - Wireless & Wired Connections

Help & troubleshooting for network issues, including connecting your device to your home Wi-Fi network, connecting to public networks, troubleshooting wireless issues & ethernet connections, and optimizing streaming performance.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
schexc
Level 9

Re: Roku Ultra - wireless network issues - no Interference menu option

Exactly...! Give us the option to turn it off!

ektoplasm
Level 9

Re: Roku Ultra - wireless network issues - no Interference menu option

Just for those on the thread who are having problems... On my devices - an express and a 4K smart tv with a Roku built in doing the following fixes it, but disables some features:

Settings > System > Advanced System Settings > Device Connect > Disable 'Device Connect'

Obviously, this is not ideal but seems to workaround the issue on my network.

 

0 Kudos
JD23
Level 7

Re: Roku Ultra - wireless network issues - no Interference menu option

I changed my setup which consist of VIZIO M-series TV streaming device and a GatewayNokia router from wireless to ethernet connect and I don't appear to be experiencing the interference from a roommates Roku device now. When it was interfering it disable my ability to do anything at all with the set. Should the problem return I'll be happy to share what happens and my suspicions about weaponizing such a device as the Roku. Thanks for your interest.

0 Kudos
ChefZ
Level 9

Re: Roku Ultra - wireless network issues - no Interference menu option

I finally got so fed up with Roku's excessively strong and interference causing wifi. I opened up all 3 of my Roku ultras and removed the two antennae in each.

All you need is a Philips screwdriver and a nylon spudger.

- remove the SD card if using one- peel off the rubber foot

- remove 4 screws

- use spudger to gently separate the plastic casing around the top

- for my particular model there were 2 raised metal antennae. I wiggled them to fatigue the metal until it broke off

- I covered the exposed terminals in electrical tape

Close it back up and you are ready to go.

FINALLY, a real solution

schexc
Level 9

Re: Roku Ultra - wireless network issues - no Interference menu option

Nice...but it really should be so much easier.

0 Kudos
ChefZ
Level 9

Re: Roku Ultra - wireless network issues - no Interference menu option

Agreed 100% but this thread proves there will likely never be a solution from roku

schexc
Level 9

Re: Roku Ultra - wireless network issues - no Interference menu option

And I think we all can agree to that!

ektoplasm
Level 9

Re: Roku Ultra - wireless network issues - no Interference menu option

I don't understand why they don't just add an option to turn down the wifi signal or turn it off. Every wifi chip supports this.

0 Kudos
RMinNJ
Level 8

Re: Roku Ultra - wireless network issues - no Interference menu option

They used to have the option to turn down the wifi signal in the wifi hidden menu but they took it away. I have no reason to operate my Roku from outside in my driveway...baffle why the roku signal is so strong.. I assume so you can cast from a phone in another part of the home.

So far the idea of opening it up and taking the antennas off seems the most sound.  

okiimatsu
Level 8

Re: Roku Ultra - wireless network issues - no Interference menu option

Roku, thanks for all the problems you've frustratingly caused on my home wifi. You are now DUMPED!!!!!!

EAT IT!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

0 Kudos