Network - Wireless & Wired Connections

Help & troubleshooting for network issues, including connecting your device to your home Wi-Fi network, connecting to public networks, troubleshooting wireless issues & ethernet connections, and optimizing streaming performance.
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
basketbuild
Level 8

Roku Ultra - wireless network issues - no Interference menu option

This option exists on the Roku 3 in the Wireless Secret Screen. It's an option to disable Interference. But, does not exist in the Roku Ultra. My only option to completely prevent issues on my wireless network right now is to unplug the power for my Roku Ultra. Here are all the details and everything I've tried:

I was experiencing trouble with my wireless network. And, while scanning the local channels, I noticed for any Roku device, there's a corresponding Roku-Direct-XXXXXXXXX being broadcast over the same channel that my wireless router is using. I looked up what this is for, and appears to be for the Enhanced remote to work with the Roku.

Seeing that, I thought the most obvious solution might be changing the channel that my wireless router is using. I looked up how to do that, logged into my wireless router, and was able to successfully change the channel that it's broadcasting over. I did some tests, and realized the issue wasn't resolved. I was able to confirm this by performing another scan for wireless networks, and the noticeable drop in wireless network performance. The Roku is following my wireless router channel around.

After doing more research, I saw that other people had success disabling an option in a hidden menu. The option is called "Interference", and to get to that option, one must press Home five times, then press FF, Play, Rewind, Play, FF. Then, select Wireless Secret Screen. Then, select Interference. Then, the option was either "None" or "Disable". I completed the steps, performed a scan on the wireless network again, and saw that my Roku 3 is no longer following around the channel my wireless router is using and harassing it.

However, when I attempt to do the same on my Roku Ultra, the option is missing. Some more research, and I found a 4 month old post on reddit of another user seeing (or, not seeing) the same thing as me. I searched through Roku documentation and couldn't find any mention of the option being there or not.

I'm not a fan of contacting a company for support typically. But, this one was bugging me due to the degraded network performance I was experiencing. So, I begrudgingly called up Roku technical support. After a bit of explaining the above information to the agent, some speculation between us was had on why the option wasn't there. I was able to describe why my Roku 3 wasn't causing issues anymore. And, which menu I do have access to in the Roku 3, etc. After going through the steps to reach the menu and having him select the appropriate sub-menus, the agent was able to confirm he had the same options missing from the local Roku Ultra test device they have on location.

I explained that I REALLY like my Roku, and would like to not switch to something else because of this. But, as much as I love it, I obviously couldn't continue with WiFi issues. The agent consulted with 3 supervisors, and they all said the feature didn't exist in the Roku Ultra (which we already knew), and that it isn't possible to disable Interference anymore. That was disappointing. The agent consulted with a "Senior Executive" as the last hope.

The agent came back stating that the "Senior Executive" stated to use a lower channel. They stated "31" or "43". I didn't see either as an option for the 5GHz range in my wireless router. So, I selected the closest one, 36. Saved the setting, waited for the wireless router to kick me off and refresh the signal, etc. When it came back up, a quick scan didn't show the Roku Ultra broadcasting over the new channel. I thought we had solved it! The agent and I had a quick chat, and we ended the call.

Unfortunately, a few minutes later, the Roku Ultra did manage to find the new channel the wireless router was broadcasting on, and it moved right over to broadcasting over top of it again! I can't bring myself to calling back after all the resistance my inquiries were met with.

Is the Interference setting truly no longer going to be an option? Does anyone else know of another way to get the Roku Ultra from broadcasting over top of my wireless router? The agent didn't really have another option for me outside of what I've outlined above. Am I out of luck unless I find a used Roku 3 I can buy? I was hoping to retain my 4K. I may have to move to an Apple TV or something else. This makes my network crawl sometimes...

Labels (2)
28 Replies
basketbuild
Level 8

Re: Roku Ultra - wireless network issues - no Interference menu option

Help?
0 Kudos
DBDukes
Level 10

Re: Roku Ultra - wireless network issues - no Interference menu option

Why not try getting help with your initial issue? All you said was "trouble" with your wireless network. You did some research, found the WiFi direct transmission -- which has been happening on upper tier Roku devices since 2013 -- and seem to have concluded that was the source of your "trouble."

Since those secret menus -- that is what they call them -- are officially unsupported, you can't rely on them to always do what you're wanting them to do, as you've found out.

So, I suggest stating clearly and succinctly the original issue that started you down this rabbit hole. What's wrong? Maybe we can help.
DBDukes
http://www.dbdukes.com/
Roku Ultra (4660)
Roku Premiere+ (3921)
0 Kudos
basketbuild
Level 8

Re: Roku Ultra - wireless network issues - no Interference menu option

"DBDukes" wrote:
Why not try getting help with your initial issue? All you said was "trouble" with your wireless network. You did some research, found the WiFi direct transmission -- which has been happening on upper tier Roku devices since 2013 -- and seem to have concluded that was the source of your "trouble."

Since those secret menus -- that is what they call them -- are officially unsupported, you can't rely on them to always do what you're wanting them to do, as you've found out.

So, I suggest stating clearly and succinctly the original issue that started you down this rabbit hole. What's wrong? Maybe we can help.

It's causing massive amounts of dropped packets, retries, and interference in general. Meaning, it causes other devices to drop, buffer, etc when using WiFi. Once the Roku Ultra is unplugged, everything runs without a hitch.
0 Kudos
basketbuild
Level 8

Re: Roku Ultra - wireless network issues - no Interference menu option

Bumping thread up again. Amongst all this spam, and the information I've been able to find so far, this isn't painting a great picture for Roku to their customers. I think I''m already one foot in the direction of going to another device.
0 Kudos
DBDukes
Level 10

Re: Roku Ultra - wireless network issues - no Interference menu option

"basketbuild" wrote:
Bumping thread up again. Amongst all this spam, and the information I've been able to find so far, this isn't painting a great picture for Roku to their customers. I think I''m already one foot in the direction of going to another device.

As many many users of Roku Ultra and other WiFi Direct devices from Roku have no such issues, that would point to something peculiar to your setup. Whether it's something about your network or other equipment, or simply a bad Roku device, would be difficult to discern. 

If you feel it's that Roku device, and if others here on the forum are unable to help (I have no such issues with any of my multiple Roku devices, and I have no first-hand experience with what you're encountering) it would be best to exchange it for another (if it's something about that one particular device), or to go with another brand altogether.

Keep in mind that you first posted about this on a Friday night. Roku techs that frequent the forums are likely not around, nor is the regular moderator (as you can tell from the amount of spam on the forums at the moment). Users more experienced with issues like you describe haven't all been around in the last day and a half, so it may take a bit longer before others that are better able to assist will be here.
DBDukes
http://www.dbdukes.com/
Roku Ultra (4660)
Roku Premiere+ (3921)
0 Kudos
basketbuild
Level 8

Re: Roku Ultra - wireless network issues - no Interference menu option

I don't appreciate dismissive and accusatory replies.

Unplugging the Roku Ultra resolves the problem. Same thing used to happen with Roku 3 before I found the hidden setting.
0 Kudos
atc98092
Level 16

Re: Roku Ultra - wireless network issues - no Interference menu option

I don't believe he was being dismissive to you, and he also happens to be someone who has helped a great many people. I understand your frustration, but you can't expect the Roku employees to be here at all times. This isn't considered (by Roku) to be a technical support forum, but Tanner will do what he can when he returns to work tomorrow, I'm sure. 
Dan
Roku Stick (3600), Ultra (4640), Premiere (3920), Insignia 720p Roku TV, Sharp 4K Roku TV, Nvidia Shield, Windows 10 Pro x64 running Serviio and Plex on a wired Gigabit network.
0 Kudos
basketbuild
Level 8

Re: Roku Ultra - wireless network issues - no Interference menu option

I never said that I expected a Roku employee to be here. That's an assumption that has been made by @dbdukes.

Please don't reply to my thread unless you can help. Again, I don't appreciate anyone dismissing my issue, or making assumptions.
0 Kudos
Smokindog
Level 9

Re: Roku Ultra - wireless network issues - no Interference menu option

"DBDukes" wrote:
"basketbuild" wrote:
Bumping thread up again. Amongst all this spam, and the information I've been able to find so far, this isn't painting a great picture for Roku to their customers. I think I''m already one foot in the direction of going to another device.

As many many users of Roku Ultra and other WiFi Direct devices from Roku have no such issues, that would point to something peculiar to your setup. Whether it's something about your network or other equipment, or simply a bad Roku device, would be difficult to discern. 

If you feel it's that Roku device, and if others here on the forum are unable to help (I have no such issues with any of my multiple Roku devices, and I have no first-hand experience with what you're encountering) it would be best to exchange it for another (if it's something about that one particular device), or to go with another brand altogether.

Keep in mind that you first posted about this on a Friday night. Roku techs that frequent the forums are likely not around, nor is the regular moderator (as you can tell from the amount of spam on the forums at the moment). Users more experienced with issues like you describe haven't all been around in the last day and a half, so it may take a bit longer before others that are better able to assist will be here.

WiFi direct can and does cause differing issues.  I'm not saying his issue is a result of WiFi direct but I do believe some of the remote battery issues may result from WiFi Direct issues.  WiFi direct uses the same frequency and channel as the WiFi connection so when/if you change channel or frequency the WiFi direct pairing must follow.  I've got a pretty sophisticated network that will modify my routers as the local environment changes based on interference from others.  I believe when the channel changes the implementation of WiFi direct is could cause drain as it "looks for home base" through either scanning and/or changes to power level used.  This problem was prevalent in many early cell implementations when no one took into account marginal and/or fringe reception issues.  I remember Sprint issuing a firmware update that added back almost 50% of the standby battery time by mitigating this issue.

Again, I'm not saying it IS the issue, I'm just saying to not be so dismissive.  I've seen this in multiple posts on this forum.  THAT is how problems never get fixed..

A new OS release was just put out so just because something WAS working fine doesn't mean it IS working fine.  I've got new issues on the Stick processing MPEG2 when coincidentally it did without error on OS8 when it wasn't "supported".  I've got remote reconnect issues with OS9 that weren't there before.  I've read about battery drain issues and experienced them on OS9 and now this.

AGAIN, I'm NOT trying to say WiFi direct is the culprit in any/all of these but until someone can properly eliminate it through testing we just don't know.
Brought to you from someplace in Texas!
0 Kudos