Network - Wireless & Wired Connections

Help & troubleshooting for network issues, including connecting your device to your home Wi-Fi network, connecting to public networks, troubleshooting wireless issues & ethernet connections, and optimizing streaming performance.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
ultra_streamer
Level 7

Roku Ultra not connecting to Google Fiber router

I'm trying to set up my new Roku Ultra 4800X, but it won't connect to my Google Fiber home WiFi. It does connect to my mobile hot spot. I updated the Roku software via the mobile hotspot connection, but it still won't connect to my home WiFi.

It shows an error after I put in the WiFi password.

I restarted both the router and the Roku device, still no luck.

I spent 30min with Roku chat support. Nothing the support suggested has worked.

My home WiFi is 500Mbps and dual band (2.4GHz and 5GHz).

Anyone has had similar problems? Any new ideas I can try?

0 Kudos
5 Replies
atc98092
Community Streaming Expert

Re: Roku Ultra not connecting to Google Fiber router

Make sure the 5 GHz radio isn't using what is called a DFS channel. Roku devices won't work on them. The channel number must either be below 49 or above 148. 

Can't say why it's not seeing the 2.4 GHz radio, though. Unless there's some sort of interference blocking it. You might try a different channel on 2.4 GHz. The Roku will work with any 2.4 GHz channel. 

Dan

Roku Community Streaming Expert

Help others find this answer and click "Accept as Solution."
If you appreciate my answer, maybe give me a Kudo.

I am not a Roku employee.
0 Kudos
ultra_streamer
Level 7

Re: Roku Ultra not connecting to Google Fiber router

Thanks @atc98092.

I checked, and my 5GHz channel is indeed using a non-DFS frequency. The channel is set to "auto" and the only options I have are 36 and 149.

0 Kudos
atc98092
Community Streaming Expert

Re: Roku Ultra not connecting to Google Fiber router


@ultra_streamer wrote:

Thanks @atc98092.

I checked, and my 5GHz channel is indeed using a non-DFS frequency. The channel is set to "auto" and the only options I have are 36 and 149.


Yep, those are both valid channels for Roku devices. I can't explain why you can't see it. You might try using the Network Reset menu function in the Settings menu and see if that clears up the issue. What that does is delete any previously saved network information. So you'll have to re-enter any network passwords you've connected with previously. It doesn't delete anything else on the Roku.

Dan

Roku Community Streaming Expert

Help others find this answer and click "Accept as Solution."
If you appreciate my answer, maybe give me a Kudo.

I am not a Roku employee.
0 Kudos
ultra_streamer
Level 7

Re: Roku Ultra not connecting to Google Fiber router

@atc98092, thanks again.

I finally got it working by setting up different SSIDs for my 2.4GHz channel and 5GHz channel. They had identical SSIDs before.

Every other device in the house was OK with the previous setup. Not Roku. Roku set up is definitely behind its time.

I shouldn't have had to waste hours on something like this. I'm very disappointed with Roku's technology level.

0 Kudos
atc98092
Community Streaming Expert

Re: Roku Ultra not connecting to Google Fiber router

I've always used different SSIDs on my 2.4 and 5 GHz radios, so maybe that's why I have never encountered any issue. Still it's strange that it made any difference. Oh well, working now is the important thing. Nice work!

Dan

Roku Community Streaming Expert

Help others find this answer and click "Accept as Solution."
If you appreciate my answer, maybe give me a Kudo.

I am not a Roku employee.
0 Kudos