Network - Wireless & Wired Connections

Help & troubleshooting for network issues, including connecting your device to your home Wi-Fi network, connecting to public networks, troubleshooting wireless issues & ethernet connections, and optimizing streaming performance.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Highlighted
PBG
Level 9

Roku Ultra 4670X only connects to 2.4 GHz channel 11 @ 50 to 65 Mbps

Jump to solution

The device works fine. Connects via wireless and wired. It’s stable with no problems. The wireless signal strength is Excellent. I just bought the Ultra thinking I was buying a device capable of meeting wireless throughput higher than 100 Mbps rated Ethernet on the Ultra. 

The Roku Ultra specs say it has 802.11ac. Not sure why the Ultra won’t connect to the higher throughput channels on my Wireless router (which is a gigabit capable device). My ISP service is 200+ Mbps and our other devices reach those speed. 

When I put an iPad Air 2 right next to the Roku Ultra, the iPad connects to the router at a 585 Mbps connection, so I can reach my full ISP speed. The Ultra will connect at only 50-65 Mbps and always on channel 11. When I connect with Ethernet, the Ultra connects in the 55 to 88 Mbps range.

i don’t see any wireless options in the Network Menu options.

Is this behavior normal for the Ultra?

 

0 Kudos
4 Solutions

Accepted Solutions
Highlighted
Community Manager
Community Manager

Re: Roku Ultra 4670X only connects to 2.4 GHz channel 11 @ 50 to 65 Mbps

Jump to solution
Hi there,

Thanks for the note.

If your wireless router is broadcasting both 2.4GHz and 5GHz networks, your device will connect to the network with the higher received signal strength. If your 5GHz network is broadcasting on a DFS channel, your device also wouldn't be able to connect, as these types of channels are not supported.

To test, I'd recommend trying to either switch the wireless broadcast channel on your 5GHz network, or disable 2.4GHz to see if this resolves the issue. Please keep us posted!

Thanks,
Tanner
Tanner D.
Roku Community Manager

View solution in original post

atc98092
Level 17

Re: Roku Ultra 4670X only connects to 2.4 GHz channel 11 @ 50 to 65 Mbps

Jump to solution

https://netbeez.net/blog/dfs-channels-wifi/

 

Don't use any channel in the DFS rows. Basically 149 or higher, or 48 or below.

Dan
Roku Stick (3600), Ultra (4640), Ultra (4670), Premiere (3920), Insignia 720p Roku TV, Sharp 4K Roku TV, Nvidia Shield, Windows 10 Pro x64 running Serviio and Plex on a wired Gigabit network.

View solution in original post

Highlighted
atc98092
Level 17

Re: Roku Ultra 4670X only connects to 2.4 GHz channel 11 @ 50 to 65 Mbps

Jump to solution

@PBG wrote:

How do I identify which channels on the 5GHz are DFS and non-DFS? The available channels in the pictures I posted earlier don’t offer any clues. 



https://netbeez.net/blog/dfs-channels-wifi/ There's a chart on this page that lists the DFS channels. Don't choose one of them. Smiley Happy

Dan
Roku Stick (3600), Ultra (4640), Ultra (4670), Premiere (3920), Insignia 720p Roku TV, Sharp 4K Roku TV, Nvidia Shield, Windows 10 Pro x64 running Serviio and Plex on a wired Gigabit network.

View solution in original post

Highlighted

Re: Roku Won't Connect to Apple Airport 2.4GHz

Jump to solution

I went into both of my apple routers and turned on the 5 ghz band. Not sure why I haven't done this yet. Both of the Roku devices connected to the 5 ghz band with no issues. I put all of our main devices on 5 ghz and left the others on 2.4 ghz. The Roku devices will also connect to the 2.4 ghz. I presume the 2.4 channels had too much going on hence the Roku's wouldn't connect. Thanks!

View solution in original post

31 Replies
Highlighted
PBG
Level 9

Re: Roku Ultra 4670X only connects to 2.4 GHz channel 11 @ 50 to 65 Mbps

Jump to solution

Channel 11 is a 2.4Ghz channel lower speed channel that has a max of 72 Mbps. The Ultra won’t connect to any 5GHz channel which gives 10 times the connection speed. 

0 Kudos
Highlighted
Community Manager
Community Manager

Re: Roku Ultra 4670X only connects to 2.4 GHz channel 11 @ 50 to 65 Mbps

Jump to solution
Hi there,

Thanks for the note.

If your wireless router is broadcasting both 2.4GHz and 5GHz networks, your device will connect to the network with the higher received signal strength. If your 5GHz network is broadcasting on a DFS channel, your device also wouldn't be able to connect, as these types of channels are not supported.

To test, I'd recommend trying to either switch the wireless broadcast channel on your 5GHz network, or disable 2.4GHz to see if this resolves the issue. Please keep us posted!

Thanks,
Tanner
Tanner D.
Roku Community Manager

View solution in original post

Highlighted
kclennan
Level 7

Re: Roku Ultra 4670X only connects to 2.4 GHz channel 11 @ 50 to 65 Mbps

Jump to solution

I am experiencing the same issues.  I have consistently interrupted buffering.  I have had my cable company out here.  When testing my internet speed right next to my tv the tests are showing 100+ mbs speed.  I can't watch any live sports without constant buffering.  My cable company, youtubetv all point to my Roku player.  I am very frustrated with my ROKU as there is no human to receive customer service!!

0 Kudos
Highlighted
PBG
Level 9

Re: Roku Ultra 4670X only connects to 2.4 GHz channel 11 @ 50 to 65 Mbps

Jump to solution

Tanner. Thanks for responding. Here’s what I found:

The wireless router I’m connecting to is an Apple AirPort Extreme 802.11ac with both the 2.4GHz and 5GHz channels set to automatic. When I turn the 2.4 GHz channel OFF, I get a warning message in AirPort Utility that doing that can cause some network performance issues - maybe because there might be too many devices connecting to the 5GHz channels, or maybe that some of the devices may not have 5GHz capability. Not completely sure about that. 

With the 2.4 GHz OFF, the Roku Ultra doesn’t recognize our AirPort Extreme home main floor network. Curiously, the Roku does recognize the 5GHz network on a Sagecom router we have in the basement. Because the Roku Ultra is so far away from that router, the signal level at the Roku shows GOOD but the speed is only 29-33 Mbps (slower than the performance at 2.4GHz when connected to the AirPort Extreme 802.11ac on the main floor - which is understandable (not sure GOOD is very good). So it seems that there’s some incompatibility between the Roku Ultra and the Apple AirPort Extreme.

You mentioned that the Roku connects to the channel with the highest signal level. I’m not sure how other devices do it, but my iPad Air 2 has 802.11a/b/g/n/ac, dual channel (2.4 GHz and 5GHz), and it always connects to the 5GHz channel. Maybe the iPad connects to the 5 GHz channel unless the signal level is below some threshold, then it drops back to the 2.4GHz??

It seems like the Roku Ultra would benefit by a firmware update that improves this performance, and fixes whatever the compatibility issue when connected to the Apple AirPort Extreme 802.11ac.

Like I said in the original post, the device works fine - I use it connected via Ethernet. That’s limited by the 100Mbps Roku interface - I get speeds up to 88Mbps which is as I expected on the 100 Mbps Ethernet (not sure why the Ultra didn’t get gigabit Ethernet). I’m a little disappointed that I don’t have the 200+ Mbps capability (limited only by my ISP plan) using the Roku Ultra, as that throughput will likely be needed

0 Kudos
Highlighted
Community Manager
Community Manager

Re: Roku Ultra 4670X only connects to 2.4 GHz channel 11 @ 50 to 65 Mbps

Jump to solution

@PBG Thanks for the additional details here. One more question, do you know if your Airport Extreme router happens to be broadcasting on a DFS channel? If so, you'll need to change the wireless broadcast channel to a non-DFS channel to see if this clears up the issue. 

Feel free to follow up with me directly with any additional details or information that may be helpful. I'll continue working with you for any other questions that may arise while we investigate. 

 

Thanks,

Tanner

Tanner D.
Roku Community Manager
atc98092
Level 17

Re: Roku Ultra 4670X only connects to 2.4 GHz channel 11 @ 50 to 65 Mbps

Jump to solution

https://netbeez.net/blog/dfs-channels-wifi/

 

Don't use any channel in the DFS rows. Basically 149 or higher, or 48 or below.

Dan
Roku Stick (3600), Ultra (4640), Ultra (4670), Premiere (3920), Insignia 720p Roku TV, Sharp 4K Roku TV, Nvidia Shield, Windows 10 Pro x64 running Serviio and Plex on a wired Gigabit network.

View solution in original post

Highlighted
PBG
Level 9

Re: Roku Ultra 4670X only connects to 2.4 GHz channel 11 @ 50 to 65 Mbps

Jump to solution

I don’t see DFS mentioned anywhere when I look through everything in AirPort Utility, but I’m guessing that that router uses DFS. I don’t see an option anywhere to enable it or disable it or change it to something else. Not sure I’d want to change it to something else for fear of affecting all the other phones, tablets, computers, and smart TVs here that connect and work OK.

Apple recommends setting the AirPort Extreme up as a dual channel auto-channel-select device (that’s the default setup). There is an option to use a separate network name for the 5GHz network, but I hesitated to set it up that way because with automatic channel setting, we can transport the iPhones and iPads around the house and they always stay connected. I’m afraid that using separate networks for 2.4GHz and 5GHz would cause us to lose connection on 5GHz when in some parts of the house and we’d have to manually reconnect to the 2.4GHz network. Then reconnect manually to the 5GHz network when we got back closed to the router. Too much hassle.

Here’s my current network info:

Current Network Information: 11/22/19

Goodwin Network 12-01-2018:

  PHY Mode:802.11n

  BSSID:24:a0:74:76:15:34

  Channel:1

  Country Code:US

  Network Type:Infrastructure

  Security:WPA2 Personal

  Signal / Noise:-12 dBm / -96 dBm

  Transmit Rate:130

  MCS Index:15

 

Goodwin Network 12-01-2018:

  PHY Mode:802.11n

  BSSID:24:a0:74:76:15:35

  Channel:132,+1

  Country Code:US

  Network Type:Infrastructure

  Security:WPA2 Personal

  Signal / Noise:-29 dBm / -96 dBm

 

 

0 Kudos
Highlighted
PBG
Level 9

Re: Roku Ultra 4670X only connects to 2.4 GHz channel 11 @ 50 to 65 Mbps

Jump to solution

68F144F8-F968-402A-BE8F-6A94455B9E7C.jpeg1C48388D-3ED3-4412-B805-DDC203F9DE58.jpeg

0 Kudos
Highlighted
atc98092
Level 17

Re: Roku Ultra 4670X only connects to 2.4 GHz channel 11 @ 50 to 65 Mbps

Jump to solution

@PBG wrote:

I don’t see DFS mentioned anywhere when I look through everything in AirPort Utility, but I’m guessing that that router uses DFS. I don’t see an option anywhere to enable it or disable it or change it to something else. Not sure I’d want to change it to something else for fear of affecting all the other phones, tablets, computers, and smart TVs here that connect and work OK.

Apple recommends setting the AirPort Extreme up as a dual channel auto-channel-select device (that’s the default setup). There is an option to use a separate network name for the 5GHz network, but I hesitated to set it up that way because with automatic channel setting, we can transport the iPhones and iPads around the house and they always stay connected. I’m afraid that using separate networks for 2.4GHz and 5GHz would cause us to lose connection on 5GHz when in some parts of the house and we’d have to manually reconnect to the 2.4GHz network. Then reconnect manually to the 5GHz network when we got back closed to the router. Too much hassle.

Here’s my current network info:

Current Network Information: 11/22/19

Goodwin Network 12-01-2018:

  PHY Mode:802.11n

  BSSID:24:a0:74:76:15:34

  Channel:1

  Country Code:US

  Network Type:Infrastructure

  Security:WPA2 Personal

  Signal / Noise:-12 dBm / -96 dBm

  Transmit Rate:130

  MCS Index:15

 

Goodwin Network 12-01-2018:

  PHY Mode:802.11n

  BSSID:24:a0:74:76:15:35

  Channel:132,+1

  Country Code:US

  Network Type:Infrastructure

  Security:WPA2 Personal

  Signal / Noise:-29 dBm / -96 dBm


Yes, your 5 GHz radio is using a DFS channel (132), so it needs to be changed for a Roku to see it. I use different SSIDs on my 2.4 and 5 GHz radios so I always know which one I've connected to. But I know some devices don't have that ability. 

Dan
Roku Stick (3600), Ultra (4640), Ultra (4670), Premiere (3920), Insignia 720p Roku TV, Sharp 4K Roku TV, Nvidia Shield, Windows 10 Pro x64 running Serviio and Plex on a wired Gigabit network.