Network - Wireless & Wired Connections

Help & troubleshooting for network issues, including connecting your device to your home Wi-Fi network, connecting to public networks, troubleshooting wireless issues & ethernet connections, and optimizing streaming performance.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
vanisingh96
Level 7

Roku Tv ignoring only my wifi network.

I have an Onn Roku TV, it was fully updated to the current firmware, and was working fine.

Now it disconnected from my wifi, and can't find it again. It finds all of my neighbors' just fine. It's like mine is blocked on it or being ignored.

I've tried different channels, a hotspot from my phone (couldn't see that either), unplugged and restarted both the tv and my router, tried the secret menu, even factory reset both my tv and router. Still can't see only my network.

Has anyone found a fix?

Labels (1)
0 Kudos
1 Reply
AvsGunnar
Level 10

Re: Roku Tv ignoring only my wifi network.

Your RokuTV should be capable of connecting to either the 2.4gz or 5gz bands of your network.  Even if your router is broadcasting a single SSID (single network name), your RokuTV should be able to connect to the 2.4gz band at least if your 5gz band is not configured properly.

Try doing a network reset at the RokuTV.  Settings..System..Advanced System Settings..Network Connection Reset..Reset Connection

This should automatically restart TV.  If not, then do Settings..System..Power..System Restart

Restart your router before resetting your RokuTV Network Settings.  You may have to press SCAN again a few times for your Network to appear.

If your network still does not appear, then most likely you will have to verify you have proper settings in your router....

1.  both the 2.4gz and 5gz radios are enabled and broadcasting

2. Under Wireless Settings in router, 2.4gz needs to be set to a channel between 1 and 11.  Do not use 12-14 even if these are options.  If set to Auto, needs to be connecting to your devices at one of these channels, 1-11. Other settings should at least be least b/g/n(Mixed), 20 mhz Bandwidth.

3. Under Wireless Settings in router, 5gz needs to be set to a channel between 36-48, or 149-161.  Roku devices will not operate on channels 52-140.  If you cannot get the above channels, try lowering your Bandwidth setting from 80mhz to either 20mhz or 40mhz.

If you download a wifi analyzer app to your mobile phone, it can quickly help you to understand how your network is configured.

If you still have problems, post back your router model number and any information you have discovered from the steps above.  It is likely just a network configuration in the router since the RokuTV is seeing neighboring wireless networks.  Note any LED lights you are seeing on the router also. 

 

 

 

 

 

0 Kudos