Network - Wireless & Wired Connections

Help & troubleshooting for network issues, including connecting your device to your home Wi-Fi network, connecting to public networks, troubleshooting wireless issues & ethernet connections, and optimizing streaming performance.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
mbsound
Level 7

Roku TV Wired Connection Keeps Resetting

Hello!

Roku TV: 5111X

TCL Model: 40FS3850

Software Version: 9.4.0 build 4200-08

 

So here's the deal, I wire everything I can. I got myself a USB NIC and when it works, it works great! However every time I power off my Roku TV and power it back on, I get an error saying that I need to set up an internet connection. This requires me to do the Network Reset dance to get it to look for the wired connection again.

Is there any way to get it to persistently see that it is sitting on a wired connection? Re-setting the network connection every time on bootup isn't the worst, it's just not ideal when you want something that just works!

The only other network oddity I have here is a PiHole running on the network, but my router is resolving to the PiHole, none of the devices on the network require any config apart from DHCP. Same issues persist when I disable the PiHole.

0 Kudos
1 Reply
AvsGunnar
Level 10

Re: Roku TV Wired Connection Keeps Resetting

From within the Roku TV, maybe try enabling Fast Start. (Settings..System..Power..Fast TV Start Enabled)

From router, you can try extending the lease time to the assigned MAC Address of the Roku TV.  Can also try to assign it a static LAN IP to bypass the lease time.  

Then there is the physical replacement of the ethernet cable itself (or at least the end connectors rj45).

I think the problem is with the NIC, not the other possiilities above.  It is the right one, no problem there, but, as you've seen, I think it is being powered down by the USB port when you turn off the TV, thus losing the network connection. (Everything is operating as designed.)  I would try enabling Fast Start as the first step. This should place TV more in a Sleep Mode, than Off mode.

Other than that, I know of other other way within Roku settings to keep the USB port powered.

 

0 Kudos