Network - Wireless & Wired Connections

Help & troubleshooting for network issues, including connecting your device to your home Wi-Fi network, connecting to public networks, troubleshooting wireless issues & ethernet connections, and optimizing streaming performance.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
BobFrankston
Level 7

Roku (TCL) prefers 2.4Ghz 1Mbps over a 5Ghz 19Mbps channel

I'm using a TCL/Roku but the issue is general. [rant omitted] my TCL Roku very strongly prefers a 2.4Ghz channel that goes at 1Mbps when there is a 5Ghz channel that operators at 19Mbps.

The reason is simple -- a very naive assumption in preferring a stronger signal over a better signal.

This is a bug in professional opinion. The easiest workaround when an SSID Is available on both 2 and 5 is to give me an option.

It is not in Roku's interest to choose the worst available signal. Even on APs with separate names for the 2.4 and 5 a screen pops up telling me that I am making a poor choice and that I should go with the worst option. Sure, there are fewer bars but the 5Gha is 20x faster!

PXL_20210527_134234968.jpg

Labels (2)
0 Kudos
12 REPLIES 12\
StreamerUser
Level 20

Re: Roku (TCL) prefers 2.4Ghz 1Mbps over a 5Ghz 19Mbps channel

Roku needs to provide a user setting to prefer 2.4Ghz or 5Ghz for dual band devices, but has resisted this for years.

You should provide direct feedback:  https://support.roku.com/contactus/contact-options

MichaelGWorkman
Level 8

Re: Roku (TCL) prefers 2.4Ghz 1Mbps over a 5Ghz 19Mbps channel

I was disappointed in my Roku Express not wanting to connect to 5 Ghz Wifi, only 2.4 Ghz Wifi. Ok so 2.4 Ghz is a product of the 1990's, over 20 years ago, why is a modern streaming device still stuck in the 1990's? Not impressed at all. The 2.4 Ghz Wifi in my apartment is very spotty and would often drop the connection. The only solution was to shell out some more money for a Roku Ultra and use an ethernet cable for the connection, instead of Wifi. Problem solved, but did not like having to spend more money on a new Roku device!!!

Strega
Level 16

Re: Roku (TCL) prefers 2.4Ghz 1Mbps over a 5Ghz 19Mbps channel

You can go to https://www.roku.com/products/compare to see which Roku models support 5GHz.  (Look for ones that say dual band.)  Eg: The Roku Express is single band (2.4GHz only) whereas the Express 4K, for $10 more, does include 5GHz.  The most-basic express does great here, but if 2.4GHz doesn't work for you, choose a different one.

0 Kudos
larrygrobertson
Level 8

Re: Roku (TCL) prefers 2.4Ghz 1Mbps over a 5Ghz 19Mbps channel

I agree 100% but there is an additional problem that I have run across.

I have 3 TCL 32S327 Smart TVs.

XFINITY

I had Xfinity high speed 1ghz service and 2.4ghz/5ghz Wi-Fi with their latest XB7 router.

The TV closest to the Microwave Oven, would drop the Wi-Fi connection when the oven is running until the microwave stopped and at that time the connection would resume automatically. My microwave is a newer top of the line LG model LMC1575BD.

Further research reveals that most microwave oven's magnetrons operate at a frequency of 2.45ghz which is very close to the TCL default  Wi-Fi connection speed of 2.4ghz.  As far as I can tell this problem does not occur on my iPhone, iPad, Android Phone & Android Tablet.

I solved the problem by going into the Xfinity Router and changing the Wi-Fi Connection names & passwords to separate names for each speed so that different devices can connect at different speeds.

2.4 Wi-Fi Name: MyPhones24

5.0 Wi-Fi Name: MyTVs50

The Xfinity router does not show the speed at which any given device is connected.  I assume that my TCL TVs connected at 5ghz when I used the "MyTVs50" Wi-Fi name, and although I didn't notice any improved speed performance it did solve the Microwave Oven interference problem for sure.

VERIZON FIOS

I recently dropped Comcast Xfinity and switched to Verizon FIOS 1ghz service.

They gave me their newest router the G3100 and 1ghz service. This router does show the connection speeds that each device is connected. Unfortunately the G3100 does not allow you to change the Wi-Fi names of 2.4ghz and 5ghz to make them unique. It does allow you to disable 2.4ghz connections across the board, however if you do, assuming that a 5ghz connection will be made instead, your router's Wi-Fi name will not show up at all in the list of available Wi-Fi connections on the TCL Roku TV. For this reason my TCL TVs always connects at 2.4ghz according to the router, with no exceptions.   With the TCL TVs all connected at 2.4ghz, there was no interference at all from the Microwave Oven.  On a positive note everything works great at 2.4ghz speed on Verizon FiOS!

CONCLUSION

I live in an apartment complex and I believe that the problem with Comcast Xfinity Wi-Fi interference introduced by the Microwave Oven might possibly be due to faulty wiring in their copper cable leading to their XB7 router even though they claim the wiring is perfect with no problems.  For example maybe there is a problem with the copper wire shielding not being grounded to "Earth Ground" like the building's electrical system is grounded.  There was also a problem of all channels having intermittent pixelization that Comcast could not solve even after 6 service calls. That is why I had to drop their service.

My problem appeared to be a Comcast problem not a TCL Roku TV problem.

ROKU (TCL) Solution

I agree with BobFrankston and StreamerUser 100% THERE SHOULD BE AN OPTION CHECKBOX IN THE TCL TV SETTINGS TO OVERIDE 2.4GHZ AND FORCE CONNECTION NEGOTIATIONS WITH THE ROUTER TO 5GHZ IF THE ROUTER SUPPORTS 5GHZ.

WHEN I RESEARCHED THE TCL ROKU TV, DOCUMENTATION BEFORE PURCHASING, IT SAID THAT IT SUPPORTS 5GHZ, BUT THIS MIGHT NOT BE TRUE SINCE THERE IS NO WAY TO PROVE IT. ALL EVIDENCE THAT I CAN FIND INDICATES THAT THE TCL ROKU TV MIGHT SUPPORT 5GHZ.  OF COURSE YOU CAN EXPECT SOME FINGER POINTING IN THE "BLAME GAME" BETWEEN COMCAST, VERIZON, ROKU AND TCL MOSTLY DUE TO ROUTER SETTING LIMITATIONS AND SPEED NEGOTIATION ALGORITHMS.  ALL OF THESE COMPANIES NEED TO MEET AND DEVELOP A STANDARD FOR WIFI SPEEDS THAT THEY CAN AGREE WITH.  LET US ALL GET ALONG IN HARMONY!

 

 

0 Kudos
AvsGunnar
Community Streaming Expert

Re: Roku (TCL) prefers 2.4Ghz 1Mbps over a 5Ghz 19Mbps channel

@larrygrobertson 

Basically you have to disable the G3100's SON (Self-Organizing Network) which is their mesh network in your router's settings.  This allows you to create seperate 2.4 ghz and 5ghz networks which you can then manually assign settings (namely the wireless channels).  Essentially, the SON feature steers to best connection that it automatically supposes.

When SON is enabled, you cannot change the assigned wireless channels on the 5ghz so they may be currently configured to use DFS channels (wireless channels between 52-140) that the Roku cannot see or use.  On the 5ghz band, Roku can only see and connect to non-DFS channels (36-48 and 149-161). 

Using a free wifi analyzer on your phone or mobile device (Apple/Play stores), you can easily see which wireless channels your router is broadcasting on both the 2.4ghz and 5ghz bands.

Once you are connected succesfully, the Roku will tell you which wireless channel you are using also, from Settings..Network..About.

Also, spot on with the above microwave interference.  Normally assigning to Ch. 1 on the 2.4 ghz will resolve these issues as well as lowering the bandwidth/channel width to 20 mhz.

------

To disable Verizon G3100 SON (mesh network)...

Under your Wi-fi...Advanced...     https://i.imgur.com/rMVUtFV.png (reference)

2.4 gz...

1.  Broadcast> Enable (this will broadcast the 2.4gz network radio)

2. 802.11 Mode> Switch to Legacy (This should broadcast b/g/n)

5gz...

1. Broadcast>Enable

2. 802.11 Mode>Compatibility (This should enable a/n/ac/ax)  

Other Advanced Options...

1. MeshWi-Fi Enabled>Switch to OFF. (This should disable SON, the merged network)

2. Transmit Power> set both 2.4 and 5 to High (100%)

Basic Settings

Rename your 2.4gz and 5gz Network SSIDs here. (ie. something and something5G).  Can keep your passwords the same.  [You should now have 2 distinct seperate networks, a 2.4gz and 5gz that is manually assignable regarding devices.

You may have to fiddle with channels but try Auto first on the 2.4gz.  Then go back and manually assign a channel. On 5ghz, use non-DFS channels (36-48 low band or 149-161 high band).

Click on image to enlarge...

anjpatel1a.png

 

 

Roku Community Streaming Expert
Just another Roku user... I am not a Roku employee.
Insignia RokuTV, Ultra 4660x, Premiere+ 3921, Express 4k+ 3941
larrygrobertson
Level 8

Re: Roku (TCL) prefers 2.4Ghz 1Mbps over a 5Ghz 19Mbps channel

Thank you AvsGunnar for this detailed information.  I will give this a try over the weekend and get back to you.

In the event that I screw it up, is there a reset to factory default settings for the G3100 that will allow me to try again?

Thanks a lot for this valuable information

 

0 Kudos
AvsGunnar
Community Streaming Expert

Re: Roku (TCL) prefers 2.4Ghz 1Mbps over a 5Ghz 19Mbps channel

@larrygrobertson 

To revert back to the merged network, you go back to the "Advanced Settings", enable the SON feature, and restart the router.  That will return you back to the condition before you disabled SON.

Normally, just take screenshots with your phone or computer (or write them down on a piece of paper) of your different settings before you change them and then just return them back to those settings.  This returns you back to the last known configuration.

The final method is to factory restart the router by pressing the reset button located on router.  This will reset the router back to default condition (all passwords and settings reverted back to default).  With this method, you will have to just setup your SSID name and passwords again.  It will, or at least, "should" connect back to internet automatically as these settings are stored in the ISP custom firmware installed on the router.

 

Roku Community Streaming Expert
Just another Roku user... I am not a Roku employee.
Insignia RokuTV, Ultra 4660x, Premiere+ 3921, Express 4k+ 3941
larrygrobertson
Level 8

Re: Roku (TCL) prefers 2.4Ghz 1Mbps over a 5Ghz 19Mbps channel

Hi AvsGunnar,

I finally got around to testing the separate name method as you described.  The network names associated with the 5ghz speeds do not show in the TCL Roku Settings->Network->Set up connection->WiFi list, It only lists the 2.4ghz connection.

I tried it on my iPhone 8 and all speeds showed in the list and I can connect to all speeds successfully.

Conclusion 2 (Verizon's G3100 not implementing correct 5ghz compatibility with TCL Roku)

This confirms Verizon's G3100 's implementation of 802.11 Mode>Compatibility (a/n/ac/ax) does not match TCL 32S327 Smart TV's implementation of 5ghz speed.

What are the odds of anyone at Comcast XFinity Tech Support being able to define the exact protocols of their XB7 5ghz connection so that it can be compared to Verizon's G3100 's 5ghz implementation of 802.11 Mode>Compatibility (a/n/ac/ax)?

Just to make sure I tested the XB7 & G3100 again and recorded the WiFi download speeds reported by the TCL Roku TV under Settings->Network->Check Connection for each router:

Comcast XB7 2.4ghz 49mbps

Comcast XB7 5.0ghz 87mbps

Verizon G3100 2.4ghz 52mbps

Verizon G3100 5.0ghz Network not available in list

Any ideas as to where I should go from here?

I will call Verizon but I don't think they will have a fix for the problem nor will they investigate why the Comcast router XB7 supports the Roku at 5ghz and the Verizon router G3100 does not.

Will it be an endless loop of finger-pointing?

I would like to hear any theories or solutions you may have.

Smiley LOL

Thank you

0 Kudos
AvsGunnar
Community Streaming Expert

Re: Roku (TCL) prefers 2.4Ghz 1Mbps over a 5Ghz 19Mbps channel

@larrygrobertson 

Please post the screenshots of your 5ghz settings from the G3100.  Also verify that you have SON disabled, and not merely named the two SSIDs differently.  SON has to be disabled and the 5ghz wireless channels configured to use non-DFS channels (36-48 or 149-161) for the Roku to see the router's 5ghz band.  Either cross out any personal info in screenshot or feel free to PM (private message) me the screenshot.  Additionally, when your Iphone8 is connecting to your 5ghz band, what wireless channel is it indicating connection on?

Older firmware versions of the G3100 did preclude some users from changing the wireless channels, but the firmware versions that allow the disabling of SON have provided a workaround to this now.  Without disabling SON, there is no way to change the wireless channels; and if the router is using DFS channels, then the Roku device by default will have to use the 2.4ghz band since it can't see the 5ghz.

The XB7 reportedly has a much better range and broadcasting ability than other Xfinity/Comcast routers and are often suggested for troublesome wireless problems.

I don't think this is your issue though, but more a configuration issue. (at least from what you have reported back.)

 

Roku Community Streaming Expert
Just another Roku user... I am not a Roku employee.
Insignia RokuTV, Ultra 4660x, Premiere+ 3921, Express 4k+ 3941