Network - Wireless & Wired Connections

Help & troubleshooting for network issues, including connecting your device to your home Wi-Fi network, connecting to public networks, troubleshooting wireless issues & ethernet connections, and optimizing streaming performance.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
renojim
Community Streaming Expert

Re: Roku Express not detecting wifi

Jump to solution

That option doesn't exist for me. The mode drop down menu is the only mention of Legacy I can find. 

You must be running an old version and should probably update.  Do you have it set to "N" and not "Legacy"?  You might also want to set the width to 20MHz if it's set to 40MHz.

Roku Community Streaming Expert

Help others find this answer and click "Accept as Solution."
If you appreciate my answer, maybe give me a Kudo.

I am not a Roku employee.
0 Kudos
kylemcqueen75
Level 8

Re: Roku Express not detecting wifi

Jump to solution

I've updated to the newest version a couple days ago as a possible fix. I will double check but I am 99% sure this option wasn't listed. I won't be home for a couple days to double check. Still wouldn't explain why it the rokus and only the rokus stopped finding my network after near 2 years of one working fine. Thought maybe it was age but newer one followed it just a couple days after the first one. Has to be a roku update, only thing that makes sense.

0 Kudos
mmortal03
Level 10

Re: Roku Express not detecting wifi

Jump to solution

It looks like, under the hood, the applicable setting "legacy_rates" was added to OpenWrt back in May 2017, in version 18.06.0, but I can't easily find when the option was added to the LuCI Web Interface code, (I think it was sometime in 2018): 
https://github.com/openwrt/openwrt/commit/ed62d91f4b5296a4aa883ce975d76f590ef4e910

Anyway, when you get back home, please watch that YouTube video I posted and it will point you to the exact location of the setting. If it's still not there, let us know what version of OpenWrt you have, because something doesn't line up, and it really should be there if you upgraded to the latest version. 

Another idea would be to just change the underlying setting to '0' using the command line over SSH, so that's something to explore, as well.

0 Kudos
nicklowe
Level 7

Re: Roku Express not detecting wifi

Jump to solution

Hi all,

The original setting was added to LuCI by Sven Roederer under the Advanced Settings tab in January 2018 via commit:

https://git.openwrt.org/?p=project/luci.git;a=commitdiff;h=a6b41271b711b233e697bab65755d6b6653414c1

For info, I have changed the default in the master branch to disable 802.11b by default:

https://git.openwrt.org/?p=openwrt/openwrt.git;a=commit;h=ce5bcff304e474d604ac0e25de7b6b124f764351

And for LuCI, I have in a companion commit moved the setting to the General Setup tab and added a description:

https://git.openwrt.org/?p=project/luci.git;a=commit;h=ec49f3b546c905a4b358d54c8d2d70e86ce023a0

These will fold in to the next release branch of OpenWRT.

You must have a device using a driver that makes use of the mac80211 subsystem for this option to be available.

Best,

Nick

AK29
Level 7

Re: Roku Express not detecting wifi

Jump to solution

@RokuDanny-R  I have tried rebooting my router, my Roku express and even tried using the hot spot on my phone. The Roku express I have still won’t detect any networks. Are there any solutions? Or will I have to buy another Roku as this one is almost 2 years old. 

0 Kudos
kylemcqueen75
Level 8

Re: Roku Express not detecting wifi

Jump to solution

Sorry I never replied. I found that option and it seemed to have fixed the problem. Haven't failed on me again. Confusing why it just randomly became an issue but hey, it's working now. 

Anyone wondering, I am using OpenWRT and the option for legacy rates was my problem. Look for a youtube video posted back a bit by @mmortal03 

RokuDanny-R
Roku Employee
Roku Employee

Re: Roku Express not detecting wifi

Jump to solution

Hi everyone,

In addition to the troubleshooting steps that @renojim has provided, I would recommend checking out our Support page for troubleshooting issues here: What should I do if I cannot connect to my home network or the internet?

Please answer the following questions so we can get a better understanding of what you are seeing:
- Have you ensured your router is broadcasting a 2.4GHz Wi-Fi network for the device to connect to? The Roku Express is only compatible with wireless b/g/n networks on the 2.4 GHz spectrum. 
- Have you tried changing the wireless broadcast channel on the router to see if this will allow your device to connect? 
- Have you tried moving the device closer to your router to see if you can get connected? 
- How long have you been experiencing this problem?

If those things still aren't helping, feel free to send me a PM with your Roku account email address and the serial number of your Roku from Settings>System>About along with the answers to the above questions and I'll be able to assist you further from there.


Thanks,
Danny

Danny R.
Roku Forum Moderator

View solution in original post

0 Kudos
DianaM1
Level 7

Re: Roku Express not detecting wifi

Jump to solution

I have one Roku Express that I have been using. While I was dusting my entertainment center, I found a second one. I plugged it in and it does not find the network. The signal strength should not be the problem because the one I have been using works fine. Any idea what I can do to get it working? I would like to keep it as a backup just in case anything happens to the one that works right now. ThanksThe one that doesn't workThe one that doesn't workThe one on the right doesn't workThe one on the right doesn't work

0 Kudos
Whitetiger
Level 7

Re: Roku Express not detecting wifi

Jump to solution

Having the problem of the roku not connecting to the internet worked up till a week ago.  Have done everything suggested outside of going and buying another one.  Reset roku, moved modem up and moved roku so straight line to modem.  At wits end

0 Kudos
HaveAnEpiphany
Level 7

Re: Roku Express not detecting wifi

Jump to solution

Thank you for this! I had tried adjusting almost every conceivable setting in my OpenWRT router without success. This did the trick for me!


@mmortal03 wrote:

@kylemcqueen75 wrote:

The mode is listed as "N" with the other option being legacy. I don't have legacy selected. Main thing is that everything worked fine for a long time, then just randomly stopped working. Haven't touched my wifi settings until the rokus stopped working. 


That's not the same setting. You have to specifically uncheck the "allow legacy 802.11b rates" setting, then Save, and Save and Apply.

The setting is under:
Network->Wireless
Click the Edit button associated with the 2.4GHz radio
Go to Advanced Settings tab
uncheck "allow legacy 802.11b rates"
Save, then Save and Apply. Possibly reboot the router after this.