Network - Wireless & Wired Connections

Help & troubleshooting for network issues, including connecting your device to your home Wi-Fi network, connecting to public networks, troubleshooting wireless issues & ethernet connections, and optimizing streaming performance.
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
LouHosman
Level 7

Roku Express had excellent wifi, loses internet

I recently purchased a few Roku Expresses when I switched from Uverse to Xfinity for cable and internet so I could avoid the cable box rental fees.  So far I'm able to use most of them with no problem, but I have one finicky Express that constantly drops the internet connection.  

When I run the wireless check, the wifi connection is always excellent, it just says that there is no internet connection.  I've unplugged/plugged in everything at least a few times, looked for firmware updates, etc. and haven't had any luck.  Does anyone have any suggestions, or did I just get a bad Express?  

0 Kudos
9 Replies
jaxxroks
Level 7

Re: Roku Express had excellent wifi, loses internet

Exactly happened to me with the premiere but no problem with any other earlier models. I was thinking maybe because my TV was too outdated so I returned it for the express same thing happened. I found this forum and pm roku tanner d and it totally helped. Once in a great while it buffers. Last nite the internet thing happened so I went to system and updated and turned it off and then it worked good
0 Kudos
LouHosman
Level 7

Re: Roku Express had excellent wifi, loses internet

Thanks,

I don't think it's my TV.  It's an oCOSMO (Sceptre) that's a couple of years old, but I can't think of why that would interfere with the internet connection if wifi is good.  What were the steps you took to alleviate the problem?  

I neglected to mention in my op that my wifi router is a TP-Link AC1200.
0 Kudos
atc98092
Level 16

Re: Roku Express had excellent wifi, loses internet

Sometimes with WiFi just moving the device a few inches can make a marked difference in connection. In particular, try moving it a little further away from the TV, and maybe higher or lower from its current position. At 2.4 GHz, the radio wavelength is quite small (we're talking under 5 inches), so placement can really change things. 
Dan
Roku Stick (3600), Ultra (4640), Premiere (3920), Insignia 720p Roku TV, Sharp 4K Roku TV, Nvidia Shield, Windows 10 Pro x64 running Serviio and Plex on a wired Gigabit network.
0 Kudos
LouHosman
Level 7

Re: Roku Express had excellent wifi, loses internet

"atc98092" wrote:
Sometimes with WiFi just moving the device a few inches can make a marked difference in connection. In particular, try moving it a little further away from the TV, and maybe higher or lower from its current position. At 2.4 GHz, the radio wavelength is quite small (we're talking under 5 inches), so placement can really change things. 

Thanks,  but it's not the wireless signal, which is always good.  My Express isn't more than 20 feet away from my router.  When I run the network check, the signal always gets a green checkmark right away, but the internet check fails.  For some reason, it just refuses to recognize the internet connection.  
0 Kudos
atc98092
Level 16

Re: Roku Express had excellent wifi, loses internet

Sorry, overlooked that part.  Smiley Surprisedops: You might try a Network Connection Reset. It's somewhere in the Settings menu, under advanced settings if I remember correctly. This dumps all stored network connection information so you can try again with a clean slate. But yes, it could be defective as well. 
Dan
Roku Stick (3600), Ultra (4640), Premiere (3920), Insignia 720p Roku TV, Sharp 4K Roku TV, Nvidia Shield, Windows 10 Pro x64 running Serviio and Plex on a wired Gigabit network.
0 Kudos
Community Manager
Community Manager

Re: Roku Express had excellent wifi, loses internet

@LouHosman

Have you also rebooted your wireless router by unplugging it from power for a minute, then trying to connect again? 

I would recommend contacting your ISP to ensure that your wireless router is broadcasting a 2.4GHz Wi-Fi network, and ask for assistance in changing the wireless broadcast channel on your router. This may help eliminate wireless interference and improve your device's ability to connect. See more here: https://support.roku.com/article/213122277-tips-for-improving-the-wireless-connection-to-your-roku-s...

Please keep us posted! 

Thanks,
Tanner
Tanner D.
Roku Community Manager
0 Kudos
LouHosman
Level 7

Re: Roku Express had excellent wifi, loses internet

"RokuTannerD" wrote:
@LouHosman

Have you also rebooted your wireless router by unplugging it from power for a minute, then trying to connect again? 

I would recommend contacting your ISP to ensure that your wireless router is broadcasting a 2.4GHz Wi-Fi network, and ask for assistance in changing the wireless broadcast channel on your router. This may help eliminate wireless interference and improve your device's ability to connect. See more here: https://support.roku.com/article/213122277-tips-for-improving-the-wireless-connection-to-your-roku-s...

Please keep us posted! 

Thanks,
Tanner

Thanks, yes my router supports 2.4 GHz and 5 GHz.  I have three Roku Expresses and one Streaming Stick+ and they're the only things connected at 2.4; everything else is on the 5 GHz.  This is the only one that has trouble.  It's a BYOD router so I'll have to see if I can change the wireless broadcast channel myself.  
0 Kudos
Community Manager
Community Manager

Re: Roku Express had excellent wifi, loses internet

Thanks for the extra info. If changing the channel doesn't resolve the issue, I'd suggest trying to connect to a different router/AP to see if you encounter the same issue, such as a mobile hotspot. 

Cheers,
Tanner
Tanner D.
Roku Community Manager
0 Kudos
DeannaB
Level 8

Re: Roku Express had excellent wifi, loses internet

I have almost the same issue.

This is an Express+ stick (I think that was the model).  From Walmart with the upgraded remote.  I have an Ultra in the living room that does not have any problems.

WiFi signal is great.    But it seems to randomly lose INTERNET connection.    It seems to happen more when I freshly turn it on.  I am using the usb power so the unit turns off with the tv.   Most of the time the check connection says I have 55Mb bandwidth, but during the times it is losing connection that goes way down to 6Mb or 3Mb in the moments I can connect.   I have used a wifi analytics app on my phone and the signal strength is excellent right next to the stick.   I am on my wifi 5GHz signal.  I don't see any signal conflicts although there are many wifi signals in the area.

The stick says signal strength is excellent, and the channel is 157.  When it first boots up, after the screen with the app appears and the clock in the upper right hand shows (it shows not connected for about 10 seconds).  It then takes about another 15+ seconds for the remote to connect and interact with the device.  Also,  the remote does tend to lose connection from time to time, sometimes associated with the internet disconnect.  I have had to remove the battery from the remote and replace it to get it to reconnect.

I will start watching a service and randomly, but mostly when it is newly turned on, the lost internet connection dialog will appear.   I can wait it out for a couple of minutes, then it will fix itself.  But it will lose connection again for at least the first half-hour of trying to watch it.  But it seems like if I leave it on for an hour or so it keeps the connection.

I have thought I might need to use the ac plug instead of the USB, but to do that I have to unmount the tv to get to the plug.  I had rather not do that if it has no chance of helping.  Or maybe the roku device itself is bad.

Any thoughts or suggestions.

Tags (1)
0 Kudos